- merge review: remove static libraries (#226377)
- merge review: remove comment causing doxygen to emit non-utf output (#226377) - other minor spec cleanups
This commit is contained in:
parent
5310dcb772
commit
6006228646
25
rpm-4.4.2.2-nonutf-comment.patch
Normal file
25
rpm-4.4.2.2-nonutf-comment.patch
Normal file
@ -0,0 +1,25 @@
|
|||||||
|
changeset: 6180:aa5086a15540
|
||||||
|
user: Ralf Corsépius <corsepiu@fedoraproject.org>
|
||||||
|
date: Wed Oct 10 08:37:35 2007 +0200
|
||||||
|
files: build.c
|
||||||
|
description:
|
||||||
|
Kick out polish comment.
|
||||||
|
(transplanted from 6b4e7092bfc65ed7a95f4be20b86db814c6d999c)
|
||||||
|
|
||||||
|
|
||||||
|
diff -r 48dd32feaef5 -r aa5086a15540 build.c
|
||||||
|
--- a/build.c Tue Oct 09 15:47:15 2007 +0300
|
||||||
|
+++ b/build.c Wed Oct 10 08:37:35 2007 +0200
|
||||||
|
@@ -49,11 +49,6 @@ static int checkSpec(rpmts ts, Header h)
|
||||||
|
return rc;
|
||||||
|
}
|
||||||
|
|
||||||
|
-/*
|
||||||
|
- * Kurwa, durni ameryka?ce sobe zawsze my?l?, ?e ca?y ?wiat mówi po
|
||||||
|
- * angielsku...
|
||||||
|
- */
|
||||||
|
-/* XXX this is still a dumb test but at least it's i18n aware */
|
||||||
|
/**
|
||||||
|
*/
|
||||||
|
static int isSpecFile(const char * specfile)
|
||||||
|
|
16
rpm.spec
16
rpm.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 4.4.2.2
|
Version: 4.4.2.2
|
||||||
Release: 1%{?dist}
|
Release: 2%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}.tar.gz
|
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}.tar.gz
|
||||||
@ -17,6 +17,7 @@ Patch4: rpm-4.4.2-devel-autodep.patch
|
|||||||
Patch5: rpm-4.4.2-rpmfc-skip.patch
|
Patch5: rpm-4.4.2-rpmfc-skip.patch
|
||||||
Patch6: rpm-4.4.2.2-matchpathcon.patch
|
Patch6: rpm-4.4.2.2-matchpathcon.patch
|
||||||
Patch7: rpm-4.4.2.1-no-popt.patch
|
Patch7: rpm-4.4.2.1-no-popt.patch
|
||||||
|
Patch8: rpm-4.4.2.2-nonutf-comment.patch
|
||||||
|
|
||||||
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
||||||
# and several different components with their own licenses included...
|
# and several different components with their own licenses included...
|
||||||
@ -139,11 +140,12 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch5 -p1 -b .fcskip
|
%patch5 -p1 -b .fcskip
|
||||||
%patch6 -p1 -b .matchpathcon
|
%patch6 -p1 -b .matchpathcon
|
||||||
%patch7 -p1 -b .no-popt
|
%patch7 -p1 -b .no-popt
|
||||||
|
%patch8 -p1 -b .nonutf-comment
|
||||||
|
|
||||||
# force external popt
|
# force external popt
|
||||||
rm -rf popt/
|
rm -rf popt/
|
||||||
|
|
||||||
# XXX for popt removal and gnueabi patches
|
# XXX for popt removal
|
||||||
autoreconf
|
autoreconf
|
||||||
|
|
||||||
# new buildid-aware debuginfo
|
# new buildid-aware debuginfo
|
||||||
@ -157,7 +159,7 @@ for i in $(find . -name config.guess -o -name config.sub) ; do
|
|||||||
[ -f /usr/lib/rpm/redhat/$(basename $i) ] && %{__rm} -f $i && %{__cp} -fv /usr/lib/rpm/redhat/$(basename $i) $i
|
[ -f /usr/lib/rpm/redhat/$(basename $i) ] && %{__rm} -f $i && %{__cp} -fv /usr/lib/rpm/redhat/$(basename $i) $i
|
||||||
done
|
done
|
||||||
|
|
||||||
# XXX rpm 4.4.2.1 can't be built with %configure due to makefile brokenness
|
# XXX rpm 4.4.2.1 can't be built with %%configure due to makefile brokenness
|
||||||
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
||||||
./configure --prefix=%{_usr} \
|
./configure --prefix=%{_usr} \
|
||||||
--sysconfdir=%{_sysconfdir} \
|
--sysconfdir=%{_sysconfdir} \
|
||||||
@ -209,7 +211,7 @@ cp -p lua/COPYRIGHT COPYRIGHT-lua
|
|||||||
|
|
||||||
# Get rid of unpackaged files
|
# Get rid of unpackaged files
|
||||||
{ cd $RPM_BUILD_ROOT
|
{ cd $RPM_BUILD_ROOT
|
||||||
rm -f .%{_libdir}/lib*.la
|
rm -f .%{_libdir}/lib*.{a,la}
|
||||||
rm -f .%{rpmhome}/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,rpm.*}
|
rm -f .%{rpmhome}/{Specfile.pm,cpanflute,cpanflute2,rpmdiff,rpmdiff.cgi,sql.prov,sql.req,tcl.req,rpm.*}
|
||||||
rm -rf .%{_mandir}/{fr,ko}
|
rm -rf .%{_mandir}/{fr,ko}
|
||||||
rm -f .%{_libdir}/python%{with_python_version}/site-packages/*.{a,la}
|
rm -f .%{_libdir}/python%{with_python_version}/site-packages/*.{a,la}
|
||||||
@ -388,7 +390,6 @@ exit 0
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_includedir}/rpm
|
%{_includedir}/rpm
|
||||||
%{_libdir}/librp*[a-z].so
|
%{_libdir}/librp*[a-z].so
|
||||||
%{_libdir}/librpm*.a
|
|
||||||
%{_mandir}/man8/rpmcache.8*
|
%{_mandir}/man8/rpmcache.8*
|
||||||
%{_mandir}/man8/rpmgraph.8*
|
%{_mandir}/man8/rpmgraph.8*
|
||||||
%{rpmattr} %{rpmhome}/rpmcache
|
%{rpmattr} %{rpmhome}/rpmcache
|
||||||
@ -401,6 +402,11 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 11 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-2
|
||||||
|
- merge review: remove static libraries (#226377)
|
||||||
|
- merge review: remove comment causing doxygen to emit non-utf output (#226377)
|
||||||
|
- other minor spec cleanups
|
||||||
|
|
||||||
* Wed Oct 03 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-1
|
* Wed Oct 03 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-1
|
||||||
- update to 4.4.2.2 final
|
- update to 4.4.2.2 final
|
||||||
- update matchpathcon patch to work better when selinux disabled
|
- update matchpathcon patch to work better when selinux disabled
|
||||||
|
Loading…
Reference in New Issue
Block a user