- create gdb index on debuginfo generation (#617166)
- rpm-build now requires /usr/bin/gdb-add-index for consistent index creation
This commit is contained in:
parent
ac644a005f
commit
5e5b68f3e7
20
rpm-4.8.1-find-debuginfo-gdb-index.patch
Normal file
20
rpm-4.8.1-find-debuginfo-gdb-index.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
commit 9570a7f6af152e2f1e63181ad8a20d12a10e3c5b
|
||||||
|
Author: Tom Tromey <tromey@redhat.com>
|
||||||
|
Date: Mon Aug 9 15:22:51 2010 +0300
|
||||||
|
|
||||||
|
Create GDB index from find-debuginfo if possible (RhBug:617166)
|
||||||
|
- Details in https://fedoraproject.org/wiki/Features/GdbIndex
|
||||||
|
|
||||||
|
diff --git a/scripts/find-debuginfo.sh b/scripts/find-debuginfo.sh
|
||||||
|
index 01456da..3ada962 100644
|
||||||
|
--- a/scripts/find-debuginfo.sh
|
||||||
|
+++ b/scripts/find-debuginfo.sh
|
||||||
|
@@ -207,6 +207,8 @@ while read nlinks inum f; do
|
||||||
|
$strict && exit 2
|
||||||
|
fi
|
||||||
|
|
||||||
|
+ [ -x /usr/bin/gdb-add-index ] && /usr/bin/gdb-add-index "$f" > /dev/null 2>&1
|
||||||
|
+
|
||||||
|
# A binary already copied into /usr/lib/debug doesn't get stripped,
|
||||||
|
# just has its file names collected and adjusted.
|
||||||
|
case "$dn" in
|
9
rpm.spec
9
rpm.spec
@ -21,7 +21,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 4%{?dist}
|
Release: 5%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.8.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.8.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -46,6 +46,7 @@ Patch201: rpm-4.8.0-python-bytecompile.patch
|
|||||||
Patch202: rpm-4.8.0-findlang-localedirs.patch
|
Patch202: rpm-4.8.0-findlang-localedirs.patch
|
||||||
Patch203: rpm-4.8.1-eat-stdin.patch
|
Patch203: rpm-4.8.1-eat-stdin.patch
|
||||||
Patch204: rpm-4.8.1-getoutput-emsg.patch
|
Patch204: rpm-4.8.1-getoutput-emsg.patch
|
||||||
|
Patch205: rpm-4.8.1-find-debuginfo-gdb-index.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
@ -146,6 +147,7 @@ Requires: elfutils >= 0.128 binutils
|
|||||||
Requires: findutils sed grep gawk diffutils file patch >= 2.5
|
Requires: findutils sed grep gawk diffutils file patch >= 2.5
|
||||||
Requires: unzip gzip bzip2 cpio xz
|
Requires: unzip gzip bzip2 cpio xz
|
||||||
Requires: pkgconfig >= 1:0.24
|
Requires: pkgconfig >= 1:0.24
|
||||||
|
Requires: /usr/bin/gdb-add-index
|
||||||
Conflicts: ocaml-runtime < 3.11.1-7
|
Conflicts: ocaml-runtime < 3.11.1-7
|
||||||
|
|
||||||
%description build
|
%description build
|
||||||
@ -198,6 +200,7 @@ packages on a system.
|
|||||||
%patch202 -p1 -b .findlang-localedirs
|
%patch202 -p1 -b .findlang-localedirs
|
||||||
%patch203 -p1 -b .eat-stdin
|
%patch203 -p1 -b .eat-stdin
|
||||||
%patch204 -p1 -b .getoutput-emsg
|
%patch204 -p1 -b .getoutput-emsg
|
||||||
|
%patch205 -p1 -b .find-debuginfo-gdb-index
|
||||||
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
@ -414,6 +417,10 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Aug 10 2010 Panu Matilainen <pmatilai@redhat.com> - 4.8.1-5
|
||||||
|
- create gdb index on debuginfo generation (#617166)
|
||||||
|
- rpm-build now requires /usr/bin/gdb-add-index for consistent index creation
|
||||||
|
|
||||||
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 4.8.1-4
|
* Thu Jul 22 2010 David Malcolm <dmalcolm@redhat.com> - 4.8.1-4
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Features/Python_2.7/MassRebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user