- permit tab as macro argument separator (#467567)
This commit is contained in:
parent
20231bf36b
commit
57f2a13d99
20
rpm-4.6.0-rc1-permit-tab.patch
Normal file
20
rpm-4.6.0-rc1-permit-tab.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
commit 49c515179ac0d34c2bb43bf242b8eb27ff6c11b2
|
||||||
|
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
Date: Sun Oct 19 01:53:03 2008 +0300
|
||||||
|
|
||||||
|
Permit tab as whitespace between macro arguments (rhbz#467567)
|
||||||
|
- another dumb regression from macro handling cleanups
|
||||||
|
|
||||||
|
diff --git a/rpmio/macro.c b/rpmio/macro.c
|
||||||
|
index 1e292c6..d1cbf93 100644
|
||||||
|
--- a/rpmio/macro.c
|
||||||
|
+++ b/rpmio/macro.c
|
||||||
|
@@ -798,7 +798,7 @@ grabArgs(MacroBuf mb, const rpmMacroEntry me, const char * se,
|
||||||
|
char *s = xcalloc((lastc-se)+1, sizeof(*s));
|
||||||
|
memcpy(s, se, (lastc-se));
|
||||||
|
|
||||||
|
- argvSplit(&av, s, " ");
|
||||||
|
+ argvSplit(&av, s, " \t");
|
||||||
|
argvAppend(&argv, av);
|
||||||
|
|
||||||
|
argvFree(av);
|
10
rpm.spec
10
rpm.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.1
|
Release: 0.%{snapver}.2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -32,6 +32,9 @@ Patch2: rpm-4.5.90-gstreamer-provides.patch
|
|||||||
# XXX only create provides for pkgconfig and libtool initially
|
# XXX only create provides for pkgconfig and libtool initially
|
||||||
Patch100: rpm-4.6.x-no-pkgconfig-reqs.patch
|
Patch100: rpm-4.6.x-no-pkgconfig-reqs.patch
|
||||||
|
|
||||||
|
# Patches already in upstream
|
||||||
|
Patch200: rpm-4.6.0-rc1-permit-tab.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.5.90-posttrans.patch
|
Patch300: rpm-4.5.90-posttrans.patch
|
||||||
|
|
||||||
@ -162,6 +165,8 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch2 -p1 -b .gstreamer-prov
|
%patch2 -p1 -b .gstreamer-prov
|
||||||
%patch100 -p1 -b .pkgconfig-deps
|
%patch100 -p1 -b .pkgconfig-deps
|
||||||
|
|
||||||
|
%patch200 -p1 -b .permit-tab
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
|
|
||||||
@ -352,6 +357,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sun Oct 19 2008 Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
- permit tab as macro argument separator (#467567)
|
||||||
|
|
||||||
* Thu Oct 16 2008 Panu Matilainen <pmatilai@redhat.com>
|
* Thu Oct 16 2008 Panu Matilainen <pmatilai@redhat.com>
|
||||||
- update to 4.6.0-rc1
|
- update to 4.6.0-rc1
|
||||||
- fixes #465586, #466597, #465409, #216221, #466503, #466009, #463447...
|
- fixes #465586, #466597, #465409, #216221, #466503, #466009, #463447...
|
||||||
|
Loading…
Reference in New Issue
Block a user