Don't emit perl(main)
This commit is contained in:
parent
2adf657fca
commit
56db760bd7
36
rpm-4.4.2-perlmainprov.patch
Normal file
36
rpm-4.4.2-perlmainprov.patch
Normal file
@ -0,0 +1,36 @@
|
|||||||
|
--- rpm-4.4.2/scripts/perl.prov.main 2006-01-18 11:32:28.000000000 -0500
|
||||||
|
+++ rpm-4.4.2/scripts/perl.prov 2006-01-18 11:32:44.000000000 -0500
|
||||||
|
@@ -121,13 +121,17 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
# not everyone puts the package name of the file as the first
|
||||||
|
- # package name so we report all namespaces as if they were
|
||||||
|
- # provided packages (really ugly).
|
||||||
|
+ # package name so we report all namespaces except some common
|
||||||
|
+ # false positives as if they were provided packages (really ugly).
|
||||||
|
|
||||||
|
if (m/^\s*package\s+([_:a-zA-Z0-9]+)\s*;/) {
|
||||||
|
$package=$1;
|
||||||
|
undef $version;
|
||||||
|
- $require{$package}=undef;
|
||||||
|
+ if ($package eq 'main') {
|
||||||
|
+ undef $package;
|
||||||
|
+ } else {
|
||||||
|
+ $require{$package}=undef;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
# after we found the package name take the first assignment to
|
||||||
|
--- rpm-4.4.2/scripts/perldeps.pl.main 2006-01-18 11:32:37.000000000 -0500
|
||||||
|
+++ rpm-4.4.2/scripts/perldeps.pl 2006-01-18 11:32:44.000000000 -0500
|
||||||
|
@@ -150,6 +150,10 @@
|
||||||
|
return if(exists($self->{'provides_check'}->{$params{'-provide'}}));
|
||||||
|
|
||||||
|
#
|
||||||
|
+ # Skip some common false positives
|
||||||
|
+ return if $params{'-provide'} eq 'main';
|
||||||
|
+
|
||||||
|
+ #
|
||||||
|
# Created dependency object
|
||||||
|
my $dep = new Dependency "provide", $params{-provide};
|
||||||
|
$dep->filename($params{-filename});
|
7
rpm.spec
7
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
|||||||
%define version 4.4.2
|
%define version 4.4.2
|
||||||
Version: %{version}
|
Version: %{version}
|
||||||
%{expand: %%define rpm_version %{version}}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 13
|
Release: 14
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||||
Source1: mono-find-provides
|
Source1: mono-find-provides
|
||||||
@ -43,6 +43,7 @@ Patch14: rpm-4.4.2-cronpath.patch
|
|||||||
Patch15: rpm-4.4.2-mono.patch
|
Patch15: rpm-4.4.2-mono.patch
|
||||||
Patch16: rpm-4.4.2-file-softmagic.patch
|
Patch16: rpm-4.4.2-file-softmagic.patch
|
||||||
Patch17: rpm-4.4.2-no-large-mmap.patch
|
Patch17: rpm-4.4.2-no-large-mmap.patch
|
||||||
|
Patch18: rpm-4.4.2-perlmainprov.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Conflicts: patch < 2.5
|
Conflicts: patch < 2.5
|
||||||
%ifos linux
|
%ifos linux
|
||||||
@ -172,6 +173,7 @@ shell-like rules.
|
|||||||
%patch15 -p1 -b .mono
|
%patch15 -p1 -b .mono
|
||||||
%patch16 -p1 -b .magic
|
%patch16 -p1 -b .magic
|
||||||
%patch17 -p1 -b .no_large_mmap
|
%patch17 -p1 -b .no_large_mmap
|
||||||
|
%patch18 -p1 -b .perlmainprov
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -564,6 +566,9 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Jan 18 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-14
|
||||||
|
- Don't emit perl(main) (#177960)
|
||||||
|
|
||||||
* Wed Jan 11 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-13
|
* Wed Jan 11 2006 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-13
|
||||||
- Don't mmap large files
|
- Don't mmap large files
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user