Don't fail build trying to kill a non-existent process (#1720143)
This commit is contained in:
parent
5965610d18
commit
49f11812bc
@ -0,0 +1,33 @@
|
||||
From c96c622483589256fd4a6925a68eb7a7d67867e5 Mon Sep 17 00:00:00 2001
|
||||
Message-Id: <c96c622483589256fd4a6925a68eb7a7d67867e5.1560419355.git.pmatilai@redhat.com>
|
||||
From: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Thu, 13 Jun 2019 12:41:02 +0300
|
||||
Subject: [PATCH] Don't fail build trying to kill a non-existent process
|
||||
(RhBug:1720143)
|
||||
|
||||
The job killer introduced at 06953879d3e0b1e9a434979056d1225ab4646142
|
||||
failed to take into account the fact that the processes *can* die between
|
||||
us grabbing the pids and actually killing them, and that trying to kill
|
||||
a non-existent process will cause a script running with -e to actually
|
||||
terminate an error. So we end up failing a successful build by trying
|
||||
to kill process that exited on its own, ugh :)
|
||||
---
|
||||
macros.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/macros.in b/macros.in
|
||||
index 724e53a19..50fe044c1 100644
|
||||
--- a/macros.in
|
||||
+++ b/macros.in
|
||||
@@ -816,7 +816,7 @@ package or when debugging this package.\
|
||||
#%___build_body %{nil}
|
||||
%___build_post \
|
||||
RPM_EC=$?\
|
||||
- for pid in $(jobs -p); do kill -9 ${pid}; done\
|
||||
+ for pid in $(jobs -p); do kill -9 ${pid} || continue; done\
|
||||
exit ${RPM_EC}\
|
||||
%{nil}
|
||||
|
||||
--
|
||||
2.21.0
|
||||
|
6
rpm.spec
6
rpm.spec
@ -21,7 +21,7 @@
|
||||
|
||||
%global rpmver 4.14.90
|
||||
%global snapver git14653
|
||||
%global rel 13
|
||||
%global rel 14
|
||||
|
||||
%global srcver %{version}%{?snapver:-%{snapver}}
|
||||
%global srcdir %{?snapver:testing}%{!?snapver:%{name}-%(echo %{version} | cut -d'.' -f1-2).x}
|
||||
@ -55,6 +55,7 @@ Patch7: 0001-Only-permit-one-thread-at-a-time-in-addFileToTag.patch
|
||||
Patch8: 0001-build-Limit-copying-changelog-one-at-a-time.patch
|
||||
|
||||
# Patches already upstream:
|
||||
Patch100: 0001-Don-t-fail-build-trying-to-kill-a-non-existent-proce.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch906: rpm-4.7.1-geode-i686.patch
|
||||
@ -541,6 +542,9 @@ make check || (cat tests/rpmtests.log; exit 0)
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 13 2019 Panu Matilainen <pmatilai@redhat.com> - 4.14.90-0.git14653.14
|
||||
- Don't fail build trying to kill a non-existent process (#1720143)
|
||||
|
||||
* Tue Jun 11 14:59:16 CEST 2019 Igor Gnatenko <ignatenkobrain@fedoraproject.org> - 4.14.90-0.git14653.13
|
||||
- Fix build of binary packages in parallel
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user