parent
b08bb75da3
commit
44ada860a5
20
rpm-4.16.1.3-rpmsign-support-EdDSA-sig.patch
Normal file
20
rpm-4.16.1.3-rpmsign-support-EdDSA-sig.patch
Normal file
@ -0,0 +1,20 @@
|
|||||||
|
commit 23770e1a4f28c56a31fe600cae332c77333b60b6
|
||||||
|
Author: Demi Marie Obenour <athena@invisiblethingslab.com>
|
||||||
|
Date: Sat Mar 6 03:23:41 2021 -0500
|
||||||
|
|
||||||
|
rpmsign: support EdDSA signatures
|
||||||
|
|
||||||
|
They were previously rejected
|
||||||
|
|
||||||
|
diff --git a/sign/rpmgensig.c b/sign/rpmgensig.c
|
||||||
|
index 28cd91576..d8c84e937 100644
|
||||||
|
--- a/sign/rpmgensig.c
|
||||||
|
+++ b/sign/rpmgensig.c
|
||||||
|
@@ -155,6 +155,7 @@ static rpmtd makeSigTag(Header sigh, int ishdr, uint8_t *pkt, size_t pktlen)
|
||||||
|
pubkey_algo = pgpDigParamsAlgo(sigp, PGPVAL_PUBKEYALGO);
|
||||||
|
switch (pubkey_algo) {
|
||||||
|
case PGPPUBKEYALGO_DSA:
|
||||||
|
+ case PGPPUBKEYALGO_EDDSA:
|
||||||
|
sigtag = ishdr ? RPMSIGTAG_DSA : RPMSIGTAG_GPG;
|
||||||
|
break;
|
||||||
|
case PGPPUBKEYALGO_RSA:
|
6
rpm.spec
6
rpm.spec
@ -32,7 +32,7 @@
|
|||||||
|
|
||||||
%global rpmver 4.16.1.3
|
%global rpmver 4.16.1.3
|
||||||
#global snapver rc1
|
#global snapver rc1
|
||||||
%global rel 3
|
%global rel 4
|
||||||
%global sover 9
|
%global sover 9
|
||||||
|
|
||||||
%global srcver %{rpmver}%{?snapver:-%{snapver}}
|
%global srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||||
@ -69,6 +69,7 @@ Patch7: 0001-Issue-deprecation-warning-when-creating-BDB-database.patch
|
|||||||
|
|
||||||
# Patches already upstream:
|
# Patches already upstream:
|
||||||
Patch100: rpm-4.16.1.3-imp-covscan-fixes.patch
|
Patch100: rpm-4.16.1.3-imp-covscan-fixes.patch
|
||||||
|
Patch101: rpm-4.16.1.3-rpmsign-support-EdDSA-sig.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch906: rpm-4.7.1-geode-i686.patch
|
Patch906: rpm-4.7.1-geode-i686.patch
|
||||||
@ -579,6 +580,9 @@ fi
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jul 22 2021 Michal Domonkos <mdomonko@redhat.com> - 4.16.1.3-4
|
||||||
|
- Add support for EdDSA signatures to rpmsign (#1962234)
|
||||||
|
|
||||||
* Mon Jul 12 2021 Michal Domonkos <mdomonko@redhat.com> - 4.16.1.3-3
|
* Mon Jul 12 2021 Michal Domonkos <mdomonko@redhat.com> - 4.16.1.3-3
|
||||||
- Release bump for a rebuild
|
- Release bump for a rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user