- add back defaultdocdir patch which hadn't been applied on 4.6.x branch
yet
This commit is contained in:
parent
afa5773d1d
commit
43b33fef16
45
rpm-4.6.0-rc1-defaultdocdir.patch
Normal file
45
rpm-4.6.0-rc1-defaultdocdir.patch
Normal file
@ -0,0 +1,45 @@
|
|||||||
|
commit 927f384a9bc058eb6f954e93cc515cc1293fd2a3
|
||||||
|
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
Date: Fri Oct 17 08:11:10 2008 +0300
|
||||||
|
|
||||||
|
Kick out the dumb defaultdocdir logic from installplatform
|
||||||
|
- defaultdocdir is simply %{_datadir}/doc
|
||||||
|
|
||||||
|
diff --git a/installplatform b/installplatform
|
||||||
|
index 8861df0..266d877 100755
|
||||||
|
--- a/installplatform
|
||||||
|
+++ b/installplatform
|
||||||
|
@@ -8,12 +8,6 @@ RPMRC="${1:-rpmrc}"
|
||||||
|
MACROS="${2:-macros}"
|
||||||
|
PLATFORM="${3:-platform}"
|
||||||
|
|
||||||
|
-if grep /share/ $PLATFORM > /dev/null 2>&1 ; then
|
||||||
|
- DEFAULTDOCDIR='%{_usr}/share/doc'
|
||||||
|
-else
|
||||||
|
- DEFAULTDOCDIR='%{_usr}/doc'
|
||||||
|
-fi
|
||||||
|
-
|
||||||
|
TEMPRC="/tmp/rpmrc.$$"
|
||||||
|
cat << E_O_F > $TEMPRC
|
||||||
|
include: $RPMRC
|
||||||
|
@@ -155,7 +149,6 @@ for SUBST in $SUBSTS ; do
|
||||||
|
-e "s,@RPMRC_GNU@,$RPMRC_GNU," \
|
||||||
|
-e "s,@LIB@,$LIB," \
|
||||||
|
-e "s,@ARCH_INSTALL_POST@,$ARCH_INSTALL_POST," \
|
||||||
|
- -e "s,@DEFAULTDOCDIR@,$DEFAULTDOCDIR," \
|
||||||
|
-e '/\${\w*:-/!s,\${,%{_,' \
|
||||||
|
-e "s,@ISANAME@,$ISANAME," \
|
||||||
|
-e "s,@ISABITS@,$ISABITS," \
|
||||||
|
diff --git a/platform.in b/platform.in
|
||||||
|
index 4b496a0..9768a8a 100644
|
||||||
|
--- a/platform.in
|
||||||
|
+++ b/platform.in
|
||||||
|
@@ -37,7 +37,7 @@
|
||||||
|
# Deprecated misspelling, present for backwards compatibility.
|
||||||
|
%_initrddir %{_initddir}
|
||||||
|
|
||||||
|
-%_defaultdocdir @DEFAULTDOCDIR@
|
||||||
|
+%_defaultdocdir %{_datadir}/doc
|
||||||
|
|
||||||
|
%_smp_mflags %([ -z "$RPM_BUILD_NCPUS" ] \\\
|
||||||
|
&& RPM_BUILD_NCPUS="`/usr/bin/getconf _NPROCESSORS_ONLN`"; \\\
|
9
rpm.spec
9
rpm.spec
@ -18,7 +18,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 0.%{snapver}.1%{?dist}
|
Release: 0.%{snapver}.2%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -31,6 +31,7 @@ Patch1: rpm-4.5.90-pkgconfig-path.patch
|
|||||||
Patch2: rpm-4.5.90-gstreamer-provides.patch
|
Patch2: rpm-4.5.90-gstreamer-provides.patch
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
|
Patch200: rpm-4.6.0-rc1-defaultdocdir.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.5.90-posttrans.patch
|
Patch300: rpm-4.5.90-posttrans.patch
|
||||||
@ -164,6 +165,9 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch1 -p1 -b .pkgconfig-path
|
%patch1 -p1 -b .pkgconfig-path
|
||||||
%patch2 -p1 -b .gstreamer-prov
|
%patch2 -p1 -b .gstreamer-prov
|
||||||
|
|
||||||
|
# upstream but not on 4.6.x branch yet, oops
|
||||||
|
%patch200 -p1 -b .defaultdocdir
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
|
|
||||||
@ -353,6 +357,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 12 2008 Panu Matilainen <pmatilai@redhat.com> - 4.6.0-0.rc3.2
|
||||||
|
- add back defaultdocdir patch which hadn't been applied on 4.6.x branch yet
|
||||||
|
|
||||||
* Fri Dec 12 2008 Panu Matilainen <pmatilai@redhat.com> - 4.6.0-0.rc3.1
|
* Fri Dec 12 2008 Panu Matilainen <pmatilai@redhat.com> - 4.6.0-0.rc3.1
|
||||||
- add dist-tag, rebuild
|
- add dist-tag, rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user