Do not process build-ids for noarch packages.
This commit is contained in:
parent
03607fe128
commit
434eb9a375
41
0017-do-not-process-buildi-ds-for-noarch.patch
Normal file
41
0017-do-not-process-buildi-ds-for-noarch.patch
Normal file
@ -0,0 +1,41 @@
|
|||||||
|
From d406bde3e914cae2d794bbaab66aad6b7038b30e Mon Sep 17 00:00:00 2001
|
||||||
|
From: Mark Wielaard <mark@klomp.org>
|
||||||
|
Date: Fri, 17 Mar 2017 10:51:36 +0100
|
||||||
|
Subject: [PATCH] build/files.c (processPackageFiles): Don't call
|
||||||
|
generateBuildIDs for noarch.
|
||||||
|
|
||||||
|
We don't want to do build-id processing for noarch packages. It might be
|
||||||
|
that noarch packages do contain architecture depended files, but those are
|
||||||
|
already handled by processBinaryFiles.
|
||||||
|
|
||||||
|
Signed-off-by: Mark Wielaard <mark@klomp.org>
|
||||||
|
---
|
||||||
|
build/files.c | 12 ++++++++----
|
||||||
|
1 file changed, 8 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/build/files.c b/build/files.c
|
||||||
|
index 6021643..35b2dd0 100644
|
||||||
|
--- a/build/files.c
|
||||||
|
+++ b/build/files.c
|
||||||
|
@@ -2384,10 +2384,14 @@ static rpmRC processPackageFiles(rpmSpec spec, rpmBuildPkgFlags pkgFlags,
|
||||||
|
goto exit;
|
||||||
|
|
||||||
|
#if HAVE_LIBDW
|
||||||
|
- if (generateBuildIDs (&fl) != 0) {
|
||||||
|
- rpmlog(RPMLOG_ERR, _("Generating build-id links failed\n"));
|
||||||
|
- fl.processingFailed = 1;
|
||||||
|
- goto exit;
|
||||||
|
+ /* Check build-ids and add build-ids links for files to package list. */
|
||||||
|
+ const char *arch = headerGetString(pkg->header, RPMTAG_ARCH);
|
||||||
|
+ if (!rstreq(arch, "noarch")) {
|
||||||
|
+ if (generateBuildIDs (&fl) != 0) {
|
||||||
|
+ rpmlog(RPMLOG_ERR, _("Generating build-id links failed\n"));
|
||||||
|
+ fl.processingFailed = 1;
|
||||||
|
+ goto exit;
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
#endif
|
||||||
|
|
||||||
|
--
|
||||||
|
1.8.3.1
|
||||||
|
|
6
rpm.spec
6
rpm.spec
@ -29,7 +29,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}10%{?dist}
|
Release: %{?snapver:0.%{snapver}.}11%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/%{srcdir}/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/%{srcdir}/%{name}-%{srcver}.tar.bz2
|
||||||
@ -88,6 +88,7 @@ Patch262: 0013-missing_build_ids_terminate_build.patch
|
|||||||
Patch263: 0014-generateBuildIDs-Fix-error-handling.patch
|
Patch263: 0014-generateBuildIDs-Fix-error-handling.patch
|
||||||
Patch264: 0015-reset-buildid-file-attrs.patch
|
Patch264: 0015-reset-buildid-file-attrs.patch
|
||||||
Patch265: 0016-debugedit-replace-files.patch
|
Patch265: 0016-debugedit-replace-files.patch
|
||||||
|
Patch266: 0017-do-not-process-buildi-ds-for-noarch.patch
|
||||||
|
|
||||||
# OpenSSL backend
|
# OpenSSL backend
|
||||||
Patch300: 0001-Add-OpenSSL-support-for-digest-and-signatures.patch
|
Patch300: 0001-Add-OpenSSL-support-for-digest-and-signatures.patch
|
||||||
@ -592,6 +593,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 17 2017 Mark Wielaard <mjw@redhat.com> - 4.13.0.1-11
|
||||||
|
- Do not process build-ids for noarch packages.
|
||||||
|
|
||||||
* Thu Mar 16 2017 Mark Wielaard <mjw@redhat.com> - 4.13.0.1-10
|
* Thu Mar 16 2017 Mark Wielaard <mjw@redhat.com> - 4.13.0.1-10
|
||||||
- Add fix for debugedit replace debug_line files.
|
- Add fix for debugedit replace debug_line files.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user