- 4.4.2.1 final
- reintroduce disttag - include full ChangeLog as doc - use up-to-date config.guess for ARM support (#246803) - ARM EANBI gnu/gnuenabi fix from Lennert Buytenhek (#246803)
This commit is contained in:
parent
f12c39dd5d
commit
39d0260c4f
44
rpm-4.4.2.1-gnueabi.patch
Normal file
44
rpm-4.4.2.1-gnueabi.patch
Normal file
@ -0,0 +1,44 @@
|
|||||||
|
diff -up rpm-4.4.2.1-rc3/configure.ac.orig rpm-4.4.2.1-rc3/configure.ac
|
||||||
|
--- rpm-4.4.2.1-rc3/configure.ac.orig 2007-07-21 15:11:25.000000000 -0400
|
||||||
|
+++ rpm-4.4.2.1-rc3/configure.ac 2007-07-21 15:12:04.000000000 -0400
|
||||||
|
@@ -1132,11 +1132,13 @@ fi
|
||||||
|
#
|
||||||
|
# get rid of the 4-th tuple, if config.guess returned "linux-gnu" for build_os
|
||||||
|
#
|
||||||
|
+build_os_gnu=-gnu
|
||||||
|
if echo "$build_os" | grep '.*-gnulibc1' > /dev/null ; then
|
||||||
|
build_os=`echo "${build_os}" | sed 's/-gnulibc1$//'`
|
||||||
|
fi
|
||||||
|
if echo "$build_os" | grep '.*-gnueabi' > /dev/null ; then
|
||||||
|
build_os=`echo "${build_os}" | sed 's/-gnueabi$//'`
|
||||||
|
+ build_os_gnu=-gnueabi
|
||||||
|
fi
|
||||||
|
if echo "$build_os" | grep '.*-gnu' > /dev/null ; then
|
||||||
|
build_os=`echo "${build_os}" | sed 's/-gnu$//'`
|
||||||
|
@@ -1231,12 +1233,14 @@ unknown|pc|ibm|redhat|pld|mandrake|conec
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
RPMCANONOS="$build_os_noversion"
|
||||||
|
+RPMCANONGNU="$build_os_gnu"
|
||||||
|
AC_SUBST(RPMCANONCOLOR)
|
||||||
|
AC_SUBST(autorelocate_path)
|
||||||
|
AC_SUBST(autorelocate_dcolor)
|
||||||
|
AC_SUBST(RPMCANONARCH)
|
||||||
|
AC_SUBST(RPMCANONVENDOR)
|
||||||
|
AC_SUBST(RPMCANONOS)
|
||||||
|
+AC_SUBST(RPMCANONGNU)
|
||||||
|
|
||||||
|
if test X"$prefix" = XNONE ; then
|
||||||
|
usrprefix="$ac_default_prefix"
|
||||||
|
diff -up rpm-4.4.2.1-rc3/macros.in.orig rpm-4.4.2.1-rc3/macros.in
|
||||||
|
--- rpm-4.4.2.1-rc3/macros.in.orig 2007-07-21 15:12:13.000000000 -0400
|
||||||
|
+++ rpm-4.4.2.1-rc3/macros.in 2007-07-21 15:12:32.000000000 -0400
|
||||||
|
@@ -819,7 +819,7 @@ print (t)\
|
||||||
|
%_build_arch @RPMCANONARCH@
|
||||||
|
%_vendor @RPMCANONVENDOR@
|
||||||
|
%_os @RPMCANONOS@
|
||||||
|
-%_gnu -gnu
|
||||||
|
+%_gnu @RPMCANONGNU@
|
||||||
|
%_target_platform %{_target_cpu}-%{_vendor}-%{_target_os}%{?_gnu}
|
||||||
|
|
||||||
|
#
|
21
rpm.spec
21
rpm.spec
@ -13,8 +13,8 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 4.4.2.1
|
Version: 4.4.2.1
|
||||||
%{expand: %%define rpm_version %{version}-rc3}
|
%{expand: %%define rpm_version %{version}}
|
||||||
Release: 0.6.rc3
|
Release: 1%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source: rpm-%{rpm_version}.tar.gz
|
Source: rpm-%{rpm_version}.tar.gz
|
||||||
@ -28,6 +28,7 @@ Patch7: rpm-4.4.2.1-checksignals.patch
|
|||||||
Patch8: rpm-4.4.2.1-checkterminate.patch
|
Patch8: rpm-4.4.2.1-checkterminate.patch
|
||||||
Patch9: rpm-4.4.2.1-python-exithook.patch
|
Patch9: rpm-4.4.2.1-python-exithook.patch
|
||||||
Patch10: rpm-4.4.2.1-checkterminate-noexit.patch
|
Patch10: rpm-4.4.2.1-checkterminate-noexit.patch
|
||||||
|
Patch11: rpm-4.4.2.1-gnueabi.patch
|
||||||
License: GPL
|
License: GPL
|
||||||
Requires(pre): shadow-utils
|
Requires(pre): shadow-utils
|
||||||
Requires(postun): shadow-utils
|
Requires(postun): shadow-utils
|
||||||
@ -142,6 +143,7 @@ shell-like rules.
|
|||||||
%patch8 -p1 -b .checkterminate
|
%patch8 -p1 -b .checkterminate
|
||||||
%patch9 -p1 -b .py-exithook
|
%patch9 -p1 -b .py-exithook
|
||||||
%patch10 -p1 -b .checkterminate-noexit
|
%patch10 -p1 -b .checkterminate-noexit
|
||||||
|
%patch11 -p1 -b .gnueabi
|
||||||
|
|
||||||
%build
|
%build
|
||||||
|
|
||||||
@ -150,6 +152,12 @@ unset LD_ASSUME_KERNEL || :
|
|||||||
|
|
||||||
WITH_PYTHON="--with-python=%{with_python_version}"
|
WITH_PYTHON="--with-python=%{with_python_version}"
|
||||||
|
|
||||||
|
# XXX pull in updated config.guess and config.sub as done by %configure
|
||||||
|
# which cannot be used to build rpm itself due to makefile brokenness
|
||||||
|
for i in $(find . -name config.guess -o -name config.sub) ; do
|
||||||
|
[ -f /usr/lib/rpm/redhat/$(basename $i) ] && %{__rm} -f $i && %{__cp} -fv /usr/lib/rpm/redhat/$(basename $i) $i
|
||||||
|
done
|
||||||
|
|
||||||
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
CFLAGS="$RPM_OPT_FLAGS"; export CFLAGS
|
||||||
./configure --prefix=%{__prefix} --sysconfdir=/etc \
|
./configure --prefix=%{__prefix} --sysconfdir=/etc \
|
||||||
--localstatedir=/var --infodir='${prefix}%{__share}/info' \
|
--localstatedir=/var --infodir='${prefix}%{__share}/info' \
|
||||||
@ -267,7 +275,7 @@ exit 0
|
|||||||
|
|
||||||
%files -f %{name}.lang
|
%files -f %{name}.lang
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%doc CHANGES GROUPS COPYING LICENSE-bdb LEGAL.NOTICE-file CREDITS
|
%doc CHANGES GROUPS COPYING LICENSE-bdb LEGAL.NOTICE-file CREDITS ChangeLog
|
||||||
%doc doc/manual/[a-z]*
|
%doc doc/manual/[a-z]*
|
||||||
%attr(0755, rpm, rpm) /bin/rpm
|
%attr(0755, rpm, rpm) /bin/rpm
|
||||||
|
|
||||||
@ -438,6 +446,13 @@ exit 0
|
|||||||
%{__includedir}/popt.h
|
%{__includedir}/popt.h
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 23 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.1-1
|
||||||
|
- 4.4.2.1 final
|
||||||
|
- reintroduce disttag
|
||||||
|
- include full ChangeLog as doc
|
||||||
|
- use up-to-date config.guess for ARM support (#246803)
|
||||||
|
- ARM EANBI gnu/gnuenabi fix from Lennert Buytenhek (#246803)
|
||||||
|
|
||||||
* Sat Jul 21 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.1-0.6.rc3
|
* Sat Jul 21 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.1-0.6.rc3
|
||||||
- dont mess up python exit codes
|
- dont mess up python exit codes
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user