- merge ppc64p7 related fixes that only went into f17 (#835978)
This commit is contained in:
parent
7f2e4e1cba
commit
31171a2dbd
32
rpm-4.10.0-ppc64p7-fixes.patch
Normal file
32
rpm-4.10.0-ppc64p7-fixes.patch
Normal file
@ -0,0 +1,32 @@
|
||||
diff --git a/lib/rpmrc.c b/lib/rpmrc.c
|
||||
index ba156fe..96f05ce 100644
|
||||
--- a/lib/rpmrc.c
|
||||
+++ b/lib/rpmrc.c
|
||||
@@ -1093,8 +1093,11 @@ static void defaultMachine(const char ** arch,
|
||||
# if defined(__linux__) && defined(__powerpc__)
|
||||
{
|
||||
int powerlvl;
|
||||
- if (sscanf(rpmat.platform, "power%d", &powerlvl) == 1 && powerlvl > 6)
|
||||
+ if (!rstreq(un.machine, "ppc") &&
|
||||
+ sscanf(rpmat.platform, "power%d", &powerlvl) == 1 &&
|
||||
+ powerlvl > 6) {
|
||||
strcpy(un.machine, "ppc64p7");
|
||||
+ }
|
||||
}
|
||||
# endif /* ppc64*-linux */
|
||||
|
||||
diff --git a/macros.in b/macros.in
|
||||
index 4c77bbb..4a4a1e4 100644
|
||||
--- a/macros.in
|
||||
+++ b/macros.in
|
||||
@@ -998,6 +998,10 @@ done \
|
||||
# arch macro for all supported Alpha processors
|
||||
%alpha alpha alphaev56 alphaev6 alphaev67
|
||||
|
||||
+#------------------------------------------------------------------------------
|
||||
+# arch macro for all supported PowerPC 64 processors
|
||||
+%power64 ppc64 ppc64p7
|
||||
+
|
||||
#------------------------------------------------------------------------
|
||||
# Use in %install to generate locale specific file lists. For example,
|
||||
#
|
8
rpm.spec
8
rpm.spec
@ -21,7 +21,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}3%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}4%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.10.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -45,6 +45,7 @@ Patch5: rpm-4.9.90-armhfp.patch
|
||||
Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||
|
||||
# Patches already in upstream
|
||||
Patch100: rpm-4.10.0-ppc64p7-fixes.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -218,6 +219,8 @@ packages on a system.
|
||||
%patch3 -p1 -b .no-man-dirs
|
||||
%patch4 -p1 -b .use-gpg2
|
||||
|
||||
%patch100 -p1 -b .ppc647p-fixes
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
%patch304 -p1 -b .ldflags
|
||||
@ -445,6 +448,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Jun 28 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.0-4
|
||||
- merge ppc64p7 related fixes that only went into f17 (#835978)
|
||||
|
||||
* Wed Jun 27 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.0-3
|
||||
- add support for minidebuginfo generation (#834073)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user