- Fix new rich dependency syntax
This commit is contained in:
parent
72ba7dafee
commit
2e60cb3797
35
rpm-4.13.0-rc1-Fix-new-richdep-syntax.patch
Normal file
35
rpm-4.13.0-rc1-Fix-new-richdep-syntax.patch
Normal file
@ -0,0 +1,35 @@
|
|||||||
|
From d20b7d2b00e349610f3cf08d9ff3723cc7c56e32 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Festi <ffesti@redhat.com>
|
||||||
|
Date: Mon, 7 Sep 2015 11:39:36 +0200
|
||||||
|
Subject: [PATCH] Fix rpmrichOpStr to use the new syntax
|
||||||
|
|
||||||
|
You need to rebuild all packages using rich deps build with previous versions of rpm as the richdeps are converted to the old syntax.
|
||||||
|
---
|
||||||
|
lib/rpmds.c | 8 ++++----
|
||||||
|
1 file changed, 4 insertions(+), 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/lib/rpmds.c b/lib/rpmds.c
|
||||||
|
index 77733bc..ba6e244 100644
|
||||||
|
--- a/lib/rpmds.c
|
||||||
|
+++ b/lib/rpmds.c
|
||||||
|
@@ -1390,13 +1390,13 @@ const char *rpmrichOpStr(rpmrichOp op)
|
||||||
|
if (op == RPMRICHOP_SINGLE)
|
||||||
|
return "SINGLE";
|
||||||
|
if (op == RPMRICHOP_AND)
|
||||||
|
- return "&";
|
||||||
|
+ return "and";
|
||||||
|
if (op == RPMRICHOP_OR)
|
||||||
|
- return "|";
|
||||||
|
+ return "or";
|
||||||
|
if (op == RPMRICHOP_IF)
|
||||||
|
- return "IF";
|
||||||
|
+ return "if";
|
||||||
|
if (op == RPMRICHOP_ELSE)
|
||||||
|
- return "ELSE";
|
||||||
|
+ return "else";
|
||||||
|
return NULL;
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
2.1.0
|
||||||
|
|
7
rpm.spec
7
rpm.spec
@ -29,7 +29,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
Release: %{?snapver:0.%{snapver}.}3%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -52,6 +52,7 @@ Patch4: rpm-4.8.1-use-gpg2.patch
|
|||||||
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
Patch5: rpm-4.12.0-rpm2cpio-hack.patch
|
||||||
|
|
||||||
# Patches already upstream:
|
# Patches already upstream:
|
||||||
|
Patch100: rpm-4.13.0-rc1-Fix-new-richdep-syntax.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch302: rpm-4.7.1-geode-i686.patch
|
Patch302: rpm-4.7.1-geode-i686.patch
|
||||||
@ -554,6 +555,10 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
|
||||||
|
* Mon Sep 07 2015 Florian Festi <ffesti@rpm.org> - 4.4.13.0-0.rc1.3
|
||||||
|
- Fix new rich dependency syntax
|
||||||
|
|
||||||
* Sat Sep 05 2015 Kalev Lember <klember@redhat.com> - 4.13.0-0.rc1.2
|
* Sat Sep 05 2015 Kalev Lember <klember@redhat.com> - 4.13.0-0.rc1.2
|
||||||
- Obsolete compat-librpm3
|
- Obsolete compat-librpm3
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user