- fix double-free on %caps in spec (#877512)
This commit is contained in:
parent
93c12c40a9
commit
2d4d8e8284
21
rpm-4.10.90-caps-free.patch
Normal file
21
rpm-4.10.90-caps-free.patch
Normal file
@ -0,0 +1,21 @@
|
|||||||
|
commit 34df9d81d15b596ea6f3f3f2e15bd0ec55323a19
|
||||||
|
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
Date: Sat Nov 17 17:57:59 2012 +0200
|
||||||
|
|
||||||
|
Fix double-free on %caps in spec (RhBug:877512)
|
||||||
|
|
||||||
|
- Fixes regression caused by dumb refactoring mistake in commit
|
||||||
|
807ba93a6cf168410e3801347898949f356fcd6c
|
||||||
|
|
||||||
|
diff --git a/build/files.c b/build/files.c
|
||||||
|
index d299cb9..10d7fff 100644
|
||||||
|
--- a/build/files.c
|
||||||
|
+++ b/build/files.c
|
||||||
|
@@ -216,7 +216,6 @@ static void FileEntryFree(FileEntry entry)
|
||||||
|
{
|
||||||
|
freeAttrRec(&(entry->ar));
|
||||||
|
argvFree(entry->langs);
|
||||||
|
- free(entry->caps);
|
||||||
|
memset(entry, 0, sizeof(*entry));
|
||||||
|
}
|
||||||
|
|
8
rpm.spec
8
rpm.spec
@ -22,7 +22,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}1%{?dist}
|
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||||
@ -46,6 +46,7 @@ Patch5: rpm-4.9.90-armhfp.patch
|
|||||||
Patch6: rpm-4.9.0-armhfp-logic.patch
|
Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||||
|
|
||||||
# Patches already in upstream
|
# Patches already in upstream
|
||||||
|
Patch100: rpm-4.10.90-caps-free.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
@ -219,6 +220,8 @@ packages on a system.
|
|||||||
%patch3 -p1 -b .no-man-dirs
|
%patch3 -p1 -b .no-man-dirs
|
||||||
%patch4 -p1 -b .use-gpg2
|
%patch4 -p1 -b .use-gpg2
|
||||||
|
|
||||||
|
%patch100 -p1 -b .caps-free
|
||||||
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
%patch304 -p1 -b .ldflags
|
%patch304 -p1 -b .ldflags
|
||||||
@ -449,6 +452,9 @@ exit 0
|
|||||||
%doc COPYING doc/librpm/html/*
|
%doc COPYING doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Nov 17 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.90-0.git11989.2
|
||||||
|
- fix double-free on %caps in spec (#877512)
|
||||||
|
|
||||||
* Thu Nov 15 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.90-0.git11989.1
|
* Thu Nov 15 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.90-0.git11989.1
|
||||||
- update to 4.11 (http://rpm.org/wiki/Releases/4.11.0) post-alpha snapshot
|
- update to 4.11 (http://rpm.org/wiki/Releases/4.11.0) post-alpha snapshot
|
||||||
- drop/adjust patches as necessary
|
- drop/adjust patches as necessary
|
||||||
|
Loading…
Reference in New Issue
Block a user