New version
This commit is contained in:
parent
c7fc8fdba6
commit
2c259d0d36
28
rpm-4.4.2-ghost-conflicts.patch
Normal file
28
rpm-4.4.2-ghost-conflicts.patch
Normal file
@ -0,0 +1,28 @@
|
||||
--- rpm-4.4.2/lib/transaction.c.ghostconflicts 2005-06-11 15:37:34.000000000 -0400
|
||||
+++ rpm-4.4.2/lib/transaction.c 2005-11-28 13:25:25.000000000 -0500
|
||||
@@ -165,6 +165,7 @@
|
||||
for (i = 0; i < sharedCount; i++, shared++) {
|
||||
int otherFileNum, fileNum;
|
||||
int isCfgFile;
|
||||
+ int isGhostFile;
|
||||
|
||||
otherFileNum = shared->otherFileNum;
|
||||
(void) rpmfiSetFX(otherFi, otherFileNum);
|
||||
@@ -177,6 +178,7 @@
|
||||
FColor &= tscolor;
|
||||
|
||||
isCfgFile = ((rpmfiFFlags(otherFi) | rpmfiFFlags(fi)) & RPMFILE_CONFIG);
|
||||
+ isGhostFile = ((rpmfiFFlags(otherFi) & RPMFILE_GHOST) && (rpmfiFFlags(fi) & RPMFILE_GHOST));
|
||||
|
||||
#ifdef DYING
|
||||
/* XXX another tedious segfault, assume file state normal. */
|
||||
@@ -187,6 +189,9 @@
|
||||
if (XFA_SKIPPING(fi->actions[fileNum]))
|
||||
continue;
|
||||
|
||||
+ if (isGhostFile)
|
||||
+ continue;
|
||||
+
|
||||
if (rpmfiCompare(otherFi, fi)) {
|
||||
int rConflicts;
|
||||
|
110
rpm-4.4.2-popt-charset.patch
Normal file
110
rpm-4.4.2-popt-charset.patch
Normal file
@ -0,0 +1,110 @@
|
||||
--- rpm-4.4.2/popt/po/de.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/de.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/zh.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/zh.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/ja.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/ja.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/es.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/es.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: Leandro Lucarella <luca@linuxmendoza.org.ar>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/eu_ES.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/eu_ES.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/fi.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/fi.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/sr.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/sr.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/pt_BR.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/pt_BR.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/it.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/it.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
||||
--- rpm-4.4.2/popt/po/id.po.charset 2005-11-28 11:30:54.000000000 -0500
|
||||
+++ rpm-4.4.2/popt/po/id.po 2005-11-28 11:31:19.000000000 -0500
|
||||
@@ -12,7 +12,7 @@
|
||||
"Last-Translator: FULL NAME <EMAIL@ADDRESS>\n"
|
||||
"Language-Team: LANGUAGE <LL@li.org>\n"
|
||||
"MIME-Version: 1.0\n"
|
||||
-"Content-Type: text/plain; charset=CHARSET\n"
|
||||
+"Content-Type: text/plain; charset=UTF-8\n"
|
||||
"Content-Transfer-Encoding: ENCODING\n"
|
||||
|
||||
#: popt.c:35
|
13
rpm.spec
13
rpm.spec
@ -20,7 +20,7 @@ Name: rpm
|
||||
%define version 4.4.2
|
||||
Version: %{version}
|
||||
%{expand: %%define rpm_version %{version}}
|
||||
Release: 7
|
||||
Release: 8
|
||||
Group: System Environment/Base
|
||||
Source: ftp://wraptastic.org/pub/rpm-4.4.x/rpm-%{rpm_version}.tar.gz
|
||||
Patch0: rpm-4.4.1-hkp-disable.patch
|
||||
@ -33,6 +33,8 @@ Patch6: rpm-4.4.2-matchpathcon.patch
|
||||
Patch7: rpm-4.4.2-perlreq.patch
|
||||
Patch8: rpm-4.4.2-db3-param.patch
|
||||
Patch9: rpm-4.4.2-contextverify.patch
|
||||
Patch10: rpm-4.4.2-popt-charset.patch
|
||||
Patch11: rpm-4.4.2-ghost-conflicts.patch
|
||||
License: GPL
|
||||
Conflicts: patch < 2.5
|
||||
%ifos linux
|
||||
@ -103,7 +105,7 @@ will manipulate RPM packages and databases.
|
||||
%package build
|
||||
Summary: Scripts and executable programs used to build packages.
|
||||
Group: Development/Tools
|
||||
Requires: rpm = %{rpm_version}-%{release}, patch >= 2.5, file
|
||||
Requires: rpm = %{rpm_version}-%{release}, patch >= 2.5, file, elfutils
|
||||
Provides: rpmbuild(VendorConfig) = 4.1-1
|
||||
|
||||
%description build
|
||||
@ -154,6 +156,8 @@ shell-like rules.
|
||||
%patch7 -p1 -b .perlreq
|
||||
%patch8 -p1 -b .param
|
||||
%patch9 -p1 -b .contextverify
|
||||
%patch10 -p1 -b .charset
|
||||
%patch11 -p1 -b .ghostconflicts
|
||||
|
||||
|
||||
%build
|
||||
@ -546,7 +550,10 @@ exit 0
|
||||
%{__includedir}/popt.h
|
||||
|
||||
%changelog
|
||||
* Mon Nov 28 2005 Paul Nasrat <pnasrat@redhat.com> - NOTYETBUILT
|
||||
* Mon Nov 28 2005 Paul Nasrat <pnasrat@redhat.com> - 4.4.2-8
|
||||
- Add elfutils Build Requires to rpmbuild (#155129)
|
||||
- Don't do conflicts if both files %ghost(#155256)
|
||||
- Fix popt charset for various languages (#172155)
|
||||
- Don't include .la file (#174261)
|
||||
|
||||
* Tue Nov 8 2005 Tomas Mraz <tmraz@redhat.com> - 4.4.2-7
|
||||
|
Loading…
Reference in New Issue
Block a user