- fix noarch __isa_* macro filter in installplatform (#865436)
This commit is contained in:
parent
240842c0b0
commit
25a06f20fe
25
rpm-4.10.1-noarch-isa.patch
Normal file
25
rpm-4.10.1-noarch-isa.patch
Normal file
@ -0,0 +1,25 @@
|
||||
commit 90dd51743200055f30d9e0e0337173118b4ae756
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Thu Oct 11 17:57:10 2012 +0300
|
||||
|
||||
Fix noarch __isa_* macro filter in installplatform (RhBug:865436)
|
||||
|
||||
- The filter wasn't doing what it was supposed to due to extra single
|
||||
quotes getting inserted, causing "rpmbuild --target noarch foo.spec"
|
||||
to whine about empty macro bodies. This is a regression introduced
|
||||
in rpm 4.10, commit 07ec480c180e4005a629242b8f9f8ab640e3e950 to be
|
||||
precise.
|
||||
|
||||
diff --git a/installplatform b/installplatform
|
||||
index f7ae241..a68b3c0 100755
|
||||
--- a/installplatform
|
||||
+++ b/installplatform
|
||||
@@ -104,7 +104,7 @@ for ARCH in noarch `grep ^arch_canon $RPMRC | cut -d: -f2`; do
|
||||
noarch)
|
||||
CANONARCH=noarch
|
||||
CANONCOLOR=0
|
||||
- FILTER="grep -v -E '^(%optflag|%__isa)'"
|
||||
+ FILTER="grep -v -E ^(%optflag|%__isa)"
|
||||
;;
|
||||
esac
|
||||
|
7
rpm.spec
7
rpm.spec
@ -21,7 +21,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}3%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.10.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -46,6 +46,7 @@ Patch6: rpm-4.9.0-armhfp-logic.patch
|
||||
|
||||
# Patches already in upstream
|
||||
Patch100: rpm-4.10.1-skipped-hardlinks.patch
|
||||
Patch101: rpm-4.10.1-noarch-isa.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -220,6 +221,7 @@ packages on a system.
|
||||
%patch4 -p1 -b .use-gpg2
|
||||
|
||||
%patch100 -p1 -b .skipped-hardlinks
|
||||
%patch101 -p1 -b .noarch-isa
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
@ -451,6 +453,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Oct 11 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.1-3
|
||||
- fix noarch __isa_* macro filter in installplatform (#865436)
|
||||
|
||||
* Wed Oct 10 2012 Panu Matilainen <pmatilai@redhat.com> - 4.10.1-2
|
||||
- account for intentionally skipped files when verifying hardlinks (#864622)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user