- adjust db util prefix & dependency due to #749293
- warn but dont fail the build if STABS encountered by debugedit (#725378)
This commit is contained in:
parent
bd02f6c71b
commit
21c63d106d
13
rpm-4.9.x-debugedit-stabs-warn.patch
Normal file
13
rpm-4.9.x-debugedit-stabs-warn.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
diff --git a/tools/debugedit.c b/tools/debugedit.c
|
||||||
|
index 89d0428..dc424d3 100644
|
||||||
|
--- a/tools/debugedit.c
|
||||||
|
+++ b/tools/debugedit.c
|
||||||
|
@@ -1586,7 +1586,7 @@ main (int argc, char *argv[])
|
||||||
|
if (strcmp (name, ".stab") == 0)
|
||||||
|
{
|
||||||
|
fprintf (stderr, "Stabs debuginfo not supported: %s\n", file);
|
||||||
|
- exit (1);
|
||||||
|
+ break;
|
||||||
|
}
|
||||||
|
if (strcmp (name, ".debug_info") == 0)
|
||||||
|
edit_dwarf2 (dso);
|
13
rpm.spec
13
rpm.spec
@ -16,12 +16,12 @@
|
|||||||
|
|
||||||
%define bdbname db4
|
%define bdbname db4
|
||||||
%define bdbver 4.8.30
|
%define bdbver 4.8.30
|
||||||
%define dbprefix db
|
%define dbprefix db4
|
||||||
|
|
||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}2%{?dist}
|
Release: %{?snapver:0.%{snapver}.}3%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.9.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.9.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -50,6 +50,8 @@ Patch303: rpm-4.9.0-debuginfo-allnames.patch
|
|||||||
Patch304: rpm-4.9.1.1-ld-flags.patch
|
Patch304: rpm-4.9.1.1-ld-flags.patch
|
||||||
# Based on patch from OpenSUSE, without the C-lang related enhancements
|
# Based on patch from OpenSUSE, without the C-lang related enhancements
|
||||||
Patch305: rpm-4.9.x-gnome-help.patch
|
Patch305: rpm-4.9.x-gnome-help.patch
|
||||||
|
# Just warn on STABS instead of failing for now
|
||||||
|
Patch306: rpm-4.9.x-debugedit-stabs-warn.patch
|
||||||
|
|
||||||
# Partially GPL/LGPL dual-licensed and some bits with BSD
|
# Partially GPL/LGPL dual-licensed and some bits with BSD
|
||||||
# SourceLicense: (GPLv2+ and LGPLv2+ with exceptions) and BSD
|
# SourceLicense: (GPLv2+ and LGPLv2+ with exceptions) and BSD
|
||||||
@ -58,7 +60,7 @@ License: GPLv2+
|
|||||||
Requires: coreutils
|
Requires: coreutils
|
||||||
%if %{without int_bdb}
|
%if %{without int_bdb}
|
||||||
# db recovery tools, rpmdb_util symlinks
|
# db recovery tools, rpmdb_util symlinks
|
||||||
Requires: %{bdbname}-utils
|
Requires: %{_bindir}/%{dbprefix}_stat
|
||||||
%endif
|
%endif
|
||||||
Requires: popt%{_isa} >= 1.10.2.1
|
Requires: popt%{_isa} >= 1.10.2.1
|
||||||
Requires: curl
|
Requires: curl
|
||||||
@ -216,6 +218,7 @@ packages on a system.
|
|||||||
%patch303 -p1 -b .debuginfo-allnames
|
%patch303 -p1 -b .debuginfo-allnames
|
||||||
%patch304 -p1 -b .ldflags
|
%patch304 -p1 -b .ldflags
|
||||||
%patch305 -p1 -b .gnome-help
|
%patch305 -p1 -b .gnome-help
|
||||||
|
%patch306 -p1 -b .debugedit-stabs-warn
|
||||||
|
|
||||||
%if %{with int_bdb}
|
%if %{with int_bdb}
|
||||||
ln -s db-%{bdbver} db
|
ln -s db-%{bdbver} db
|
||||||
@ -429,6 +432,10 @@ exit 0
|
|||||||
%doc COPYING doc/librpm/html/*
|
%doc COPYING doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Oct 28 2011 Panu Matilainen <pmatilai@redhat.com> - 4.9.1.2-3
|
||||||
|
- adjust db util prefix & dependency due to #749293
|
||||||
|
- warn but dont fail the build if STABS encountered by debugedit (#725378)
|
||||||
|
|
||||||
* Wed Oct 12 2011 Panu Matilainen <pmatilai@redhat.com> - 4.9.1.2-2
|
* Wed Oct 12 2011 Panu Matilainen <pmatilai@redhat.com> - 4.9.1.2-2
|
||||||
- try teaching find-lang about the new gnome help layout (#736523)
|
- try teaching find-lang about the new gnome help layout (#736523)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user