- Enable --no-backup-if-mismatch by default in %patch macro
- Resolves: #884755 - Add %{_default_patch_flags} to %__patch which is used in %autosetup - Use fuzz settings for %autopatch/%autosetup
This commit is contained in:
parent
ea526e71ec
commit
20d5c660aa
31
rpm-4.13.0-fuzz-settings.patch
Normal file
31
rpm-4.13.0-fuzz-settings.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From 50905f4a599f167622736fab24800fe062551809 Mon Sep 17 00:00:00 2001
|
||||
From: =?UTF-8?q?Neal=20Gompa=20=28=E3=83=8B=E3=83=BC=E3=83=AB=E3=83=BB?=
|
||||
=?UTF-8?q?=E3=82=B3=E3=82=99=E3=83=B3=E3=83=8F=E3=82=9A=29?=
|
||||
<ngompa13@gmail.com>
|
||||
Date: Sun, 13 Mar 2016 09:05:00 -0400
|
||||
Subject: [PATCH] Use fuzz settings for %autopatch/%autosetup
|
||||
|
||||
In the %apply_patches that inspired %autopatch, patch application
|
||||
respects the fuzz settings that are used for %patch. %autopatch
|
||||
and %autosetup weren't using this, which led to an inconsistent
|
||||
patch application behavior.
|
||||
---
|
||||
macros.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/macros.in b/macros.in
|
||||
index 7b807f9..ce252d4 100644
|
||||
--- a/macros.in
|
||||
+++ b/macros.in
|
||||
@@ -1085,7 +1085,7 @@ done \
|
||||
# Plain patch (-m is unused)
|
||||
%__scm_setup_patch(q) %{nil}
|
||||
%__scm_apply_patch(qp:m:)\
|
||||
-%{__patch} %{-p:-p%{-p*}} %{-q:-s}
|
||||
+%{__patch} %{-p:-p%{-p*}} %{-q:-s} --fuzz=%{_default_patch_fuzz}
|
||||
|
||||
# Mercurial (aka hg)
|
||||
%__scm_setup_hg(q)\
|
||||
--
|
||||
1.9.3
|
||||
|
25
rpm-4.13.0-no-backup-if-mismatch.patch
Normal file
25
rpm-4.13.0-no-backup-if-mismatch.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 69ed95eb422c59f9d99f75ccb78f32311a31702d Mon Sep 17 00:00:00 2001
|
||||
From: Lubos Kardos <lkardos@redhat.com>
|
||||
Date: Fri, 15 Apr 2016 10:45:47 +0200
|
||||
Subject: [PATCH 2/2] Enable --no-backup-if-mismatch by default in %patch macro
|
||||
(rhbz:884755)
|
||||
|
||||
---
|
||||
macros.in | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/macros.in b/macros.in
|
||||
index bbff0c1..f9172d0 100644
|
||||
--- a/macros.in
|
||||
+++ b/macros.in
|
||||
@@ -364,6 +364,7 @@ package or when debugging this package.\
|
||||
|
||||
# Default patch flags
|
||||
#%_default_patch_flags -s
|
||||
+%_default_patch_flags --no-backup-if-mismatch
|
||||
|
||||
#==============================================================================
|
||||
# ---- Build configuration macros.
|
||||
--
|
||||
1.9.3
|
||||
|
29
rpm-4.13.0-patch-flags.patch
Normal file
29
rpm-4.13.0-patch-flags.patch
Normal file
@ -0,0 +1,29 @@
|
||||
From 66a6082634687e45b321a5ade9887420d5830162 Mon Sep 17 00:00:00 2001
|
||||
From: Lubos Kardos <lkardos@redhat.com>
|
||||
Date: Fri, 15 Apr 2016 10:47:57 +0200
|
||||
Subject: [PATCH 1/2] Add %{_default_patch_flags} to %__patch which is used in
|
||||
%autosetup
|
||||
|
||||
%{_default_patch_flags} is used in %patch spec directive and now it is
|
||||
used also in %__patch macro which is used in %autosetup macro. This make
|
||||
consitent using newer %autosetup macro and older %patch directives.
|
||||
---
|
||||
macros.in | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/macros.in b/macros.in
|
||||
index ce252d4..bbff0c1 100644
|
||||
--- a/macros.in
|
||||
+++ b/macros.in
|
||||
@@ -1085,7 +1085,7 @@ done \
|
||||
# Plain patch (-m is unused)
|
||||
%__scm_setup_patch(q) %{nil}
|
||||
%__scm_apply_patch(qp:m:)\
|
||||
-%{__patch} %{-p:-p%{-p*}} %{-q:-s} --fuzz=%{_default_patch_fuzz}
|
||||
+%{__patch} %{-p:-p%{-p*}} %{-q:-s} --fuzz=%{_default_patch_fuzz} %{_default_patch_flags}
|
||||
|
||||
# Mercurial (aka hg)
|
||||
%__scm_setup_hg(q)\
|
||||
--
|
||||
1.9.3
|
||||
|
10
rpm.spec
10
rpm.spec
@ -29,7 +29,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}30%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}31%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -76,6 +76,9 @@ Patch120: rpm-4.13.0-redirect2null.patch
|
||||
Patch121: rpm-4.13.0-lang-doc-directives.patch
|
||||
Patch122: rpm-4.13.0-elem-progress-callback.patch
|
||||
Patch123: rpm-4.13.0-weak-rich-consistency.patch
|
||||
Patch124: rpm-4.13.0-fuzz-settings.patch
|
||||
Patch125: rpm-4.13.0-patch-flags.patch
|
||||
Patch126: rpm-4.13.0-no-backup-if-mismatch.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch302: rpm-4.7.1-geode-i686.patch
|
||||
@ -587,6 +590,11 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Fri Apr 15 2016 Lubos Kardos <lkardos@redhat.com> 4.13.0-0.rc1.31
|
||||
- Enable --no-backup-if-mismatch by default in %patch macro (#884755)
|
||||
- Add %{_default_patch_flags} to %__patch which is used in %autosetup
|
||||
- Use fuzz settings for %autopatch/%autosetup
|
||||
|
||||
* Thu Apr 14 2016 Lubos Kardos <lkardos@redhat.com> 4.13.0-0-rc1.30
|
||||
- Make creating index records consistent for rich and rich-weak deps (#1325982)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user