- update to 4.6.0-rc1
- fixes #465586, #466597, #465409, #216221, #466503, #466009, #463447... - avoid using %%configure macro for now, it has unwanted side-effects on rpm
This commit is contained in:
parent
353e517dc9
commit
20231bf36b
@ -1 +1 @@
|
|||||||
rpm-4.5.90.git8514.tar.bz2
|
rpm-4.6.0-rc1.tar.bz2
|
||||||
|
@ -1,48 +0,0 @@
|
|||||||
commit 65e06b20130da895fda8e3698a7ebe18e14d13ca
|
|
||||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
|
||||||
Date: Wed Oct 1 10:06:27 2008 +0300
|
|
||||||
|
|
||||||
Tweaks to how ISA-macros are generated (rhbz#464754)
|
|
||||||
- for ppc and sparc, move the check for 64bit version first and use a
|
|
||||||
wildcards to cover more field automatically
|
|
||||||
|
|
||||||
diff --git a/installplatform b/installplatform
|
|
||||||
index bb5933d..8861df0 100755
|
|
||||||
--- a/installplatform
|
|
||||||
+++ b/installplatform
|
|
||||||
@@ -80,13 +80,13 @@ for SUBST in $SUBSTS ; do
|
|
||||||
ISANAME=
|
|
||||||
ISABITS=
|
|
||||||
case "${ARCH}" in
|
|
||||||
- sparc|sparcv8|sparcv9*)
|
|
||||||
+ sparc64*)
|
|
||||||
ISANAME=sparc
|
|
||||||
- ISABITS=32
|
|
||||||
+ ISABITS=64
|
|
||||||
;;
|
|
||||||
- sparc64|sparc64v)
|
|
||||||
+ sparc*)
|
|
||||||
ISANAME=sparc
|
|
||||||
- ISABITS=64
|
|
||||||
+ ISABITS=32
|
|
||||||
;;
|
|
||||||
s390)
|
|
||||||
ISANAME=s390
|
|
||||||
@@ -96,13 +96,13 @@ for SUBST in $SUBSTS ; do
|
|
||||||
ISANAME=s390
|
|
||||||
ISABITS=64
|
|
||||||
;;
|
|
||||||
- ppc)
|
|
||||||
+ ppc64*)
|
|
||||||
ISANAME=ppc
|
|
||||||
- ISABITS=32
|
|
||||||
+ ISABITS=64
|
|
||||||
;;
|
|
||||||
- ppc64)
|
|
||||||
+ ppc*)
|
|
||||||
ISANAME=ppc
|
|
||||||
- ISABITS=64
|
|
||||||
+ ISABITS=32
|
|
||||||
;;
|
|
||||||
i?86|pentium?|athlon|geode)
|
|
||||||
ISANAME=x86
|
|
28
rpm.spec
28
rpm.spec
@ -9,9 +9,9 @@
|
|||||||
|
|
||||||
%define rpmhome /usr/lib/rpm
|
%define rpmhome /usr/lib/rpm
|
||||||
|
|
||||||
%define rpmver 4.5.90
|
%define rpmver 4.6.0
|
||||||
%define snapver git8514
|
%define snapver rc1
|
||||||
%define srcver %{rpmver}.%{snapver}
|
%define srcver %{rpmver}-%{snapver}
|
||||||
|
|
||||||
%define bdbver 4.5.20
|
%define bdbver 4.5.20
|
||||||
|
|
||||||
@ -32,9 +32,6 @@ Patch2: rpm-4.5.90-gstreamer-provides.patch
|
|||||||
# XXX only create provides for pkgconfig and libtool initially
|
# XXX only create provides for pkgconfig and libtool initially
|
||||||
Patch100: rpm-4.6.x-no-pkgconfig-reqs.patch
|
Patch100: rpm-4.6.x-no-pkgconfig-reqs.patch
|
||||||
|
|
||||||
# Already in upstream, remove on next snapshot update
|
|
||||||
Patch200: rpm-4.5.90-ppc-isa.patch
|
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.5.90-posttrans.patch
|
Patch300: rpm-4.5.90-posttrans.patch
|
||||||
|
|
||||||
@ -165,8 +162,6 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch2 -p1 -b .gstreamer-prov
|
%patch2 -p1 -b .gstreamer-prov
|
||||||
%patch100 -p1 -b .pkgconfig-deps
|
%patch100 -p1 -b .pkgconfig-deps
|
||||||
|
|
||||||
%patch200 -p1 -b .ppc-isa
|
|
||||||
|
|
||||||
# needs a bit of upstream love first...
|
# needs a bit of upstream love first...
|
||||||
#%patch300 -p1 -b .posttrans
|
#%patch300 -p1 -b .posttrans
|
||||||
|
|
||||||
@ -180,9 +175,17 @@ CPPFLAGS=-I%{_includedir}/db%{bdbver}
|
|||||||
LDFLAGS=-L%{_libdir}/db%{bdbver}
|
LDFLAGS=-L%{_libdir}/db%{bdbver}
|
||||||
%endif
|
%endif
|
||||||
CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
|
CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
|
||||||
export CPPFLAGS LDFLAGS
|
CFLAGS="$RPM_OPT_FLAGS"
|
||||||
|
export CPPFLAGS CFLAGS LDFLAGS
|
||||||
|
|
||||||
%configure \
|
# Using configure macro has some unwanted side-effects on rpm platform
|
||||||
|
# setup, use the old-fashioned way for now only defining minimal paths.
|
||||||
|
./configure \
|
||||||
|
--prefix=%{_usr} \
|
||||||
|
--sysconfdir=%{_sysconfdir} \
|
||||||
|
--localstatedir=%{_var} \
|
||||||
|
--mandir=%{_mandir} \
|
||||||
|
--libdir=%{_libdir} \
|
||||||
%{!?with_int_bdb: --with-external-db} \
|
%{!?with_int_bdb: --with-external-db} \
|
||||||
%{?with_sqlite: --enable-sqlite3} \
|
%{?with_sqlite: --enable-sqlite3} \
|
||||||
--with-lua \
|
--with-lua \
|
||||||
@ -349,6 +352,11 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Oct 16 2008 Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
- update to 4.6.0-rc1
|
||||||
|
- fixes #465586, #466597, #465409, #216221, #466503, #466009, #463447...
|
||||||
|
- avoid using %%configure macro for now, it has unwanted side-effects on rpm
|
||||||
|
|
||||||
* Wed Oct 01 2008 Panu Matilainen <pmatilai@redhat.com>
|
* Wed Oct 01 2008 Panu Matilainen <pmatilai@redhat.com>
|
||||||
- update to official 4.5.90 alpha tarball
|
- update to official 4.5.90 alpha tarball
|
||||||
- a big pile of misc bugfixes + translation updates
|
- a big pile of misc bugfixes + translation updates
|
||||||
|
Loading…
Reference in New Issue
Block a user