Use external find-debug and debugedit

Resolves: #2166383
This commit is contained in:
Florian Festi 2023-05-03 11:33:15 +02:00
parent 288f177357
commit 1ff4308fe4
2 changed files with 21 additions and 1 deletions

View File

@ -0,0 +1,11 @@
--- rpm-4.16.1.3/tests/Makefile.am.orig 2023-05-03 12:44:36.287582896 +0200
+++ rpm-4.16.1.3/tests/Makefile.am 2023-05-03 12:46:34.182938006 +0200
@@ -170,7 +170,7 @@
for d in dev etc magic tmp var; do if [ ! -d testing/$${d} ]; then mkdir testing/$${d}; fi; done
for node in urandom stdin stderr stdout null full; do ln -s /dev/$${node} testing/dev/$${node}; done
for cf in hosts resolv.conf passwd shadow group gshadow mtab ; do [ -f /etc/$${cf} ] && ln -s /etc/$${cf} testing/etc/$${cf}; done
- for prog in gzip cat patch tar sh ln chmod rm mkdir uname grep sed find file ionice mktemp nice cut sort diff touch install wc coreutils xargs; do p=`which $${prog}`; if [ "$${p}" != "" ]; then ln -s $${p} testing/$(bindir)/; fi; done
+ for prog in gzip cat patch tar sh ln chmod rm mkdir uname grep sed find file ionice mktemp nice cut sort diff touch install wc coreutils xargs debugedit find-debuginfo find-debuginfo.sh ; do p=`which $${prog}`; if [ "$${p}" != "" ]; then ln -s $${p} testing/$(bindir)/; fi; done
for d in /proc /sys /selinux /etc/selinux; do if [ -d $${d} ]; then ln -s $${d} testing/$${d}; fi; done
(cd testing/magic && file -C)
chmod -R u-w testing/

View File

@ -100,6 +100,7 @@ Patch906: rpm-4.7.1-geode-i686.patch
# Probably to be upstreamed in slightly different form
Patch907: rpm-4.15.x-ldflags.patch
Patch908: 0001-Give-warning-on-not-supported-hash-for-RSA-keys.patch
Patch909: rpm-4.16.1.3-external-debugedit.patch
# Not yet (all) upstream, debugedit DWARF5
# https://code.wildebeest.org/git/user/mjw/rpm/log/?h=gcc-dwarf5-4.16.1.2
@ -128,7 +129,7 @@ BuildRequires: libdb-devel
%endif
%if %{with check}
BuildRequires: fakechroot gnupg2
BuildRequires: fakechroot gnupg2 debugedit
%endif
# XXX generally assumed to be installed but make it explicit as rpm
@ -245,6 +246,7 @@ Suggests: gdb-minimal
# "just work" while allowing for alternatives, depend on a virtual
# provide, typically coming from redhat-rpm-config.
Requires: system-rpm-config
Requires: debugedit
%description build
The rpm-build package contains the scripts and executable programs
@ -416,6 +418,12 @@ pushd python
%py3_install
popd
# replace in-tree debugedit with upstream one
rm $RPM_BUILD_ROOT/%{rpmhome}/debugedit
rm $RPM_BUILD_ROOT/%{rpmhome}/find-debuginfo.sh
ln -s ../../bin/debugedit $RPM_BUILD_ROOT/%{rpmhome}/debugedit
ln -s ../../bin/find-debuginfo $RPM_BUILD_ROOT/%{rpmhome}/find-debuginfo.sh
mkdir -p $RPM_BUILD_ROOT%{_unitdir}
install -m 644 %{SOURCE10} $RPM_BUILD_ROOT/%{_unitdir}
@ -631,6 +639,7 @@ fi
* Wed May 03 2023 Florian Festi <ffesti@redhat.com> - 4.16.1.3-23
- Don't error out on IMA signatures on files not supporting them
(#2157835, #2157836)
- Use external find-debug and debugedit (#2166383)
* Mon Dec 19 2022 Florian Festi <ffesti@redhat.com> - 4.16.1.3-22
- Fix option handling in rpm2archive for #2150804