- update to 4.11.2-rc1
- drop upstreamed patches, adjust others as needed - handle python egg-info's version munging in file lists
This commit is contained in:
parent
5c70a391af
commit
1d5ceec05f
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@
|
||||
/rpm-4.11.1-rc1.tar.bz2
|
||||
/rpm-4.11.1-rc2.tar.bz2
|
||||
/rpm-4.11.1.tar.bz2
|
||||
/rpm-4.11.2-rc1.tar.bz2
|
||||
|
@ -1,28 +0,0 @@
|
||||
commit 4775f07b5108f61a3910ca3110315c1543c109b5
|
||||
Author: Michael Schroeder <mls@suse.de>
|
||||
Date: Wed Oct 2 15:02:18 2013 +0200
|
||||
|
||||
Add application() and application(filename) provides for desktop files.
|
||||
|
||||
Gnome software center needs to know what package to deinstall if it
|
||||
needs to deinstall a desktop application. Looking up provides it much
|
||||
cheaper than looking up which package owns a file.
|
||||
|
||||
We also add an empty application() provides to make it easy to
|
||||
enumerate all packages containing desktop applications.
|
||||
|
||||
Signed-off-by: Panu Matilainen <pmatilai@redhat.com>
|
||||
|
||||
diff --git a/scripts/desktop-file.prov b/scripts/desktop-file.prov
|
||||
index 5b159ae..54b7280 100755
|
||||
--- a/scripts/desktop-file.prov
|
||||
+++ b/scripts/desktop-file.prov
|
||||
@@ -11,6 +11,8 @@ while read instfile ; do
|
||||
*.desktop)
|
||||
if ! grep -q '^Type=Application$' "$instfile"; then continue; fi
|
||||
if ! grep -q '^Exec=' "$instfile"; then continue; fi
|
||||
+ echo "application()"
|
||||
+ echo "application(${instfile##*/applications/})"
|
||||
mime=`grep '^MimeType=' "$instfile" | cut -d'=' -f2`
|
||||
IFS=';'
|
||||
for type in $mime ; do
|
@ -1,19 +0,0 @@
|
||||
commit 65eec62cb7796dad6fbf1d5436251e176449f522
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Thu Aug 29 16:32:32 2013 +0300
|
||||
|
||||
Fix double-free on %caps() wildcard %files entry (RhBug:956190)
|
||||
|
||||
diff --git a/build/files.c b/build/files.c
|
||||
index 20f452f..eed5696 100644
|
||||
--- a/build/files.c
|
||||
+++ b/build/files.c
|
||||
@@ -1448,7 +1448,7 @@ static rpmRC addFile(FileList fl, const char * diskPath,
|
||||
}
|
||||
|
||||
if (fl->cur.caps) {
|
||||
- flp->caps = fl->cur.caps;
|
||||
+ flp->caps = xstrdup(fl->cur.caps);
|
||||
} else {
|
||||
flp->caps = xstrdup("");
|
||||
}
|
@ -1,23 +0,0 @@
|
||||
commit 5f3598a700e8e028f9140682262869ca319597ee
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Fri Sep 6 16:31:25 2013 +0300
|
||||
|
||||
Fix segfault executing a -p <lua> scriptlet without a body (RhBug:1004062)
|
||||
|
||||
- There are any number of places where this could be fixed, but
|
||||
to keep the behavior similar to eg /bin/sh scriptlet without a body,
|
||||
just turn a non-existent script into an empty string.
|
||||
|
||||
diff --git a/rpmio/rpmlua.c b/rpmio/rpmlua.c
|
||||
index 0576318..921cc37 100644
|
||||
--- a/rpmio/rpmlua.c
|
||||
+++ b/rpmio/rpmlua.c
|
||||
@@ -526,6 +526,8 @@ int rpmluaRunScript(rpmlua _lua, const char *script, const char *name)
|
||||
int ret = 0;
|
||||
if (name == NULL)
|
||||
name = "<lua>";
|
||||
+ if (script == NULL)
|
||||
+ script = "";
|
||||
if (luaL_loadbuffer(L, script, strlen(script), name) != 0) {
|
||||
rpmlog(RPMLOG_ERR, _("invalid syntax in lua script: %s\n"),
|
||||
lua_tostring(L, -1));
|
@ -1,27 +0,0 @@
|
||||
commit 65c7cc17664358051f0358de272e616dd88ab624
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Tue Aug 27 15:15:40 2013 +0300
|
||||
|
||||
Relax the filename triplet sanity check a bit (RhBug:1001553)
|
||||
|
||||
- At least unowned directories can cause orphans to be left around
|
||||
in RPMTAG_DIRNAMES, in which case its possible for number of
|
||||
dirnames to be larger than the number of basenames. This is
|
||||
arguably a bug in the relocation code but doesn't seem worth
|
||||
the trouble... so just relax the check to simply permit non-empty
|
||||
dirnames array, the index bound checking is far more important.
|
||||
|
||||
diff --git a/lib/rpmfi.c b/lib/rpmfi.c
|
||||
index 30663d0..00506ce 100644
|
||||
--- a/lib/rpmfi.c
|
||||
+++ b/lib/rpmfi.c
|
||||
@@ -1128,7 +1128,8 @@ static int indexSane(rpmtd xd, rpmtd yd, rpmtd zd)
|
||||
uint32_t zc = rpmtdCount(zd);
|
||||
|
||||
/* check that the amount of data in each is sane */
|
||||
- if (xc > 0 && yc > 0 && yc <= xc && zc == xc) {
|
||||
+ /* normally yc <= xc but larger values are not fatal (RhBug:1001553) */
|
||||
+ if (xc > 0 && yc > 0 && zc == xc) {
|
||||
uint32_t * i;
|
||||
/* ...and that the indexes are within bounds */
|
||||
while ((i = rpmtdNextUint32(zd))) {
|
@ -1,55 +0,0 @@
|
||||
commit 1ac9e84d9a4a04df7c8f659a8df676fc4f8544f0
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Fri Jul 5 10:27:18 2013 +0300
|
||||
|
||||
Ensure relocatable packages always get install-prefix(es) set (RhBug:979443)
|
||||
|
||||
- Scriptlets from relocatable packages should always run with
|
||||
$RPM_INSTALL_PREFIX* defined, whether actually being relocated or not.
|
||||
- Fixes regression introduced by the optimization in commit
|
||||
5d3018c4ed476b1b7ac18e2573af517f872cb303. We always need to call
|
||||
addPrefixes() but return early from rpmRelocateFileList() when
|
||||
no relocations are taking place, fixing the performance regression
|
||||
introduced all the way back in cb8241dda783f7e8c143b08fecf57fe89a39c3a6
|
||||
which is what 5d3018c4ed476b1b7ac18e2573af517f872cb303 was trying
|
||||
to fix. Pooh :)
|
||||
|
||||
(cherry picked from commit 88d24b14a8e0e33e768cb74a3487acf0925b012a)
|
||||
|
||||
diff --git a/lib/rpmfi.c b/lib/rpmfi.c
|
||||
index 0bfb5dd..185deae 100644
|
||||
--- a/lib/rpmfi.c
|
||||
+++ b/lib/rpmfi.c
|
||||
@@ -793,7 +793,8 @@ static int addPrefixes(Header h, rpmRelocation *relocations, int numRelocations)
|
||||
headerPutStringArray(h, RPMTAG_INSTPREFIXES, actualRelocations, numActual);
|
||||
}
|
||||
free(actualRelocations);
|
||||
- return numActual;
|
||||
+ /* When any relocations are present there'll be more work to do */
|
||||
+ return 1;
|
||||
}
|
||||
|
||||
static void saveRelocs(Header h, rpmtd bnames, rpmtd dnames, rpmtd dindexes)
|
||||
@@ -835,7 +836,8 @@ void rpmRelocateFileList(rpmRelocation *relocations, int numRelocations,
|
||||
int i, j;
|
||||
struct rpmtd_s bnames, dnames, dindexes, fmodes;
|
||||
|
||||
- addPrefixes(h, relocations, numRelocations);
|
||||
+ if (!addPrefixes(h, relocations, numRelocations))
|
||||
+ return;
|
||||
|
||||
if (!_printed) {
|
||||
_printed = 1;
|
||||
diff --git a/lib/rpmte.c b/lib/rpmte.c
|
||||
index 6afd69e..87fb391 100644
|
||||
--- a/lib/rpmte.c
|
||||
+++ b/lib/rpmte.c
|
||||
@@ -98,7 +98,7 @@ static rpmfi getFI(rpmte p, Header h)
|
||||
(RPMFI_NOHEADER | RPMFI_FLAGS_ERASE);
|
||||
|
||||
/* relocate stuff in header if necessary */
|
||||
- if (rpmteType(p) == TR_ADDED && rpmfsFC(p->fs) > 0 && p->nrelocs) {
|
||||
+ if (rpmteType(p) == TR_ADDED && rpmfsFC(p->fs) > 0) {
|
||||
if (!headerIsSource(h) && !headerIsEntry(h, RPMTAG_ORIGBASENAMES)) {
|
||||
rpmRelocateFileList(p->relocs, p->nrelocs, p->fs, h);
|
||||
}
|
@ -1,23 +1,23 @@
|
||||
diff -Nur rpm-4.11.1/fileattrs/kmod.attr rpm-4.11.1.new/fileattrs/kmod.attr
|
||||
--- rpm-4.11.1/fileattrs/kmod.attr 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ rpm-4.11.1.new/fileattrs/kmod.attr 2013-10-31 16:33:57.919845171 -0400
|
||||
diff -up rpm-4.11.2-rc1/fileattrs/kmod.attr.kmod-provides rpm-4.11.2-rc1/fileattrs/kmod.attr
|
||||
--- rpm-4.11.2-rc1/fileattrs/kmod.attr.kmod-provides 2014-01-20 11:47:48.325409810 +0200
|
||||
+++ rpm-4.11.2-rc1/fileattrs/kmod.attr 2014-01-20 11:47:48.325409810 +0200
|
||||
@@ -0,0 +1,2 @@
|
||||
+%__kmod_provides %{_rpmconfigdir}/kmod.prov
|
||||
+%__kmod_path ^/lib/modules/.*$
|
||||
diff -Nur rpm-4.11.1/fileattrs/Makefile.am rpm-4.11.1.new/fileattrs/Makefile.am
|
||||
--- rpm-4.11.1/fileattrs/Makefile.am 2012-11-18 03:21:06.000000000 -0500
|
||||
+++ rpm-4.11.1.new/fileattrs/Makefile.am 2013-10-31 16:35:16.443641444 -0400
|
||||
@@ -6,6 +6,6 @@
|
||||
|
||||
diff -up rpm-4.11.2-rc1/fileattrs/Makefile.am.kmod-provides rpm-4.11.2-rc1/fileattrs/Makefile.am
|
||||
--- rpm-4.11.2-rc1/fileattrs/Makefile.am.kmod-provides 2014-01-20 11:47:48.325409810 +0200
|
||||
+++ rpm-4.11.2-rc1/fileattrs/Makefile.am 2014-01-20 11:49:31.764544198 +0200
|
||||
@@ -7,6 +7,6 @@ fattrsdir = $(rpmconfigdir)/fileattrs
|
||||
fattrs_DATA = \
|
||||
desktop.attr elf.attr font.attr libtool.attr perl.attr perllib.attr \
|
||||
- pkgconfig.attr python.attr ocaml.attr script.attr mono.attr
|
||||
+ pkgconfig.attr python.attr ocaml.attr script.attr mono.attr kmod.attr
|
||||
appdata.attr desktop.attr elf.attr font.attr libtool.attr perl.attr \
|
||||
perllib.attr pkgconfig.attr python.attr ocaml.attr script.attr \
|
||||
- mono.attr
|
||||
+ mono.attr kmod.attr
|
||||
|
||||
EXTRA_DIST = $(fattrs_DATA)
|
||||
diff -Nur rpm-4.11.1/scripts/kmod.prov rpm-4.11.1.new/scripts/kmod.prov
|
||||
--- rpm-4.11.1/scripts/kmod.prov 1969-12-31 19:00:00.000000000 -0500
|
||||
+++ rpm-4.11.1.new/scripts/kmod.prov 2013-10-31 16:33:57.919845171 -0400
|
||||
diff -up rpm-4.11.2-rc1/scripts/kmod.prov.kmod-provides rpm-4.11.2-rc1/scripts/kmod.prov
|
||||
--- rpm-4.11.2-rc1/scripts/kmod.prov.kmod-provides 2014-01-20 11:47:48.325409810 +0200
|
||||
+++ rpm-4.11.2-rc1/scripts/kmod.prov 2014-01-20 11:47:48.325409810 +0200
|
||||
@@ -0,0 +1,17 @@
|
||||
+#!/bin/sh +x
|
||||
+
|
||||
@ -36,19 +36,19 @@ diff -Nur rpm-4.11.1/scripts/kmod.prov rpm-4.11.1.new/scripts/kmod.prov
|
||||
+ echo "kmod($kmod)"
|
||||
+ fi
|
||||
+done
|
||||
diff -Nur rpm-4.11.1/scripts/Makefile.am rpm-4.11.1.new/scripts/Makefile.am
|
||||
--- rpm-4.11.1/scripts/Makefile.am 2012-11-18 03:21:06.000000000 -0500
|
||||
+++ rpm-4.11.1.new/scripts/Makefile.am 2013-10-31 16:35:53.990543808 -0400
|
||||
@@ -20,7 +20,7 @@
|
||||
diff -up rpm-4.11.2-rc1/scripts/Makefile.am.kmod-provides rpm-4.11.2-rc1/scripts/Makefile.am
|
||||
--- rpm-4.11.2-rc1/scripts/Makefile.am.kmod-provides 2014-01-17 13:17:29.000000000 +0200
|
||||
+++ rpm-4.11.2-rc1/scripts/Makefile.am 2014-01-20 11:50:24.065601168 +0200
|
||||
@@ -20,7 +20,7 @@ EXTRA_DIST = \
|
||||
ocaml-find-requires.sh ocaml-find-provides.sh \
|
||||
pkgconfigdeps.sh libtooldeps.sh \
|
||||
pkgconfigdeps.sh libtooldeps.sh appdata.prov \
|
||||
fontconfig.prov desktop-file.prov script.req \
|
||||
- macros.perl macros.php macros.python
|
||||
+ macros.perl macros.php macros.python kmod.prov
|
||||
|
||||
rpmconfig_SCRIPTS = \
|
||||
brp-compress brp-python-bytecompile brp-java-gcjcompile \
|
||||
@@ -34,7 +34,7 @@
|
||||
@@ -34,7 +34,7 @@ rpmconfig_SCRIPTS = \
|
||||
pkgconfigdeps.sh libtooldeps.sh \
|
||||
ocaml-find-requires.sh ocaml-find-provides.sh \
|
||||
fontconfig.prov desktop-file.prov script.req \
|
||||
|
@ -1,109 +0,0 @@
|
||||
diff --git a/installplatform b/installplatform
|
||||
index 9a11bc3..6908f02 100755
|
||||
--- a/installplatform
|
||||
+++ b/installplatform
|
||||
@@ -54,12 +54,18 @@ for ARCH in noarch `grep ^arch_canon $RPMRC | cut -d: -f2`; do
|
||||
CANONARCH=s390x
|
||||
CANONCOLOR=3
|
||||
;;
|
||||
- ppc64*)
|
||||
+ ppc64|ppc64p7)
|
||||
ISANAME=ppc
|
||||
ISABITS=64
|
||||
CANONARCH=ppc64
|
||||
CANONCOLOR=3
|
||||
;;
|
||||
+ ppc64le)
|
||||
+ ISANAME=ppc
|
||||
+ ISABITS=64
|
||||
+ CANONARCH=ppc64le
|
||||
+ CANONCOLOR=3
|
||||
+ ;;
|
||||
ppc*)
|
||||
ISANAME=ppc
|
||||
ISABITS=32
|
||||
diff --git a/lib/rpmrc.c b/lib/rpmrc.c
|
||||
index 794d028..f209851 100644
|
||||
--- a/lib/rpmrc.c
|
||||
+++ b/lib/rpmrc.c
|
||||
@@ -1125,6 +1125,7 @@ static void defaultMachine(rpmrcCtx ctx, const char ** arch, const char ** os)
|
||||
# endif /* sparc*-linux */
|
||||
|
||||
# if defined(__linux__) && defined(__powerpc__)
|
||||
+# if __BYTE_ORDER__ == __ORDER_BIG_ENDIAN__
|
||||
{
|
||||
int powerlvl;
|
||||
if (!rstreq(un.machine, "ppc") &&
|
||||
@@ -1133,6 +1134,7 @@ static void defaultMachine(rpmrcCtx ctx, const char ** arch, const char ** os)
|
||||
strcpy(un.machine, "ppc64p7");
|
||||
}
|
||||
}
|
||||
+# endif /* __ORDER_BIG_ENDIAN__ */
|
||||
# endif /* ppc64*-linux */
|
||||
|
||||
# if defined(__GNUC__) && defined(__alpha__)
|
||||
diff --git a/rpmrc.in b/rpmrc.in
|
||||
index 55ff25f..affb736 100644
|
||||
--- a/rpmrc.in
|
||||
+++ b/rpmrc.in
|
||||
@@ -48,6 +48,7 @@ optflags: ppc32dy4 -O2 -g -fsigned-char
|
||||
optflags: ppciseries -O2 -g -fsigned-char
|
||||
optflags: ppcpseries -O2 -g -fsigned-char
|
||||
optflags: ppc64 -O2 -g -fsigned-char
|
||||
+optflags: ppc64le -O2 -g -fsigned-char
|
||||
optflags: ppc64p7 -O3 -mtune=power7 -mcpu=power7 -g -fsigned-char
|
||||
|
||||
optflags: parisc -O2 -g -mpa-risc-1-0
|
||||
@@ -96,6 +97,7 @@ archcolor: sparc64 2
|
||||
archcolor: sparcv9 2
|
||||
archcolor: ppc 1
|
||||
archcolor: ppc64 2
|
||||
+archcolor: ppc64le 2
|
||||
|
||||
archcolor: armv3l 1
|
||||
archcolor: armv4b 1
|
||||
@@ -194,6 +196,7 @@ arch_canon: i370: i370 14
|
||||
arch_canon: s390x: s390x 15
|
||||
|
||||
arch_canon: ppc64: ppc64 16
|
||||
+arch_canon: ppc64le: ppc64le 16
|
||||
arch_canon: ppc64pseries: ppc64pseries 16
|
||||
arch_canon: ppc64iseries: ppc64iseries 16
|
||||
arch_canon: ppc64p7: ppc64p7 16
|
||||
@@ -281,6 +284,7 @@ buildarchtranslate: ppcpseries: ppc
|
||||
buildarchtranslate: ppc64iseries: ppc64
|
||||
buildarchtranslate: ppc64pseries: ppc64
|
||||
buildarchtranslate: ppc64p7: ppc64
|
||||
+buildarchtranslate: ppc64le: ppc64le
|
||||
|
||||
buildarchtranslate: armv3l: armv3l
|
||||
buildarchtranslate: armv4b: armv4b
|
||||
@@ -352,6 +356,7 @@ arch_compat: rs6000: noarch fat
|
||||
arch_compat: ppc64pseries: ppc64
|
||||
arch_compat: ppc64iseries: ppc64
|
||||
arch_compat: ppc64p7: ppc64
|
||||
+arch_compat: ppc64le: noarch fat
|
||||
|
||||
arch_compat: sun4c: sparc
|
||||
arch_compat: sun4d: sparc
|
||||
@@ -475,6 +480,7 @@ buildarch_compat: ppciseries: noarch
|
||||
buildarch_compat: ppcpseries: noarch
|
||||
buildarch_compat: ppc: noarch fat
|
||||
buildarch_compat: ppc64: noarch fat
|
||||
+buildarch_compat: ppc64le: noarch fat
|
||||
buildarch_compat: ppc64pseries: ppc64
|
||||
buildarch_compat: ppc64iseries: ppc64
|
||||
buildarch_compat: ppc64p7: ppc64
|
||||
diff --git a/macros.in b/macros.in
|
||||
index 2e693e1..5a075a3 100644
|
||||
--- a/macros.in
|
||||
+++ b/macros.in
|
||||
@@ -1002,7 +1002,7 @@ done \
|
||||
|
||||
#------------------------------------------------------------------------------
|
||||
# arch macro for all supported PowerPC 64 processors
|
||||
-%power64 ppc64 ppc64p7
|
||||
+%power64 ppc64 ppc64p7 ppc64le
|
||||
|
||||
#------------------------------------------------------------------------
|
||||
# Use in %install to generate locale specific file lists. For example,
|
@ -1,59 +0,0 @@
|
||||
commit 62bdcc0a32d07a7423876b3ae17900da04eb8a97
|
||||
Author: Jan Silhan <jsilhan@redhat.com>
|
||||
Date: Fri Oct 18 18:30:52 2013 +0200
|
||||
|
||||
Python 3 compatibility fixes
|
||||
|
||||
- Use open() instead of calling file constructor
|
||||
- Borrow python-six trick of dealing with difference in string types
|
||||
|
||||
Signed-off-by: Panu Matilainen <pmatilai@redhat.com>
|
||||
|
||||
diff --git a/python/rpm/transaction.py b/python/rpm/transaction.py
|
||||
index 756e893..df72ce9 100644
|
||||
--- a/python/rpm/transaction.py
|
||||
+++ b/python/rpm/transaction.py
|
||||
@@ -1,8 +1,14 @@
|
||||
#!/usr/bin/python
|
||||
|
||||
+import sys
|
||||
import rpm
|
||||
from rpm._rpm import ts as TransactionSetCore
|
||||
|
||||
+if sys.version_info[0] == 3:
|
||||
+ _string_types = str,
|
||||
+else:
|
||||
+ _string_types = basestring,
|
||||
+
|
||||
# TODO: migrate relevant documentation from C-side
|
||||
class TransactionSet(TransactionSetCore):
|
||||
_probFilter = 0
|
||||
@@ -45,14 +51,14 @@ class TransactionSet(TransactionSetCore):
|
||||
return tuple(keys)
|
||||
|
||||
def addInstall(self, item, key, how="u"):
|
||||
- if isinstance(item, basestring):
|
||||
- f = file(item)
|
||||
+ if isinstance(item, _string_types):
|
||||
+ f = open(item)
|
||||
header = self.hdrFromFdno(f)
|
||||
f.close()
|
||||
- elif isinstance(item, file):
|
||||
- header = self.hdrFromFdno(item)
|
||||
- else:
|
||||
+ elif isinstance(item, rpm.hdr):
|
||||
header = item
|
||||
+ else:
|
||||
+ header = self.hdrFromFdno(item)
|
||||
|
||||
if not how in ['u', 'i']:
|
||||
raise ValueError('how argument must be "u" or "i"')
|
||||
@@ -69,7 +75,7 @@ class TransactionSet(TransactionSetCore):
|
||||
hdrs = item
|
||||
elif isinstance(item, int):
|
||||
hdrs = self.dbMatch(rpm.RPMDBI_PACKAGES, item)
|
||||
- elif isinstance(item, basestring):
|
||||
+ elif isinstance(item, _string_types):
|
||||
hdrs = self.dbMatch(rpm.RPMDBI_LABEL, item)
|
||||
else:
|
||||
raise TypeError("invalid type %s" % type(item))
|
@ -11,84 +11,6 @@
|
||||
endif
|
||||
endif
|
||||
|
||||
--- rpm-4.11.1-rc1-orig/Makefile.in 2013-06-10 08:38:51.000000000 +0200
|
||||
+++ rpm-4.11.1-rc1/Makefile.in 2013-06-24 18:34:06.342894002 +0200
|
||||
@@ -74,7 +74,8 @@ bin_PROGRAMS = rpm2cpio$(EXEEXT) rpmbuil
|
||||
rpmgraph$(EXEEXT)
|
||||
rpmlibexec_PROGRAMS = $(am__EXEEXT_1) rpmdeps$(EXEEXT)
|
||||
@LIBDWARF_TRUE@@LIBELF_TRUE@am__append_6 = scripts/find-debuginfo.sh
|
||||
-@LIBDWARF_TRUE@@LIBELF_TRUE@am__append_7 = debugedit elfdeps
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@am__append_7 = debugedit elfdeps \
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@ sepdebugcrcfix
|
||||
@DOXYGEN_TRUE@@HACKINGDOCS_TRUE@am__append_8 = doc/hacking/html/index.html
|
||||
@DOXYGEN_TRUE@am__append_9 = doc/librpm/html/index.html
|
||||
@WITH_INTERNAL_DB_TRUE@am__append_10 = db.h
|
||||
@@ -110,7 +111,8 @@ am__installdirs = "$(DESTDIR)$(bindir)"
|
||||
"$(DESTDIR)$(rpmconfigdir)" "$(DESTDIR)$(rpmvardir)" \
|
||||
"$(DESTDIR)$(pkgincludedir)" "$(DESTDIR)$(pkgincludedir)"
|
||||
@LIBDWARF_TRUE@@LIBELF_TRUE@am__EXEEXT_1 = debugedit$(EXEEXT) \
|
||||
-@LIBDWARF_TRUE@@LIBELF_TRUE@ elfdeps$(EXEEXT)
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@ elfdeps$(EXEEXT) \
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@ sepdebugcrcfix$(EXEEXT)
|
||||
PROGRAMS = $(bin_PROGRAMS) $(rpmbin_PROGRAMS) $(rpmlibexec_PROGRAMS)
|
||||
am__debugedit_SOURCES_DIST = tools/debugedit.c tools/hashtab.c \
|
||||
tools/hashtab.h
|
||||
@@ -157,6 +159,11 @@ am_rpmspec_OBJECTS = rpmspec-rpmspec.$(O
|
||||
rpmspec_OBJECTS = $(am_rpmspec_OBJECTS)
|
||||
rpmspec_DEPENDENCIES = libcliutils.la build/librpmbuild.la \
|
||||
lib/librpm.la rpmio/librpmio.la
|
||||
+am__sepdebugcrcfix_SOURCES_DIST = tools/sepdebugcrcfix.c
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@am_sepdebugcrcfix_OBJECTS = \
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@ tools/sepdebugcrcfix.$(OBJEXT)
|
||||
+sepdebugcrcfix_OBJECTS = $(am_sepdebugcrcfix_OBJECTS)
|
||||
+sepdebugcrcfix_DEPENDENCIES =
|
||||
am__vpath_adj_setup = srcdirstrip=`echo "$(srcdir)" | sed 's|.|.|g'`;
|
||||
am__vpath_adj = case $$p in \
|
||||
$(srcdir)/*) f=`echo "$$p" | sed "s|^$$srcdirstrip/||"`;; \
|
||||
@@ -223,12 +230,12 @@ SOURCES = $(libcliutils_la_SOURCES) $(de
|
||||
$(elfdeps_SOURCES) $(rpm_SOURCES) $(rpm2cpio_SOURCES) \
|
||||
$(rpmbuild_SOURCES) $(rpmdb_SOURCES) $(rpmdeps_SOURCES) \
|
||||
$(rpmgraph_SOURCES) $(rpmkeys_SOURCES) $(rpmsign_SOURCES) \
|
||||
- $(rpmspec_SOURCES)
|
||||
+ $(rpmspec_SOURCES) $(sepdebugcrcfix_SOURCES)
|
||||
DIST_SOURCES = $(libcliutils_la_SOURCES) $(am__debugedit_SOURCES_DIST) \
|
||||
$(am__elfdeps_SOURCES_DIST) $(rpm_SOURCES) $(rpm2cpio_SOURCES) \
|
||||
$(rpmbuild_SOURCES) $(rpmdb_SOURCES) $(rpmdeps_SOURCES) \
|
||||
$(rpmgraph_SOURCES) $(rpmkeys_SOURCES) $(rpmsign_SOURCES) \
|
||||
- $(rpmspec_SOURCES)
|
||||
+ $(rpmspec_SOURCES) $(am__sepdebugcrcfix_SOURCES_DIST)
|
||||
RECURSIVE_TARGETS = all-recursive check-recursive dvi-recursive \
|
||||
html-recursive info-recursive install-data-recursive \
|
||||
install-dvi-recursive install-exec-recursive \
|
||||
@@ -636,6 +643,8 @@ rpm2cpio_LDADD = lib/librpm.la rpmio/lib
|
||||
@LIBDWARF_TRUE@@LIBELF_TRUE@elfdeps_LDADD = rpmio/librpmio.la \
|
||||
@LIBDWARF_TRUE@@LIBELF_TRUE@ @WITH_LIBELF_LIB@ @WITH_POPT_LIB@ \
|
||||
@LIBDWARF_TRUE@@LIBELF_TRUE@ $(am__empty)
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@sepdebugcrcfix_SOURCES = tools/sepdebugcrcfix.c
|
||||
+@LIBDWARF_TRUE@@LIBELF_TRUE@sepdebugcrcfix_LDADD = @WITH_LIBELF_LIB@
|
||||
rpmdeps_SOURCES = tools/rpmdeps.c
|
||||
rpmdeps_LDADD = lib/librpm.la rpmio/librpmio.la build/librpmbuild.la @WITH_POPT_LIB@
|
||||
rpmgraph_SOURCES = tools/rpmgraph.c
|
||||
@@ -903,6 +912,11 @@ rpmsign$(EXEEXT): $(rpmsign_OBJECTS) $(r
|
||||
rpmspec$(EXEEXT): $(rpmspec_OBJECTS) $(rpmspec_DEPENDENCIES) $(EXTRA_rpmspec_DEPENDENCIES)
|
||||
@rm -f rpmspec$(EXEEXT)
|
||||
$(AM_V_CCLD)$(LINK) $(rpmspec_OBJECTS) $(rpmspec_LDADD) $(LIBS)
|
||||
+tools/sepdebugcrcfix.$(OBJEXT): tools/$(am__dirstamp) \
|
||||
+ tools/$(DEPDIR)/$(am__dirstamp)
|
||||
+sepdebugcrcfix$(EXEEXT): $(sepdebugcrcfix_OBJECTS) $(sepdebugcrcfix_DEPENDENCIES) $(EXTRA_sepdebugcrcfix_DEPENDENCIES)
|
||||
+ @rm -f sepdebugcrcfix$(EXEEXT)
|
||||
+ $(AM_V_CCLD)$(LINK) $(sepdebugcrcfix_OBJECTS) $(sepdebugcrcfix_LDADD) $(LIBS)
|
||||
install-dist_binSCRIPTS: $(dist_bin_SCRIPTS)
|
||||
@$(NORMAL_INSTALL)
|
||||
@list='$(dist_bin_SCRIPTS)'; test -n "$(bindir)" || list=; \
|
||||
@@ -994,6 +1008,7 @@ distclean-compile:
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@tools/$(DEPDIR)/hashtab.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@tools/$(DEPDIR)/rpmdeps.Po@am__quote@
|
||||
@AMDEP_TRUE@@am__include@ @am__quote@tools/$(DEPDIR)/rpmgraph.Po@am__quote@
|
||||
+@AMDEP_TRUE@@am__include@ @am__quote@tools/$(DEPDIR)/sepdebugcrcfix.Po@am__quote@
|
||||
|
||||
.c.o:
|
||||
@am__fastdepCC_TRUE@ $(AM_V_CC)depbase=`echo $@ | sed 's|[^/]*$$|$(DEPDIR)/&|;s|\.o$$||'`;\
|
||||
--- rpm-4.11.1-rc1-orig/scripts/find-debuginfo.sh 2013-06-24 17:20:55.407538301 +0200
|
||||
+++ rpm-4.11.1-rc1/scripts/find-debuginfo.sh 2013-06-24 18:34:41.270897302 +0200
|
||||
@@ -114,10 +114,12 @@ done
|
||||
|
33
rpm.spec
33
rpm.spec
@ -11,8 +11,10 @@
|
||||
|
||||
%define rpmhome /usr/lib/rpm
|
||||
|
||||
%define rpmver 4.11.1
|
||||
%define rpmver 4.11.2
|
||||
%define snapver rc1
|
||||
%define srcver %{rpmver}%{?snapver:-%{snapver}}
|
||||
%define eggver %{rpmver}%{?snapver:_%{snapver}}
|
||||
|
||||
%define bdbname libdb
|
||||
%define bdbver 5.3.15
|
||||
@ -21,7 +23,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}12%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}1%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/rpm-4.11.x/%{name}-%{srcver}.tar.bz2
|
||||
@ -50,14 +52,7 @@ Patch7: rpm-4.11.1-kmod-find-provides.patch
|
||||
# Patches already in upstream
|
||||
# Filter soname dependencies by name
|
||||
Patch100: rpm-4.11.x-filter-soname-deps.patch
|
||||
Patch101: rpm-4.11.1-instprefix.patch
|
||||
Patch102: rpm-4.11.x-do-not-filter-ld64.patch
|
||||
Patch103: rpm-4.11.1-file-triplet-check.patch
|
||||
Patch104: rpm-4.11.1-caps-double-free.patch
|
||||
Patch105: rpm-4.11.1-empty-lua-script.patch
|
||||
Patch106: rpm-4.11.1-ppc64le.patch
|
||||
Patch107: rpm-4.11.1-application-provides.patch
|
||||
Patch108: rpm-4.11.1-py3-fixes.patch
|
||||
Patch101: rpm-4.11.x-do-not-filter-ld64.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -258,14 +253,7 @@ packages on a system.
|
||||
%patch7 -p1 -b .kmod-provides
|
||||
|
||||
%patch100 -p1 -b .filter-soname-deps
|
||||
%patch101 -p1 -b .instprefix
|
||||
%patch102 -p1 -b .dont-filter-ld64
|
||||
%patch103 -p1 -b .file-triplet-check
|
||||
%patch104 -p1 -b .caps-double-free
|
||||
%patch105 -p1 -b .empty-lua-script
|
||||
%patch106 -p1 -b .ppc64le
|
||||
%patch107 -p1 -b .application-provides
|
||||
%patch108 -p1 -b .py3-fixes
|
||||
%patch101 -p1 -b .dont-filter-ld64
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
@ -497,12 +485,12 @@ exit 0
|
||||
%files python
|
||||
%defattr(-,root,root)
|
||||
%{python_sitearch}/rpm
|
||||
%{python_sitearch}/rpm_python-%{version}-py2.7.egg-info
|
||||
%{python_sitearch}/rpm_python-%{eggver}-py2.7.egg-info
|
||||
|
||||
%files python3
|
||||
%defattr(-,root,root)
|
||||
%{python3_sitearch}/rpm
|
||||
%{python3_sitearch}/rpm_python-%{version}-py%{python3_version}.egg-info
|
||||
%{python3_sitearch}/rpm_python-%{eggver}-py%{python3_version}.egg-info
|
||||
|
||||
%files devel
|
||||
%defattr(-,root,root)
|
||||
@ -522,6 +510,11 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Mon Jan 20 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.2-0.rc1.1
|
||||
- update to 4.11.2-rc1 (http://rpm.org/wiki/Releases/4.11.2)
|
||||
- drop upstreamed patches, adjust others as needed
|
||||
- handle python egg-info's version munging in file lists
|
||||
|
||||
* Wed Jan 15 2014 Panu Matilainen <pmatilai@redhat.com> - 4.11.1-12
|
||||
- include ppc64le in %%power64 macro (#1052930)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user