build with internal libdb to allow libdb with higher soname
This commit is contained in:
parent
f097c8059c
commit
16864eefd3
7
.gitignore
vendored
7
.gitignore
vendored
@ -1,8 +1 @@
|
||||
rpm-4.8.1.tar.bz2
|
||||
/rpm-4.9.0-beta1.tar.bz2
|
||||
/rpm-4.9.0-rc1.tar.bz2
|
||||
/rpm-4.9.0.tar.bz2
|
||||
/rpm-4.9.1.tar.bz2
|
||||
/rpm-4.9.1.1.tar.bz2
|
||||
/rpm-4.9.1.2.tar.bz2
|
||||
/rpm-4.9.90.git11505.tar.bz2
|
||||
|
67
rpm-4.9.90-int-libdb.patch
Normal file
67
rpm-4.9.90-int-libdb.patch
Normal file
@ -0,0 +1,67 @@
|
||||
commit dd05fdd35f680dfff606731a664859ae45762bb1
|
||||
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||
Date: Mon Mar 26 13:03:03 2012 +0300
|
||||
|
||||
Dont bother building internal versions of db utilities we dont need
|
||||
|
||||
- rpmdb_dump, load, recover, verify, stat etc are useful at times,
|
||||
but these are not. This also fixes build with internal db for
|
||||
more recent versions of Berkeley DB.
|
||||
|
||||
diff --git a/lib/Makefile.am b/lib/Makefile.am
|
||||
index 8c3b970..2245c19 100644
|
||||
--- a/lib/Makefile.am
|
||||
+++ b/lib/Makefile.am
|
||||
@@ -82,29 +82,6 @@ CLEANFILES += $(libdb_la)
|
||||
|
||||
rpmlibexec_PROGRAMS =
|
||||
|
||||
-rpmlibexec_PROGRAMS += rpmdb_archive
|
||||
-rpmdb_archive_SOURCES =
|
||||
-rpmdb_archive_LDADD = \
|
||||
- $(top_builddir)/db3/db_archive.o \
|
||||
- $(top_builddir)/db3/util_sig.o \
|
||||
- librpm.la
|
||||
-
|
||||
-rpmlibexec_PROGRAMS += rpmdb_checkpoint
|
||||
-rpmdb_checkpoint_SOURCES =
|
||||
-rpmdb_checkpoint_LDADD = \
|
||||
- $(top_builddir)/db3/db_checkpoint.o \
|
||||
- $(top_builddir)/db3/util_log.o \
|
||||
- $(top_builddir)/db3/util_sig.o \
|
||||
- librpm.la
|
||||
-
|
||||
-rpmlibexec_PROGRAMS += rpmdb_deadlock
|
||||
-rpmdb_deadlock_SOURCES =
|
||||
-rpmdb_deadlock_LDADD = \
|
||||
- $(top_builddir)/db3/db_deadlock.o \
|
||||
- $(top_builddir)/db3/util_log.o \
|
||||
- $(top_builddir)/db3/util_sig.o \
|
||||
- librpm.la
|
||||
-
|
||||
rpmlibexec_PROGRAMS += rpmdb_dump
|
||||
rpmdb_dump_SOURCES =
|
||||
rpmdb_dump_LDADD = \
|
||||
@@ -121,22 +98,6 @@ rpmdb_load_LDADD = \
|
||||
$(top_builddir)/db3/util_sig.o \
|
||||
librpm.la
|
||||
|
||||
-rpmlibexec_PROGRAMS += rpmdb_printlog
|
||||
-rpmdb_printlog_SOURCES =
|
||||
-rpmdb_printlog_LDADD = \
|
||||
- $(top_builddir)/db3/db_printlog.o \
|
||||
- $(top_builddir)/db3/btree_autop.o \
|
||||
- $(top_builddir)/db3/crdel_autop.o \
|
||||
- $(top_builddir)/db3/db_autop.o \
|
||||
- $(top_builddir)/db3/dbreg_autop.o \
|
||||
- $(top_builddir)/db3/fileops_autop.o \
|
||||
- $(top_builddir)/db3/hash_autop.o \
|
||||
- $(top_builddir)/db3/qam_autop.o \
|
||||
- $(top_builddir)/db3/rep_autop.o \
|
||||
- $(top_builddir)/db3/txn_autop.o \
|
||||
- $(top_builddir)/db3/util_sig.o \
|
||||
- librpm.la
|
||||
-
|
||||
rpmlibexec_PROGRAMS += rpmdb_recover
|
||||
rpmdb_recover_SOURCES =
|
||||
rpmdb_recover_LDADD = \
|
19
rpm.spec
19
rpm.spec
@ -1,7 +1,7 @@
|
||||
# build against xz?
|
||||
%bcond_without xz
|
||||
# just for giggles, option to build with internal Berkeley DB
|
||||
%bcond_with int_bdb
|
||||
%bcond_without int_bdb
|
||||
# run internal testsuite?
|
||||
%bcond_without check
|
||||
# disable plugins initially
|
||||
@ -16,13 +16,13 @@
|
||||
%define srcver %{rpmver}%{?snapver:.%{snapver}}
|
||||
|
||||
%define bdbname libdb
|
||||
%define bdbver 5.2.36
|
||||
%define bdbver 5.3.15
|
||||
%define dbprefix db
|
||||
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}10%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}11%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/testing/%{name}-%{srcver}.tar.bz2
|
||||
@ -50,6 +50,7 @@ Patch202: rpm-4.9.90-keyid-size.patch
|
||||
Patch203: rpm-4.9.90-header-datalength.patch
|
||||
Patch204: rpm-4.9.90-rpmdeps-args.patch
|
||||
Patch205: rpm-4.9.90-canonarch.patch
|
||||
Patch206: rpm-4.9.90-int-libdb.patch
|
||||
|
||||
# These are not yet upstream
|
||||
Patch301: rpm-4.6.0-niagara.patch
|
||||
@ -88,6 +89,9 @@ BuildRequires: elfutils-libelf-devel%{_isa}
|
||||
BuildRequires: readline-devel%{_isa} zlib-devel%{_isa}
|
||||
BuildRequires: nss-devel%{_isa}
|
||||
BuildRequires: nss-softokn-freebl-devel%{_isa}
|
||||
BuildRequires: libtool%{_isa}
|
||||
BuildRequires: autoconf
|
||||
BuildRequires: automake
|
||||
# The popt version here just documents an older known-good version
|
||||
BuildRequires: popt-devel%{_isa} >= 1.10.2
|
||||
BuildRequires: file-devel%{_isa}
|
||||
@ -225,6 +229,7 @@ packages on a system.
|
||||
%patch203 -p1 -b .header-datalength
|
||||
%patch204 -p1 -b .rpmdeps-args
|
||||
%patch205 -p1 -b .canonarch
|
||||
%patch206 -p1 -b .int-libdb
|
||||
|
||||
%patch301 -p1 -b .niagara
|
||||
%patch302 -p1 -b .geode
|
||||
@ -251,6 +256,11 @@ CPPFLAGS="$CPPFLAGS `pkg-config --cflags nss`"
|
||||
CFLAGS="$RPM_OPT_FLAGS"
|
||||
export CPPFLAGS CFLAGS LDFLAGS
|
||||
|
||||
libtoolize
|
||||
aclocal
|
||||
autoconf
|
||||
automake
|
||||
|
||||
# Using configure macro has some unwanted side-effects on rpm platform
|
||||
# setup, use the old-fashioned way for now only defining minimal paths.
|
||||
./configure \
|
||||
@ -451,6 +461,9 @@ exit 0
|
||||
%doc COPYING doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Tue Apr 03 2012 Jindrich Novy <jnovy@redhat.com> - 4.9.90-0.git11505.11
|
||||
- build with internal libdb to allow libdb build with higher soname
|
||||
|
||||
* Fri Mar 30 2012 Panu Matilainen <pmatilai@redhat.com> - 4.9.90-0.git11505.10
|
||||
- fix base arch macro generation (#808250)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user