- fix build with BDB 4.8.x by removing XA "support" from BDB backend
- perl dep extractor heredoc parsing improvements (#524929) - update extra-provides patch status (its upstream now)
This commit is contained in:
parent
e0a8ab7463
commit
11e840a438
33
rpm-4.7.1-perl-heredoc.patch
Normal file
33
rpm-4.7.1-perl-heredoc.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
commit 007218488a33678c66b19b34ab1ef9fd2ffaec9e
|
||||||
|
Author: Ville Skyttä <ville.skytta@iki.fi>
|
||||||
|
Date: Tue Sep 22 21:11:20 2009 +0300
|
||||||
|
|
||||||
|
Improve perl.req here-doc skipping.
|
||||||
|
|
||||||
|
This version is stricter in finding the end identifier by using equality test
|
||||||
|
instead of a regex (as a side effect, fixes rhbz#524929) as well as parsing
|
||||||
|
quoted identifiers, and adds support for identifiers in backticks.
|
||||||
|
(cherry picked from commit dab575b24498e2362845e7da6dc76015fa88b4a9)
|
||||||
|
|
||||||
|
diff --git a/scripts/perl.req b/scripts/perl.req
|
||||||
|
index 0d26346..4c08dcd 100755
|
||||||
|
--- a/scripts/perl.req
|
||||||
|
+++ b/scripts/perl.req
|
||||||
|
@@ -82,12 +82,14 @@ sub process_file {
|
||||||
|
|
||||||
|
# skip the "= <<" block
|
||||||
|
|
||||||
|
- if ( ( m/^\s*\$(.*)\s*=\s*<<\s*["'](.*)['"]/) ||
|
||||||
|
- ( m/^\s*\$(.*)\s*=\s*<<\s*(.*);/) ) {
|
||||||
|
+ if ( ( m/^\s*\$(?:.*)\s*=\s*<<\s*(["'`])(.*)\1/) ||
|
||||||
|
+ ( m/^\s*\$(.*)\s*=\s*<<(\w*)\s*;/) ) {
|
||||||
|
$tag = $2;
|
||||||
|
while (<FILE>) {
|
||||||
|
- ( $_ =~ /^$tag/) && last;
|
||||||
|
+ chomp;
|
||||||
|
+ ( $_ eq $tag ) && last;
|
||||||
|
}
|
||||||
|
+ $_ = <FILE>;
|
||||||
|
}
|
||||||
|
|
||||||
|
# skip q{} quoted sections - just hope we don't have curly brackets
|
22
rpm-4.7.1-remove-db4-xa.patch
Normal file
22
rpm-4.7.1-remove-db4-xa.patch
Normal file
@ -0,0 +1,22 @@
|
|||||||
|
commit 0482504290d9d2f065dd8cb0d0c697c788724db3
|
||||||
|
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
Date: Mon Sep 21 10:29:38 2009 +0300
|
||||||
|
|
||||||
|
Remove XA "support" from the backend
|
||||||
|
- it's removed from BDB 4.8.x and this has hardly ever done anything anyway
|
||||||
|
(cherry picked from commit 510c6763ef745b308abd1cc6cec2a62119e87c9c)
|
||||||
|
|
||||||
|
diff --git a/lib/backend/dbconfig.c b/lib/backend/dbconfig.c
|
||||||
|
index e668036..2b16241 100644
|
||||||
|
--- a/lib/backend/dbconfig.c
|
||||||
|
+++ b/lib/backend/dbconfig.c
|
||||||
|
@@ -40,9 +40,6 @@ struct poptOption rdbOptions[] = {
|
||||||
|
NULL, NULL },
|
||||||
|
#endif
|
||||||
|
|
||||||
|
- { "xa_create", 0,POPT_BIT_SET, &db3dbi.dbi_cflags, DB_XA_CREATE,
|
||||||
|
- NULL, NULL },
|
||||||
|
-
|
||||||
|
{ "create", 0,POPT_BIT_SET, &db3dbi.dbi_oeflags, DB_CREATE,
|
||||||
|
NULL, NULL },
|
||||||
|
{ "thread", 0,POPT_BIT_SET, &db3dbi.dbi_oeflags, DB_THREAD,
|
14
rpm.spec
14
rpm.spec
@ -21,7 +21,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: 6%{?dist}
|
Release: 7%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.7.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.7.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -47,9 +47,11 @@ Patch204: rpm-4.7.1-chroot-env-paths.patch
|
|||||||
Patch205: rpm-4.7.1-rpm2cpio-init.patch
|
Patch205: rpm-4.7.1-rpm2cpio-init.patch
|
||||||
Patch206: rpm-4.7.1-filedep-dnevr.patch
|
Patch206: rpm-4.7.1-filedep-dnevr.patch
|
||||||
Patch207: rpm-4.7.1-chroot-remove-env.patch
|
Patch207: rpm-4.7.1-chroot-remove-env.patch
|
||||||
|
Patch208: rpm-4.7.1-remove-db4-xa.patch
|
||||||
|
Patch209: rpm-4.7.1-perl-heredoc.patch
|
||||||
|
Patch210: rpm-4.7.0-extra-provides.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch300: rpm-4.7.0-extra-provides.patch
|
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
Patch302: rpm-4.7.1-geode-i686.patch
|
Patch302: rpm-4.7.1-geode-i686.patch
|
||||||
|
|
||||||
@ -208,8 +210,10 @@ packages on a system.
|
|||||||
%patch205 -p1 -b .rpm2cpio.init
|
%patch205 -p1 -b .rpm2cpio.init
|
||||||
%patch206 -p1 -b .filedep-dnevr
|
%patch206 -p1 -b .filedep-dnevr
|
||||||
%patch207 -p1 -b .chroot-remove-env
|
%patch207 -p1 -b .chroot-remove-env
|
||||||
|
%patch208 -p1 -b .remove-db4-xa
|
||||||
|
%patch209 -p1 -b .perl-heredoc
|
||||||
|
%patch210 -p1 -b .extra-prov
|
||||||
|
|
||||||
%patch300 -p1 -b .extra-prov
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
|
|
||||||
@ -423,6 +427,10 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Oct 06 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.1-7
|
||||||
|
- fix build with BDB 4.8.x by removing XA "support" from BDB backend
|
||||||
|
- perl dep extractor heredoc parsing improvements (#524929)
|
||||||
|
|
||||||
* Mon Sep 21 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.1-6
|
* Mon Sep 21 2009 Panu Matilainen <pmatilai@redhat.com> - 4.7.1-6
|
||||||
- use relative paths within db environment (related to #507309, #507309...)
|
- use relative paths within db environment (related to #507309, #507309...)
|
||||||
- remove db environment on close in chrooted operation (related to above)
|
- remove db environment on close in chrooted operation (related to above)
|
||||||
|
Loading…
Reference in New Issue
Block a user