- 4.4.2.2-rc2
- resolves #180996, #281611, #259961, #277161, #155079 - drop debugedit-names patch now that it's really upstream
This commit is contained in:
parent
68e66c4e7e
commit
115a45cd07
@ -1 +1 @@
|
|||||||
rpm-4.4.2.2-rc1.tar.gz
|
rpm-4.4.2.2-rc2.tar.gz
|
||||||
|
@ -1,60 +0,0 @@
|
|||||||
From roland@redhat.com Sun Aug 12 15:45:49 2007
|
|
||||||
Date: Sun, 12 Aug 2007 05:45:16 -0700 (PDT)
|
|
||||||
From: Roland McGrath <roland@redhat.com>
|
|
||||||
To: Panu Matilainen <pmatilai@redhat.com>
|
|
||||||
Cc: Paul Nasrat <pnasrat@redhat.com>
|
|
||||||
Subject: Re: debugedit.c goof
|
|
||||||
|
|
||||||
> No need, already applied upstream HEAD, 4.4.x branch and rawhide build
|
|
||||||
> with the fix triggered.
|
|
||||||
|
|
||||||
Too quick! I have another fix. ;-)
|
|
||||||
|
|
||||||
This one is less trivial, and not tested. It should make it put names in
|
|
||||||
the -l file when they match the edit replace directory name as well as the
|
|
||||||
edit match directory name, the point being that it emits the same names
|
|
||||||
when run twice in a row.
|
|
||||||
|
|
||||||
Thanks,
|
|
||||||
Roland
|
|
||||||
|
|
||||||
|
|
||||||
diff -r fb1ee4c438c9 tools/debugedit.c
|
|
||||||
--- a/tools/debugedit.c Sun Aug 12 15:27:46 2007 +0300
|
|
||||||
+++ b/tools/debugedit.c Sun Aug 12 05:42:13 2007 -0700
|
|
||||||
@@ -567,23 +567,22 @@ edit_dwarf2_line (DSO *dso, uint_32 off,
|
|
||||||
memcpy (s + comp_dir_len + 1 + dir_len + 1, file, file_len + 1);
|
|
||||||
}
|
|
||||||
canonicalize_path (s, s);
|
|
||||||
- if (base_dir == NULL ||
|
|
||||||
- has_prefix (s, base_dir))
|
|
||||||
- {
|
|
||||||
- char *p;
|
|
||||||
- size_t size;
|
|
||||||
- ssize_t ret;
|
|
||||||
- if (base_dir)
|
|
||||||
+ if (list_file_fd != -1)
|
|
||||||
+ {
|
|
||||||
+ char *p = NULL;
|
|
||||||
+ if (base_dir == NULL)
|
|
||||||
+ p = s;
|
|
||||||
+ else if (has_prefix (s, base_dir))
|
|
||||||
p = s + strlen (base_dir);
|
|
||||||
- else
|
|
||||||
- p = s;
|
|
||||||
-
|
|
||||||
- if (list_file_fd != -1)
|
|
||||||
+ else if (has_prefix (s, dest_dir))
|
|
||||||
+ p = s + strlen (dest_dir);
|
|
||||||
+
|
|
||||||
+ if (p)
|
|
||||||
{
|
|
||||||
- size = strlen (p) + 1;
|
|
||||||
+ size_t size = strlen (p) + 1;
|
|
||||||
while (size > 0)
|
|
||||||
{
|
|
||||||
- ret = write (list_file_fd, p, size);
|
|
||||||
+ ssize_t ret = write (list_file_fd, p, size);
|
|
||||||
if (ret == -1)
|
|
||||||
break;
|
|
||||||
size -= ret;
|
|
13
rpm.spec
13
rpm.spec
@ -6,10 +6,10 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 4.4.2.2
|
Version: 4.4.2.2
|
||||||
Release: 0.4.rc1
|
Release: 0.5.rc2
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source: %{name}-%{version}-rc1.tar.gz
|
Source: %{name}-%{version}-rc2.tar.gz
|
||||||
Patch1: rpm-4.4.1-prereq.patch
|
Patch1: rpm-4.4.1-prereq.patch
|
||||||
Patch2: rpm-4.4.2-ghost-conflicts.patch
|
Patch2: rpm-4.4.2-ghost-conflicts.patch
|
||||||
Patch3: rpm-4.4.2-trust.patch
|
Patch3: rpm-4.4.2-trust.patch
|
||||||
@ -17,7 +17,6 @@ Patch4: rpm-4.4.2-devel-autodep.patch
|
|||||||
Patch5: rpm-4.4.2-rpmfc-skip.patch
|
Patch5: rpm-4.4.2-rpmfc-skip.patch
|
||||||
Patch6: rpm-4.4.2-matchpathcon.patch
|
Patch6: rpm-4.4.2-matchpathcon.patch
|
||||||
Patch7: rpm-4.4.2.1-no-popt.patch
|
Patch7: rpm-4.4.2.1-no-popt.patch
|
||||||
Patch8: rpm-4.4.2.1-debuginfo-names.patch
|
|
||||||
|
|
||||||
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
||||||
# and several different components with their own licenses included...
|
# and several different components with their own licenses included...
|
||||||
@ -132,7 +131,7 @@ that will manipulate RPM packages and databases.
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{name}-%{version}-rc1
|
%setup -q -n %{name}-%{version}-rc2
|
||||||
%patch1 -p1 -b .prereq
|
%patch1 -p1 -b .prereq
|
||||||
%patch2 -p1 -b .ghostconflicts
|
%patch2 -p1 -b .ghostconflicts
|
||||||
%patch3 -p1 -b .trust
|
%patch3 -p1 -b .trust
|
||||||
@ -140,7 +139,6 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch5 -p1 -b .fcskip
|
%patch5 -p1 -b .fcskip
|
||||||
%patch6 -p1 -b .matchpathcon
|
%patch6 -p1 -b .matchpathcon
|
||||||
%patch7 -p1 -b .no-popt
|
%patch7 -p1 -b .no-popt
|
||||||
%patch8 -p1 -b .debugedit-names
|
|
||||||
|
|
||||||
# force external popt
|
# force external popt
|
||||||
rm -rf popt/
|
rm -rf popt/
|
||||||
@ -403,6 +401,11 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Sep 11 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-0.5.rc2
|
||||||
|
- 4.4.2.2-rc2
|
||||||
|
- resolves #180996, #281611, #259961, #277161, #155079
|
||||||
|
- drop debugedit-names patch now that it's really upstream
|
||||||
|
|
||||||
* Wed Sep 05 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-0.4.rc1
|
* Wed Sep 05 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-0.4.rc1
|
||||||
- remove duplicated libraries from rpm-devel (#278151)
|
- remove duplicated libraries from rpm-devel (#278151)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user