Also block idle and sleep in the systemd-inhibit plugin
Resolves: #1297984
This commit is contained in:
parent
fbda200dd8
commit
0d0e45ddf5
27
rpm-4.13.0-idle-and-sleep-in-systemd-inhibit.patch
Normal file
27
rpm-4.13.0-idle-and-sleep-in-systemd-inhibit.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 83219d023b5b21826c7482d4aa3f6372f520825d Mon Sep 17 00:00:00 2001
|
||||||
|
From: Florian Festi <ffesti@redhat.com>
|
||||||
|
Date: Fri, 19 Feb 2016 09:56:31 +0100
|
||||||
|
Subject: [PATCH] Also block idle and sleep in the systemd-inhibit plugin
|
||||||
|
|
||||||
|
We really should not suspend or hibernate during rpm operations. Chances are
|
||||||
|
too high to not wake up properly and damage the system (see rhbz#1297984).
|
||||||
|
---
|
||||||
|
plugins/systemd_inhibit.c | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/plugins/systemd_inhibit.c b/plugins/systemd_inhibit.c
|
||||||
|
index b05d3d2..4a90c44 100644
|
||||||
|
--- a/plugins/systemd_inhibit.c
|
||||||
|
+++ b/plugins/systemd_inhibit.c
|
||||||
|
@@ -27,7 +27,7 @@ static int inhibit(void)
|
||||||
|
}
|
||||||
|
|
||||||
|
if (msg) {
|
||||||
|
- const char *what = "shutdown";
|
||||||
|
+ const char *what = "idle:sleep:shutdown";
|
||||||
|
const char *mode = "block";
|
||||||
|
const char *who = "RPM";
|
||||||
|
const char *reason = "Transaction running";
|
||||||
|
--
|
||||||
|
2.5.0
|
||||||
|
|
6
rpm.spec
6
rpm.spec
@ -29,7 +29,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}23%{?dist}
|
Release: %{?snapver:0.%{snapver}.}24%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.12.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -68,6 +68,7 @@ Patch112: rpm-4.13.0-missingok.patch
|
|||||||
Patch113: rpm-4.13.0-recursing-rpmdeps.patch
|
Patch113: rpm-4.13.0-recursing-rpmdeps.patch
|
||||||
Patch114: rpm-4.13.0-autosetup-errors.patch
|
Patch114: rpm-4.13.0-autosetup-errors.patch
|
||||||
Patch115: rpm-4.13.0-unlimited-macro-expand.patch
|
Patch115: rpm-4.13.0-unlimited-macro-expand.patch
|
||||||
|
Patch116: rpm-4.13.0-idle-and-sleep-in-systemd-inhibit.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch302: rpm-4.7.1-geode-i686.patch
|
Patch302: rpm-4.7.1-geode-i686.patch
|
||||||
@ -578,6 +579,9 @@ exit 0
|
|||||||
%doc doc/librpm/html/*
|
%doc doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 19 2016 Florian Festi <ffesti@rpm.org> - 4.4.13.0-0.rc1.24
|
||||||
|
- Also block idle and sleep in the systemd-inhibit plugin (#1297984)
|
||||||
|
|
||||||
* Mon Feb 02 2016 Lubos Kardos <lkardos@redhat.com> - 4.13.0-0.rc1.23
|
* Mon Feb 02 2016 Lubos Kardos <lkardos@redhat.com> - 4.13.0-0.rc1.23
|
||||||
- Remove size limit when expanding macros (#1301677)
|
- Remove size limit when expanding macros (#1301677)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user