- bah, test-suite autofoo breaks due to chmod-test change in configure.ac,
buildrequire autoconf for now
This commit is contained in:
parent
4a8173e79b
commit
0b53f7cb09
@ -10,15 +10,3 @@ diff -up rpm-4.7.2/configure.ac.chmod-test rpm-4.7.2/configure.ac
|
|||||||
rm -f foo.chmodtest
|
rm -f foo.chmodtest
|
||||||
if test "$a" = "-rwxr-xr-x"; then
|
if test "$a" = "-rwxr-xr-x"; then
|
||||||
AC_MSG_RESULT(yes)
|
AC_MSG_RESULT(yes)
|
||||||
diff -up rpm-4.7.2/configure.chmod-test rpm-4.7.2/configure
|
|
||||||
--- rpm-4.7.2/configure.chmod-test 2009-12-04 11:24:06.000000000 +0200
|
|
||||||
+++ rpm-4.7.2/configure 2009-12-04 11:24:51.000000000 +0200
|
|
||||||
@@ -17626,7 +17626,7 @@ $as_echo_n "checking POSIX chmod... " >&
|
|
||||||
touch foo.chmodtest
|
|
||||||
chmod 744 foo.chmodtest
|
|
||||||
chmod +X foo.chmodtest 2>/dev/null
|
|
||||||
-a=`ls -l foo.chmodtest | awk '{print $1}'`
|
|
||||||
+a=`ls -l foo.chmodtest | awk '{print substr($1,1,10)}'`
|
|
||||||
rm -f foo.chmodtest
|
|
||||||
if test "$a" = "-rwxr-xr-x"; then
|
|
||||||
{ $as_echo "$as_me:$LINENO: result: yes" >&5
|
|
||||||
|
3
rpm.spec
3
rpm.spec
@ -97,6 +97,9 @@ BuildRequires: xz-devel >= 4.999.8
|
|||||||
BuildRequires: sqlite-devel
|
BuildRequires: sqlite-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
# XXX temporarily for chmod-test patch
|
||||||
|
BuildRequires: autoconf
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
|
|
||||||
%description
|
%description
|
||||||
|
Loading…
Reference in New Issue
Block a user