- Don't mess up problem pkgNEVR in python ts.check() (#349091)
This commit is contained in:
parent
e3543e0202
commit
078fe119bb
27
rpm-4.4.2.2-pyproblem.patch
Normal file
27
rpm-4.4.2.2-pyproblem.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
changeset: 6193:cc2abc150d64
|
||||||
|
tag: tip
|
||||||
|
user: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
date: Wed Oct 24 09:50:13 2007 +0300
|
||||||
|
summary: Don't mess up problem pkgNEVR in python ts.check() (rhbz#349091)
|
||||||
|
|
||||||
|
diff -r 751cf2c7614e -r cc2abc150d64 python/rpmts-py.c
|
||||||
|
--- a/python/rpmts-py.c Thu Oct 18 09:34:54 2007 +0300
|
||||||
|
+++ b/python/rpmts-py.c Wed Oct 24 09:50:13 2007 +0300
|
||||||
|
@@ -439,7 +439,7 @@ fprintf(stderr, "*** rpmts_Check(%p) ts
|
||||||
|
if (p->type == RPMPROB_BADRELOCATE)
|
||||||
|
continue;
|
||||||
|
|
||||||
|
- byName = p->pkgNEVR;
|
||||||
|
+ byName = strdup(p->pkgNEVR);
|
||||||
|
if ((byArch= strrchr(byName, '.')) != NULL)
|
||||||
|
*byArch++ = '\0';
|
||||||
|
if ((byRelease = strrchr(byName, '-')) != NULL)
|
||||||
|
@@ -475,6 +475,7 @@ fprintf(stderr, "*** rpmts_Check(%p) ts
|
||||||
|
#endif
|
||||||
|
PyList_Append(list, (PyObject *) cf);
|
||||||
|
Py_DECREF(cf);
|
||||||
|
+ free(byName);
|
||||||
|
}
|
||||||
|
|
||||||
|
ps = rpmpsFree(ps);
|
||||||
|
|
7
rpm.spec
7
rpm.spec
@ -6,7 +6,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: 4.4.2.2
|
Version: 4.4.2.2
|
||||||
Release: 5%{?dist}
|
Release: 6%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}.tar.gz
|
Source: http://rpm.org/releases/rpm-4.4.x/%{name}-%{version}.tar.gz
|
||||||
@ -20,6 +20,7 @@ Patch7: rpm-4.4.2.1-no-popt.patch
|
|||||||
Patch8: rpm-4.4.2.2-nonutf-comment.patch
|
Patch8: rpm-4.4.2.2-nonutf-comment.patch
|
||||||
Patch9: rpm-4.4.2.2-osgideps.patch
|
Patch9: rpm-4.4.2.2-osgideps.patch
|
||||||
Patch10: rpm-4.4.2.2-debugedit-fpc.patch
|
Patch10: rpm-4.4.2.2-debugedit-fpc.patch
|
||||||
|
Patch11: rpm-4.4.2.2-pyproblem.patch
|
||||||
|
|
||||||
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
# XXX Beware, this is one murky license, partially GPL/LGPL dual-licensed
|
||||||
# and several different components with their own licenses included...
|
# and several different components with their own licenses included...
|
||||||
@ -146,6 +147,7 @@ that will manipulate RPM packages and databases.
|
|||||||
%patch8 -p1 -b .nonutf-comment
|
%patch8 -p1 -b .nonutf-comment
|
||||||
%patch9 -p1 -b .osgideps
|
%patch9 -p1 -b .osgideps
|
||||||
%patch10 -p1 -b .debugedit-fpc
|
%patch10 -p1 -b .debugedit-fpc
|
||||||
|
%patch11 -p1 -b .pyproblem
|
||||||
|
|
||||||
# force external popt
|
# force external popt
|
||||||
rm -rf popt/
|
rm -rf popt/
|
||||||
@ -408,6 +410,9 @@ exit 0
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Oct 24 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-6
|
||||||
|
- Don't mess up problem pkgNEVR in python ts.check() (#349091)
|
||||||
|
|
||||||
* Mon Oct 22 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-5
|
* Mon Oct 22 2007 Panu Matilainen <pmatilai@redhat.com> 4.4.2.2-5
|
||||||
- add missing popt-devel dependency to rpm-devel
|
- add missing popt-devel dependency to rpm-devel
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user