- fix segfault when building more than one package at a time (#675565)
This commit is contained in:
parent
065f3e2851
commit
05eaef6e80
18
rpm-4.9.0-beta1-rpmugfree.patch
Normal file
18
rpm-4.9.0-beta1-rpmugfree.patch
Normal file
@ -0,0 +1,18 @@
|
|||||||
|
commit ec031020eb7ed9a0cc3d086bcd7ae7611eb308fc
|
||||||
|
Author: Panu Matilainen <pmatilai@redhat.com>
|
||||||
|
Date: Mon Feb 7 09:15:29 2011 +0200
|
||||||
|
|
||||||
|
Fix segfault when building more than one rpm (RhBug:675565)
|
||||||
|
- Remember to set the static string cache pointer to NULL on free, duh
|
||||||
|
|
||||||
|
diff --git a/lib/rpmug.c b/lib/rpmug.c
|
||||||
|
index 2bb18e5..b365e4a 100644
|
||||||
|
--- a/lib/rpmug.c
|
||||||
|
+++ b/lib/rpmug.c
|
||||||
|
@@ -198,5 +198,5 @@ void rpmugFree(void)
|
||||||
|
rpmugGid(NULL, NULL);
|
||||||
|
rpmugUname(-1);
|
||||||
|
rpmugGname(-1);
|
||||||
|
- strCacheFree(strStash);
|
||||||
|
+ strStash = strCacheFree(strStash);
|
||||||
|
}
|
7
rpm.spec
7
rpm.spec
@ -22,7 +22,7 @@
|
|||||||
Summary: The RPM package management system
|
Summary: The RPM package management system
|
||||||
Name: rpm
|
Name: rpm
|
||||||
Version: %{rpmver}
|
Version: %{rpmver}
|
||||||
Release: %{?snapver:0.%{snapver}.}6%{?dist}
|
Release: %{?snapver:0.%{snapver}.}7%{?dist}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
Url: http://www.rpm.org/
|
Url: http://www.rpm.org/
|
||||||
Source0: http://rpm.org/releases/rpm-4.8.x/%{name}-%{srcver}.tar.bz2
|
Source0: http://rpm.org/releases/rpm-4.8.x/%{name}-%{srcver}.tar.bz2
|
||||||
@ -50,6 +50,7 @@ Patch105: rpm-4.9.0-beta1-env-noremove.patch
|
|||||||
Patch106: rpm-4.9.0-beta1-open-cwd.patch
|
Patch106: rpm-4.9.0-beta1-open-cwd.patch
|
||||||
Patch107: rpm-4.9.0-beta1-monodeps.patch
|
Patch107: rpm-4.9.0-beta1-monodeps.patch
|
||||||
Patch108: rpm-4.9.0-beta1-ocaml-magic.patch
|
Patch108: rpm-4.9.0-beta1-ocaml-magic.patch
|
||||||
|
Patch109: rpm-4.9.0-beta1-rpmugfree.patch
|
||||||
|
|
||||||
# These are not yet upstream
|
# These are not yet upstream
|
||||||
Patch301: rpm-4.6.0-niagara.patch
|
Patch301: rpm-4.6.0-niagara.patch
|
||||||
@ -223,6 +224,7 @@ packages on a system.
|
|||||||
%patch106 -p1 -b .open-cwd
|
%patch106 -p1 -b .open-cwd
|
||||||
%patch107 -p1 -b .monodeps
|
%patch107 -p1 -b .monodeps
|
||||||
%patch108 -p1 -b .ocaml-magic
|
%patch108 -p1 -b .ocaml-magic
|
||||||
|
%patch109 -p1 -b .rpmugfree
|
||||||
|
|
||||||
%patch301 -p1 -b .niagara
|
%patch301 -p1 -b .niagara
|
||||||
%patch302 -p1 -b .geode
|
%patch302 -p1 -b .geode
|
||||||
@ -433,6 +435,9 @@ exit 0
|
|||||||
%doc COPYING doc/librpm/html/*
|
%doc COPYING doc/librpm/html/*
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Feb 07 2011 Panu Matilainen <pmatilai@redhat.com> - 4.9.0-0.beta1.7
|
||||||
|
- fix segfault when building more than one package at a time (#675565)
|
||||||
|
|
||||||
* Sun Feb 06 2011 Panu Matilainen <pmatilai@redhat.com> - 4.9.0-0.beta1.6
|
* Sun Feb 06 2011 Panu Matilainen <pmatilai@redhat.com> - 4.9.0-0.beta1.6
|
||||||
- adjust ocaml rule for libmagic string change
|
- adjust ocaml rule for libmagic string change
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user