Add fix for debugedit replace debug_line files.
This commit is contained in:
parent
72b4743645
commit
03607fe128
13
0016-debugedit-replace-files.patch
Normal file
13
0016-debugedit-replace-files.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/tools/debugedit.c b/tools/debugedit.c
|
||||
index 4798c63..87a423f 100644
|
||||
--- a/tools/debugedit.c
|
||||
+++ b/tools/debugedit.c
|
||||
@@ -1185,7 +1185,7 @@ edit_dwarf2_line (DSO *dso)
|
||||
{
|
||||
const char *file = (const char *) optr;
|
||||
const char *file_path = NULL;
|
||||
- if (t->replace_dirs)
|
||||
+ if (t->replace_files)
|
||||
{
|
||||
file_path = skip_dir_prefix (file, base_dir);
|
||||
if (file_path != NULL)
|
6
rpm.spec
6
rpm.spec
@ -29,7 +29,7 @@
|
||||
Summary: The RPM package management system
|
||||
Name: rpm
|
||||
Version: %{rpmver}
|
||||
Release: %{?snapver:0.%{snapver}.}9%{?dist}
|
||||
Release: %{?snapver:0.%{snapver}.}10%{?dist}
|
||||
Group: System Environment/Base
|
||||
Url: http://www.rpm.org/
|
||||
Source0: http://rpm.org/releases/%{srcdir}/%{name}-%{srcver}.tar.bz2
|
||||
@ -87,6 +87,7 @@ Patch261: 0012-generateBuildIDs-Don-t-warn-or-error-for-object-file.patch
|
||||
Patch262: 0013-missing_build_ids_terminate_build.patch
|
||||
Patch263: 0014-generateBuildIDs-Fix-error-handling.patch
|
||||
Patch264: 0015-reset-buildid-file-attrs.patch
|
||||
Patch265: 0016-debugedit-replace-files.patch
|
||||
|
||||
# OpenSSL backend
|
||||
Patch300: 0001-Add-OpenSSL-support-for-digest-and-signatures.patch
|
||||
@ -591,6 +592,9 @@ exit 0
|
||||
%doc doc/librpm/html/*
|
||||
|
||||
%changelog
|
||||
* Thu Mar 16 2017 Mark Wielaard <mjw@redhat.com> - 4.13.0.1-10
|
||||
- Add fix for debugedit replace debug_line files.
|
||||
|
||||
* Thu Mar 16 2017 Igor Gnatenko <ignatenko@redhat.com> - 4.13.0.1-9
|
||||
- Switch to OpenSSL (RHBZ #1390624)
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user