Backport patch to use systemd-0.4.0 crate
Otherwise the `patch.crates-io` directive throws off `cargo vendor` and `cargo build` then tries to fetch from `github.com/jlebon/rust-systemd`.
This commit is contained in:
parent
2f9cc3806a
commit
fca874846e
33
0001-rust-Drop-crates-io-patch-and-use-0.4.0.patch
Normal file
33
0001-rust-Drop-crates-io-patch-and-use-0.4.0.patch
Normal file
@ -0,0 +1,33 @@
|
|||||||
|
From a87486e18e900271a7bd44453ce7c33b33bb78d3 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jonathan Lebon <jonathan@jlebon.com>
|
||||||
|
Date: Thu, 25 Oct 2018 14:52:12 -0400
|
||||||
|
Subject: [PATCH] rust: Drop crates-io patch and use 0.4.0
|
||||||
|
|
||||||
|
The latest release of the crate includes the features and fixes we need.
|
||||||
|
|
||||||
|
Closes: #1639
|
||||||
|
Approved by: cgwalters
|
||||||
|
---
|
||||||
|
rust/Cargo.toml | 6 +-----
|
||||||
|
1 file changed, 1 insertion(+), 5 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
|
||||||
|
index 202d2287..62aa51a4 100644
|
||||||
|
--- a/rust/Cargo.toml
|
||||||
|
+++ b/rust/Cargo.toml
|
||||||
|
@@ -16,11 +16,7 @@ tempfile = "3.0.3"
|
||||||
|
openat = "0.1.15"
|
||||||
|
curl = "0.4.14"
|
||||||
|
c_utf8 = "0.1.0"
|
||||||
|
-systemd = "0.3.0"
|
||||||
|
-
|
||||||
|
-# Until https://github.com/jmesmon/rust-systemd/pull/54 gets merged
|
||||||
|
-[patch.crates-io]
|
||||||
|
-systemd = { git = "https://github.com/jlebon/rust-systemd", branch = "pr/add-monotonic" }
|
||||||
|
+systemd = "0.4.0"
|
||||||
|
|
||||||
|
[lib]
|
||||||
|
name = "rpmostree_rust"
|
||||||
|
--
|
||||||
|
2.17.1
|
||||||
|
|
@ -22,6 +22,8 @@ Source0: rpm-ostree-%{version}.tar.xz
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/projectatomic/rpm-ostree
|
URL: https://github.com/projectatomic/rpm-ostree
|
||||||
|
|
||||||
|
Patch0: 0001-rust-Drop-crates-io-patch-and-use-0.4.0.patch
|
||||||
|
|
||||||
%if %{with rust}
|
%if %{with rust}
|
||||||
%if !%{defined rust_arches}
|
%if !%{defined rust_arches}
|
||||||
# It's not defined yet in the base CentOS7 root
|
# It's not defined yet in the base CentOS7 root
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (rpm-ostree-2018.9.tar.xz) = 14b7d160d73268bd4427d62d1be1a16a8d721bde5edaceea672fbe2fd917617fbeab086325f62dff649c200906b4c4df7098c196039532d5624f14eb4c30c05f
|
SHA512 (rpm-ostree-2018.9.tar.xz) = c83b3ef6d489168ef1ac6afb8718a26f1dce382df97558d47ef1cdaad0aa8b4006dc7c7509734673cff3d0d434ca93ad0d1c3979d15adb13997d458d385b79d3
|
||||||
|
Loading…
Reference in New Issue
Block a user