Release 2019.7

And drop the gcc10 compat patch; it's in the latest bundled libdnf.
This commit is contained in:
Jonathan Lebon 2019-12-19 12:10:37 -05:00
parent 593ee1b507
commit cead07812e
4 changed files with 19 additions and 34 deletions

1
.gitignore vendored
View File

@ -81,3 +81,4 @@
/rpm-ostree-2019.6.tar.xz /rpm-ostree-2019.6.tar.xz
/rpm-ostree-2019.6.24.gfec61ce5.tar.xz /rpm-ostree-2019.6.24.gfec61ce5.tar.xz
/rpm-ostree-2019.6.27.g3b8a1ec6.tar.xz /rpm-ostree-2019.6.27.g3b8a1ec6.tar.xz
/rpm-ostree-2019.7.tar.xz

View File

@ -1,30 +0,0 @@
diff -Nrup a/libdnf/libdnf/goal/Goal.hpp b/libdnf/libdnf/goal/Goal.hpp
--- a/libdnf/libdnf/goal/Goal.hpp 2019-04-26 09:44:27.000000000 -0600
+++ b/libdnf/libdnf/goal/Goal.hpp 2019-10-16 08:11:52.507044805 -0600
@@ -22,6 +22,7 @@
#define __GOAL_HPP
#include <memory>
+#include <stdexcept>
#include "../dnf-types.h"
#include "../hy-goal.h"
diff -Nrup a/libdnf/libdnf/repo/solvable/Dependency.cpp b/libdnf/libdnf/repo/solvable/Dependency.cpp
--- a/libdnf/libdnf/repo/solvable/Dependency.cpp 2019-04-26 09:44:27.000000000 -0600
+++ b/libdnf/libdnf/repo/solvable/Dependency.cpp 2019-10-24 16:42:07.888017106 -0600
@@ -28,6 +28,8 @@ extern "C" {
#include <solv/util.h>
}
+#include <stdexcept>
+
namespace libdnf {
static int transformToLibsolvComparisonType(int cmp_type)
@@ -106,4 +108,4 @@ Dependency::getReldepId(DnfSack *sack, c
}
}
-}
\ No newline at end of file
+}

View File

@ -3,13 +3,12 @@
Summary: Hybrid image/package system Summary: Hybrid image/package system
Name: rpm-ostree Name: rpm-ostree
Version: 2019.6.27.g3b8a1ec6 Version: 2019.7
Release: 2%{?dist} Release: 1%{?dist}
#VCS: https://github.com/cgwalters/rpm-ostree #VCS: https://github.com/cgwalters/rpm-ostree
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot" # This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
# in the upstream git. If rust is enabled, it contains vendored sources. # in the upstream git. If rust is enabled, it contains vendored sources.
Source0: rpm-ostree-%{version}.tar.xz Source0: rpm-ostree-%{version}.tar.xz
Patch0: gcc10.patch
License: LGPLv2+ License: LGPLv2+
URL: https://github.com/projectatomic/rpm-ostree URL: https://github.com/projectatomic/rpm-ostree
@ -23,6 +22,15 @@ BuildRequires: rust
BuildRequires: rust-toolset BuildRequires: rust-toolset
%endif %endif
# RHEL8 doesn't ship zchunk today. See also the comments
# in configure.ac around this as libdnf/librepo need to be in
# sync, and today we bundle libdnf but not librepo.
%if 0%{?rhel}
%bcond_with zchunk
%else
%bcond_without zchunk
%endif
# For the autofiles bits below # For the autofiles bits below
BuildRequires: /usr/bin/python3 BuildRequires: /usr/bin/python3
# We always run autogen.sh # We always run autogen.sh
@ -75,6 +83,9 @@ BuildRequires: pkgconfig(json-c)
BuildRequires: pkgconfig(cppunit) BuildRequires: pkgconfig(cppunit)
BuildRequires: pkgconfig(sqlite3) BuildRequires: pkgconfig(sqlite3)
BuildRequires: pkgconfig(smartcols) BuildRequires: pkgconfig(smartcols)
%if %{with zchunk}
BuildRequires: pkgconfig(zck) >= 0.9.11
%endif
BuildRequires: gpgme-devel BuildRequires: gpgme-devel
Requires: libmodulemd1%{?_isa} >= %{libmodulemd_version} Requires: libmodulemd1%{?_isa} >= %{libmodulemd_version}
@ -179,6 +190,9 @@ $PYTHON autofiles.py > files.devel \
%files devel -f files.devel %files devel -f files.devel
%changelog %changelog
* Thu Dec 19 2019 Jonathan Lebon <jonathan@jlebon.com> - 2019.7
- New upstream version
* Sat Dec 14 2019 Jeff Law <law@redhat.com> - 2019.6.24.gfec61ce5-2 * Sat Dec 14 2019 Jeff Law <law@redhat.com> - 2019.6.24.gfec61ce5-2
- Fix missing #includes for gcc-10 - Fix missing #includes for gcc-10

View File

@ -1 +1 @@
SHA512 (rpm-ostree-2019.6.27.g3b8a1ec6.tar.xz) = d7939c619b59c2331b26fdc041fc53adf4af59ca630a48d4016a878e07d7aa2d78c957cdb1842e9dc96a66e5336da5b005d9b15b2de4d7576ffe473ac90ff3d1 SHA512 (rpm-ostree-2019.7.tar.xz) = e8521becb63df176a125b5407594352af09b2a7ce422b5274c3eec8124fe3ecf20b135739851d254a73018c1aded380651d93b3f2c8b61ac555279e58f3880c9