Resolves: rhbz#2105405
This commit is contained in:
parent
32d046e0ed
commit
97e4c30e6f
1
.gitignore
vendored
1
.gitignore
vendored
@ -106,3 +106,4 @@
|
|||||||
/rpm-ostree-2022.2.tar.xz
|
/rpm-ostree-2022.2.tar.xz
|
||||||
/rpm-ostree-2022.7.tar.xz
|
/rpm-ostree-2022.7.tar.xz
|
||||||
/rpm-ostree-2022.8.tar.xz
|
/rpm-ostree-2022.8.tar.xz
|
||||||
|
/rpm-ostree-2022.11.tar.xz
|
||||||
|
26
0001-build-Drop-dependency-on-rpm-to-4.16.patch
Normal file
26
0001-build-Drop-dependency-on-rpm-to-4.16.patch
Normal file
@ -0,0 +1,26 @@
|
|||||||
|
From c7597899b2718557be30da1b26f3fb1028cbb3aa Mon Sep 17 00:00:00 2001
|
||||||
|
From: Colin Walters <walters@verbum.org>
|
||||||
|
Date: Tue, 12 Jul 2022 15:12:05 -0400
|
||||||
|
Subject: [PATCH] build: Drop dependency on rpm to 4.16
|
||||||
|
|
||||||
|
This is what's in RHEL9 right now.
|
||||||
|
---
|
||||||
|
configure.ac | 2 +-
|
||||||
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index ecdd2c6e..a560446c 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -81,7 +81,7 @@ PKG_PROG_PKG_CONFIG
|
||||||
|
dnl Remember to update AM_CPPFLAGS in Makefile.am when bumping GIO req.
|
||||||
|
PKG_CHECK_MODULES(PKGDEP_GIO_UNIX, [gio-unix-2.0])
|
||||||
|
dnl These are the dependencies of the public librpmostree-1.0.0 shared library
|
||||||
|
-PKG_CHECK_MODULES(PKGDEP_LIBRPMOSTREE, [gio-unix-2.0 >= 2.50.0 json-glib-1.0 ostree-1 >= 2021.2 rpm >= 4.17])
|
||||||
|
+PKG_CHECK_MODULES(PKGDEP_LIBRPMOSTREE, [gio-unix-2.0 >= 2.50.0 json-glib-1.0 ostree-1 >= 2021.2 rpm >= 4.16])
|
||||||
|
dnl And these additional ones are used by for the rpmostreeinternals C/C++ library
|
||||||
|
PKG_CHECK_MODULES(PKGDEP_RPMOSTREE, [polkit-gobject-1 libarchive])
|
||||||
|
|
||||||
|
--
|
||||||
|
2.36.1
|
||||||
|
|
@ -1,40 +0,0 @@
|
|||||||
From 34cdfd6e055e79a659364c5c97ee300d1672379a Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jonathan Lebon <jonathan@jlebon.com>
|
|
||||||
Date: Thu, 2 Jun 2022 11:39:55 -0400
|
|
||||||
Subject: [PATCH] rust/scripts: Ignore `kernel-automotive-core.posttrans`
|
|
||||||
|
|
||||||
Yet another kernel package variant whose %posttrans we want to ignore.
|
|
||||||
|
|
||||||
As mentioned in there, I think we should change the strategy so that we
|
|
||||||
detect kernel packages like we do in the core based on its `Provides` to
|
|
||||||
know to ignore %posttrans.
|
|
||||||
|
|
||||||
Alternatively/additionally, we should work with kernel and systemd teams
|
|
||||||
so that e.g. it short-circuits if it detects an "offline" system. That
|
|
||||||
would also benefit containers, which AFAIK even today runs dracut on
|
|
||||||
kernel installs.
|
|
||||||
|
|
||||||
Closes: #3720
|
|
||||||
---
|
|
||||||
rust/src/scripts.rs | 2 ++
|
|
||||||
1 file changed, 2 insertions(+)
|
|
||||||
|
|
||||||
diff --git a/rust/src/scripts.rs b/rust/src/scripts.rs
|
|
||||||
index 3b15c629..1f59e390 100644
|
|
||||||
--- a/rust/src/scripts.rs
|
|
||||||
+++ b/rust/src/scripts.rs
|
|
||||||
@@ -18,9 +18,11 @@ use phf::phf_set;
|
|
||||||
static IGNORED_PKG_SCRIPTS: phf::Set<&'static str> = phf_set! {
|
|
||||||
"glibc.prein",
|
|
||||||
// We take over depmod/dracut etc. It's `kernel` in C7 and kernel-core in F25+
|
|
||||||
+ // XXX: we should probably change this to instead ignore based on the kernel virtual Provides
|
|
||||||
"kernel.posttrans",
|
|
||||||
"kernel-core.posttrans",
|
|
||||||
"kernel-debug-core.posttrans",
|
|
||||||
+ "kernel-automotive-core.posttrans",
|
|
||||||
// Additionally ignore posttrans scripts for the Oracle Linux `kernel-uek` package
|
|
||||||
"kernel-uek.posttrans",
|
|
||||||
// Legacy workaround
|
|
||||||
--
|
|
||||||
2.36.1
|
|
||||||
|
|
@ -3,14 +3,14 @@
|
|||||||
|
|
||||||
Summary: Hybrid image/package system
|
Summary: Hybrid image/package system
|
||||||
Name: rpm-ostree
|
Name: rpm-ostree
|
||||||
Version: 2022.8
|
Version: 2022.11
|
||||||
Release: 3%{?dist}
|
Release: 2%{?dist}
|
||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/coreos/rpm-ostree
|
URL: https://github.com/coreos/rpm-ostree
|
||||||
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
|
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
|
||||||
# in the upstream git. It also contains vendored Rust sources.
|
# in the upstream git. It also contains vendored Rust sources.
|
||||||
Source0: https://github.com/coreos/rpm-ostree/releases/download/v%{version}/rpm-ostree-%{version}.tar.xz
|
Source0: https://github.com/coreos/rpm-ostree/releases/download/v%{version}/rpm-ostree-%{version}.tar.xz
|
||||||
Patch0: 0001-rust-scripts-Ignore-kernel-automotive-core.posttrans.patch
|
Patch0: 0001-build-Drop-dependency-on-rpm-to-4.16.patch
|
||||||
|
|
||||||
ExclusiveArch: %{rust_arches}
|
ExclusiveArch: %{rust_arches}
|
||||||
|
|
||||||
@ -28,6 +28,13 @@ BuildRequires: rust
|
|||||||
# Embedded unit tests
|
# Embedded unit tests
|
||||||
%bcond_with bin_unit_tests
|
%bcond_with bin_unit_tests
|
||||||
|
|
||||||
|
# This is copied from the libdnf spec
|
||||||
|
%if 0%{?rhel} && ! 0%{?centos}
|
||||||
|
%bcond_without rhsm
|
||||||
|
%else
|
||||||
|
%bcond_with rhsm
|
||||||
|
%endif
|
||||||
|
|
||||||
# RHEL (8,9) doesn't ship zchunk today. Keep this in sync
|
# RHEL (8,9) doesn't ship zchunk today. Keep this in sync
|
||||||
# with libdnf: https://gitlab.com/redhat/centos-stream/rpms/libdnf/-/blob/762f631e36d1e42c63a794882269d26c156b68c1/libdnf.spec#L45
|
# with libdnf: https://gitlab.com/redhat/centos-stream/rpms/libdnf/-/blob/762f631e36d1e42c63a794882269d26c156b68c1/libdnf.spec#L45
|
||||||
%if 0%{?rhel}
|
%if 0%{?rhel}
|
||||||
@ -84,7 +91,7 @@ BuildRequires: jq
|
|||||||
#########################################################################
|
#########################################################################
|
||||||
|
|
||||||
|
|
||||||
%global libsolv_version 0.7.17
|
%global libsolv_version 0.7.21
|
||||||
%global libmodulemd_version 2.13.0
|
%global libmodulemd_version 2.13.0
|
||||||
%global librepo_version 1.13.1
|
%global librepo_version 1.13.1
|
||||||
|
|
||||||
@ -96,14 +103,13 @@ BuildRequires: pkgconfig(librepo) >= %{librepo_version}
|
|||||||
BuildRequires: pkgconfig(check)
|
BuildRequires: pkgconfig(check)
|
||||||
BuildRequires: pkgconfig(gio-unix-2.0) >= 2.46.0
|
BuildRequires: pkgconfig(gio-unix-2.0) >= 2.46.0
|
||||||
BuildRequires: pkgconfig(gtk-doc)
|
BuildRequires: pkgconfig(gtk-doc)
|
||||||
BuildRequires: rpm-devel >= 4.11.0
|
BuildRequires: rpm-devel >= 4.15.0
|
||||||
%if %{with zchunk}
|
%if %{with zchunk}
|
||||||
BuildRequires: pkgconfig(zck) >= 0.9.11
|
BuildRequires: pkgconfig(zck) >= 0.9.11
|
||||||
%endif
|
%endif
|
||||||
BuildRequires: pkgconfig(sqlite3)
|
BuildRequires: pkgconfig(sqlite3)
|
||||||
BuildRequires: pkgconfig(json-c)
|
BuildRequires: pkgconfig(json-c)
|
||||||
BuildRequires: pkgconfig(cppunit)
|
BuildRequires: pkgconfig(cppunit)
|
||||||
BuildRequires: pkgconfig(libcrypto)
|
|
||||||
BuildRequires: pkgconfig(modulemd-2.0) >= %{libmodulemd_version}
|
BuildRequires: pkgconfig(modulemd-2.0) >= %{libmodulemd_version}
|
||||||
BuildRequires: pkgconfig(smartcols)
|
BuildRequires: pkgconfig(smartcols)
|
||||||
BuildRequires: gettext
|
BuildRequires: gettext
|
||||||
@ -113,6 +119,9 @@ BuildRequires: gpgme-devel
|
|||||||
# not in RHEL8. Missing this package breaks -znow.
|
# not in RHEL8. Missing this package breaks -znow.
|
||||||
BuildRequires: libassuan-devel
|
BuildRequires: libassuan-devel
|
||||||
%endif
|
%endif
|
||||||
|
%if %{with rhsm}
|
||||||
|
BuildRequires: pkgconfig(librhsm) >= 0.0.3
|
||||||
|
%endif
|
||||||
|
|
||||||
Requires: libmodulemd%{?_isa} >= %{libmodulemd_version}
|
Requires: libmodulemd%{?_isa} >= %{libmodulemd_version}
|
||||||
Requires: libsolv%{?_isa} >= %{libsolv_version}
|
Requires: libsolv%{?_isa} >= %{libsolv_version}
|
||||||
@ -171,7 +180,8 @@ env NOCONFIGURE=1 ./autogen.sh
|
|||||||
%if 0%{?build_rustflags:1}
|
%if 0%{?build_rustflags:1}
|
||||||
export RUSTFLAGS="%{build_rustflags}"
|
export RUSTFLAGS="%{build_rustflags}"
|
||||||
%endif
|
%endif
|
||||||
%configure --disable-silent-rules --enable-gtk-doc %{?rpmdb_default} %{?with_sanitizers:--enable-sanitizers} %{?with_bin_unit_tests:--enable-bin-unit-tests}
|
%configure --disable-silent-rules --enable-gtk-doc %{?rpmdb_default} %{?with_sanitizers:--enable-sanitizers} %{?with_bin_unit_tests:--enable-bin-unit-tests} \
|
||||||
|
%{?with_rhsm:--enable-featuresrs=rhsm}
|
||||||
|
|
||||||
%make_build
|
%make_build
|
||||||
|
|
||||||
@ -237,6 +247,10 @@ $PYTHON autofiles.py > files.devel \
|
|||||||
|
|
||||||
%files devel -f files.devel
|
%files devel -f files.devel
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jul 11 2022 Colin Walters <walters@verbum.org> - 2022.11-2
|
||||||
|
- https://github.com/coreos/rpm-ostree/releases/tag/v2022.11
|
||||||
|
Resolves: rhbz#2105405
|
||||||
|
|
||||||
* Thu Jun 09 2022 Jonathan Lebon <jonathan@jlebon.com> - 2022.8-3
|
* Thu Jun 09 2022 Jonathan Lebon <jonathan@jlebon.com> - 2022.8-3
|
||||||
- Backport https://github.com/coreos/rpm-ostree/pull/3721
|
- Backport https://github.com/coreos/rpm-ostree/pull/3721
|
||||||
Resolves: rhbz#2094085
|
Resolves: rhbz#2094085
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (rpm-ostree-2022.8.tar.xz) = c2c79430bd9f09c93d7e78ba3243f76ee31baac318fc3cc7a21ccb419dc9967406ea317eedb51c5df4202c47a5f6047999b6287d63d0ba8b0d797162030af3bb
|
SHA512 (rpm-ostree-2022.11.tar.xz) = 6bc12eab5205dc989ce29dfaa3744bc2beaa5490bae64a6834fcb1bd57f47b1e5a3dd93024e9601c748683762b776238a70707cdb78bf59f3a1e3bd09bbb2dc8
|
||||||
|
Loading…
Reference in New Issue
Block a user