Release 2018.10
This commit is contained in:
parent
634dc19315
commit
97346cf780
1
.gitignore
vendored
1
.gitignore
vendored
@ -65,3 +65,4 @@
|
|||||||
/rpm-ostree-2018.7.tar.xz
|
/rpm-ostree-2018.7.tar.xz
|
||||||
/rpm-ostree-2018.8.tar.xz
|
/rpm-ostree-2018.8.tar.xz
|
||||||
/rpm-ostree-2018.9.tar.xz
|
/rpm-ostree-2018.9.tar.xz
|
||||||
|
/rpm-ostree-2018.10.tar.xz
|
||||||
|
28
0001-Revert-compose-Print-devino-cache-hits-on-commit.patch
Normal file
28
0001-Revert-compose-Print-devino-cache-hits-on-commit.patch
Normal file
@ -0,0 +1,28 @@
|
|||||||
|
From 48aae521ca6a6e8098fe85f71dd8ee146e4863c7 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Jonathan Lebon <jonathan@jlebon.com>
|
||||||
|
Date: Fri, 14 Dec 2018 16:31:13 -0500
|
||||||
|
Subject: [PATCH] Revert "compose: Print devino cache hits on commit"
|
||||||
|
|
||||||
|
This reverts commit 0abfcecd3854ce218857bf1071d365dbd351cd4d.
|
||||||
|
---
|
||||||
|
src/app/rpmostree-composeutil.c | 4 ----
|
||||||
|
1 file changed, 4 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/src/app/rpmostree-composeutil.c b/src/app/rpmostree-composeutil.c
|
||||||
|
index 5c478691..544a4790 100644
|
||||||
|
--- a/src/app/rpmostree-composeutil.c
|
||||||
|
+++ b/src/app/rpmostree-composeutil.c
|
||||||
|
@@ -395,10 +395,6 @@ rpmostree_composeutil_write_composejson (OstreeRepo *repo,
|
||||||
|
g_variant_builder_add (builder, "{sv}", "ostree-n-content-written",
|
||||||
|
g_variant_new_uint32 (stats->content_objects_written));
|
||||||
|
|
||||||
|
- g_print ("Content Cache Hits: %u\n", stats->devino_cache_hits);
|
||||||
|
- g_variant_builder_add (builder, "{sv}", "ostree-n-cache-hits",
|
||||||
|
- g_variant_new_uint32 (stats->devino_cache_hits));
|
||||||
|
-
|
||||||
|
g_print ("Content Bytes Written: %" G_GUINT64_FORMAT "\n", stats->content_bytes_written);
|
||||||
|
g_variant_builder_add (builder, "{sv}", "ostree-content-bytes-written",
|
||||||
|
g_variant_new_uint64 (stats->content_bytes_written));
|
||||||
|
--
|
||||||
|
2.17.2
|
||||||
|
|
@ -1,93 +0,0 @@
|
|||||||
From 62a3ffcb42d9af23715f21a8c9b5d688c31c999d Mon Sep 17 00:00:00 2001
|
|
||||||
From: rpm-build <rpm-build>
|
|
||||||
Date: Fri, 2 Nov 2018 11:46:26 -0400
|
|
||||||
Subject: [PATCH] compose: Don't require SELinux policy in legacy path
|
|
||||||
|
|
||||||
In #1630, we lowered SELinux policy loading into the core. However, this
|
|
||||||
also enabled SELinux policy loading from the host system even in the
|
|
||||||
legacy (non-unified) compose path. This meant that compose systems now
|
|
||||||
needed to have the policy installed even though we didn't need it at
|
|
||||||
all. This caused regressions in pungi:
|
|
||||||
|
|
||||||
https://pagure.io/dusty/failed-composes/issue/956
|
|
||||||
|
|
||||||
Just make the binding of the "selinux" member conditional on whether or
|
|
||||||
not we're in unified mode (which is really when we even care about
|
|
||||||
having it loaded from the start for pkgcache purposes).
|
|
||||||
|
|
||||||
Closes: #1656
|
|
||||||
Approved by: cgwalters
|
|
||||||
---
|
|
||||||
src/app/rpmostree-compose-builtin-tree.c | 1 +
|
|
||||||
src/app/rpmostree-composeutil.c | 16 ++++++++++++++--
|
|
||||||
src/app/rpmostree-composeutil.h | 1 +
|
|
||||||
3 files changed, 16 insertions(+), 2 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/src/app/rpmostree-compose-builtin-tree.c b/src/app/rpmostree-compose-builtin-tree.c
|
|
||||||
index 620fa36..4e9d45c 100644
|
|
||||||
--- a/src/app/rpmostree-compose-builtin-tree.c
|
|
||||||
+++ b/src/app/rpmostree-compose-builtin-tree.c
|
|
||||||
@@ -576,6 +576,7 @@ rpm_ostree_compose_context_new (const char *treefile_pathstr,
|
|
||||||
self->treespec = rpmostree_composeutil_get_treespec (self->corectx,
|
|
||||||
self->treefile_rs,
|
|
||||||
self->treefile,
|
|
||||||
+ opt_unified_core,
|
|
||||||
error);
|
|
||||||
if (!self->treespec)
|
|
||||||
return FALSE;
|
|
||||||
diff --git a/src/app/rpmostree-composeutil.c b/src/app/rpmostree-composeutil.c
|
|
||||||
index 820ecfd..621bc85 100644
|
|
||||||
--- a/src/app/rpmostree-composeutil.c
|
|
||||||
+++ b/src/app/rpmostree-composeutil.c
|
|
||||||
@@ -241,6 +241,7 @@ RpmOstreeTreespec *
|
|
||||||
rpmostree_composeutil_get_treespec (RpmOstreeContext *ctx,
|
|
||||||
RORTreefile *treefile_rs,
|
|
||||||
JsonObject *treedata,
|
|
||||||
+ gboolean bind_selinux,
|
|
||||||
GError **error)
|
|
||||||
{
|
|
||||||
GLNX_AUTO_PREFIX_ERROR ("Parsing treefile", error);
|
|
||||||
@@ -255,8 +256,6 @@ rpmostree_composeutil_get_treespec (RpmOstreeContext *ctx,
|
|
||||||
return FALSE;
|
|
||||||
if (!treespec_bind_bool (treedata, treespec, "recommends", TRUE, error))
|
|
||||||
return FALSE;
|
|
||||||
- if (!treespec_bind_bool (treedata, treespec, "selinux", TRUE, error))
|
|
||||||
- return FALSE;
|
|
||||||
if (!treespec_bind_array (treedata, treespec, "install-langs", "instlangs", FALSE, error))
|
|
||||||
return FALSE;
|
|
||||||
{ const char *releasever;
|
|
||||||
@@ -267,6 +266,19 @@ rpmostree_composeutil_get_treespec (RpmOstreeContext *ctx,
|
|
||||||
g_key_file_set_string (treespec, "tree", "releasever", releasever);
|
|
||||||
}
|
|
||||||
|
|
||||||
+ if (bind_selinux)
|
|
||||||
+ {
|
|
||||||
+ if (!treespec_bind_bool (treedata, treespec, "selinux", TRUE, error))
|
|
||||||
+ return FALSE;
|
|
||||||
+ }
|
|
||||||
+ else
|
|
||||||
+ {
|
|
||||||
+ /* In the legacy compose path, we don't want to use any of the core's selinux stuff,
|
|
||||||
+ * e.g. importing, relabeling, etc... so just disable it. We do still set the policy
|
|
||||||
+ * to the final one right before commit as usual. */
|
|
||||||
+ g_key_file_set_boolean (treespec, "tree", "selinux", FALSE);
|
|
||||||
+ }
|
|
||||||
+
|
|
||||||
const char *input_ref = NULL;
|
|
||||||
if (!_rpmostree_jsonutil_object_get_optional_string_member (treedata, "ref", &input_ref, error))
|
|
||||||
return FALSE;
|
|
||||||
diff --git a/src/app/rpmostree-composeutil.h b/src/app/rpmostree-composeutil.h
|
|
||||||
index e3e64c6..3d91f58 100644
|
|
||||||
--- a/src/app/rpmostree-composeutil.h
|
|
||||||
+++ b/src/app/rpmostree-composeutil.h
|
|
||||||
@@ -47,6 +47,7 @@ RpmOstreeTreespec *
|
|
||||||
rpmostree_composeutil_get_treespec (RpmOstreeContext *ctx,
|
|
||||||
RORTreefile *treefile_rs,
|
|
||||||
JsonObject *treedata,
|
|
||||||
+ gboolean bind_selinux,
|
|
||||||
GError **error);
|
|
||||||
|
|
||||||
GHashTable *
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,33 +0,0 @@
|
|||||||
From a87486e18e900271a7bd44453ce7c33b33bb78d3 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Jonathan Lebon <jonathan@jlebon.com>
|
|
||||||
Date: Thu, 25 Oct 2018 14:52:12 -0400
|
|
||||||
Subject: [PATCH] rust: Drop crates-io patch and use 0.4.0
|
|
||||||
|
|
||||||
The latest release of the crate includes the features and fixes we need.
|
|
||||||
|
|
||||||
Closes: #1639
|
|
||||||
Approved by: cgwalters
|
|
||||||
---
|
|
||||||
rust/Cargo.toml | 6 +-----
|
|
||||||
1 file changed, 1 insertion(+), 5 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/rust/Cargo.toml b/rust/Cargo.toml
|
|
||||||
index 202d2287..62aa51a4 100644
|
|
||||||
--- a/rust/Cargo.toml
|
|
||||||
+++ b/rust/Cargo.toml
|
|
||||||
@@ -16,11 +16,7 @@ tempfile = "3.0.3"
|
|
||||||
openat = "0.1.15"
|
|
||||||
curl = "0.4.14"
|
|
||||||
c_utf8 = "0.1.0"
|
|
||||||
-systemd = "0.3.0"
|
|
||||||
-
|
|
||||||
-# Until https://github.com/jmesmon/rust-systemd/pull/54 gets merged
|
|
||||||
-[patch.crates-io]
|
|
||||||
-systemd = { git = "https://github.com/jlebon/rust-systemd", branch = "pr/add-monotonic" }
|
|
||||||
+systemd = "0.4.0"
|
|
||||||
|
|
||||||
[lib]
|
|
||||||
name = "rpmostree_rust"
|
|
||||||
--
|
|
||||||
2.17.1
|
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Hybrid image/package system
|
Summary: Hybrid image/package system
|
||||||
Name: rpm-ostree
|
Name: rpm-ostree
|
||||||
Version: 2018.9
|
Version: 2018.10
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
#VCS: https://github.com/cgwalters/rpm-ostree
|
#VCS: https://github.com/cgwalters/rpm-ostree
|
||||||
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
|
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
|
||||||
# in the upstream git. If rust is enabled, it contains vendored sources.
|
# in the upstream git. If rust is enabled, it contains vendored sources.
|
||||||
@ -9,8 +9,7 @@ Source0: rpm-ostree-%{version}.tar.xz
|
|||||||
License: LGPLv2+
|
License: LGPLv2+
|
||||||
URL: https://github.com/projectatomic/rpm-ostree
|
URL: https://github.com/projectatomic/rpm-ostree
|
||||||
|
|
||||||
Patch0: 0001-rust-Drop-crates-io-patch-and-use-0.4.0.patch
|
Patch0: 0001-Revert-compose-Print-devino-cache-hits-on-commit.patch
|
||||||
Patch1: 0001-compose-Don-t-require-SELinux-policy-in-legacy-path.patch
|
|
||||||
|
|
||||||
%if !%{defined rust_arches}
|
%if !%{defined rust_arches}
|
||||||
# It's not defined yet in the base CentOS7 root
|
# It's not defined yet in the base CentOS7 root
|
||||||
@ -183,6 +182,9 @@ $PYTHON autofiles.py > files.devel \
|
|||||||
%files devel -f files.devel
|
%files devel -f files.devel
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Dec 14 2018 Jonathan Lebon <jonathan@jlebon.com> - 2018.10-1
|
||||||
|
- New upstream version
|
||||||
|
|
||||||
* Tue Dec 04 2018 Jonathan Lebon <jonathan@jlebon.com>
|
* Tue Dec 04 2018 Jonathan Lebon <jonathan@jlebon.com>
|
||||||
- Simplify Rust conditionals
|
- Simplify Rust conditionals
|
||||||
|
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (rpm-ostree-2018.9.tar.xz) = c83b3ef6d489168ef1ac6afb8718a26f1dce382df97558d47ef1cdaad0aa8b4006dc7c7509734673cff3d0d434ca93ad0d1c3979d15adb13997d458d385b79d3
|
SHA512 (rpm-ostree-2018.10.tar.xz) = 7db3327f375bebf6ce1c2a2cf8fab19cf270b90fbf95e7221e63a50e204b8aef153e7df43c792af563a6d586d4d176ee90f51e5807be1eec1199edd60744bd90
|
||||||
|
Loading…
Reference in New Issue
Block a user