parent
6b7575a219
commit
70988d6d32
@ -1,25 +0,0 @@
|
|||||||
From fa250c4e127eab158f5f67485cb28961cbb6b294 Mon Sep 17 00:00:00 2001
|
|
||||||
From: Colin Walters <walters@verbum.org>
|
|
||||||
Date: Fri, 27 Jan 2017 03:07:37 -0500
|
|
||||||
Subject: [PATCH] Back out network namespace usage
|
|
||||||
|
|
||||||
To work around https://pagure.io/releng/issue/6602
|
|
||||||
---
|
|
||||||
src/libpriv/rpmostree-bwrap.c | 1 -
|
|
||||||
1 file changed, 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/src/libpriv/rpmostree-bwrap.c b/src/libpriv/rpmostree-bwrap.c
|
|
||||||
index 40cb3dc..10dfe42 100644
|
|
||||||
--- a/src/libpriv/rpmostree-bwrap.c
|
|
||||||
+++ b/src/libpriv/rpmostree-bwrap.c
|
|
||||||
@@ -208,7 +208,6 @@ rpmostree_bwrap_new (int rootfs_fd,
|
|
||||||
* but it may need some mapping work.
|
|
||||||
*/
|
|
||||||
"--unshare-pid",
|
|
||||||
- "--unshare-net",
|
|
||||||
"--unshare-uts",
|
|
||||||
"--unshare-ipc",
|
|
||||||
"--unshare-cgroup-try",
|
|
||||||
--
|
|
||||||
2.9.3
|
|
||||||
|
|
61
0001-build-Deal-with-gperf-3.1-changing-to-size_t.patch
Normal file
61
0001-build-Deal-with-gperf-3.1-changing-to-size_t.patch
Normal file
@ -0,0 +1,61 @@
|
|||||||
|
From f6842838d709439c30b82ba90324d201b0498dbf Mon Sep 17 00:00:00 2001
|
||||||
|
From: Colin Walters <walters@verbum.org>
|
||||||
|
Date: Fri, 17 Feb 2017 12:29:10 -0500
|
||||||
|
Subject: [PATCH] build: Deal with gperf 3.1 changing to size_t
|
||||||
|
|
||||||
|
https://bugzilla.redhat.com/show_bug.cgi?id=1424268
|
||||||
|
|
||||||
|
Closes: #631
|
||||||
|
Approved by: jlebon
|
||||||
|
---
|
||||||
|
configure.ac | 20 ++++++++++++++++++++
|
||||||
|
src/libpriv/rpmostree-scripts.h | 2 +-
|
||||||
|
2 files changed, 21 insertions(+), 1 deletion(-)
|
||||||
|
|
||||||
|
diff --git a/configure.ac b/configure.ac
|
||||||
|
index 6273806..b088b89 100644
|
||||||
|
--- a/configure.ac
|
||||||
|
+++ b/configure.ac
|
||||||
|
@@ -102,6 +102,26 @@ AC_CHECK_TOOL(GPERF, gperf)
|
||||||
|
AS_IF([test -z "$GPERF"],
|
||||||
|
AC_MSG_ERROR([*** gperf not found])
|
||||||
|
)
|
||||||
|
+dnl stolen from https://github.com/systemd/systemd/commit/c9f7b4d
|
||||||
|
+GPERF_TEST="$(echo foo,bar | ${GPERF} -L ANSI-C)"
|
||||||
|
+AC_COMPILE_IFELSE(
|
||||||
|
+[AC_LANG_PROGRAM([
|
||||||
|
+#include <string.h>
|
||||||
|
+const char * in_word_set(const char *, size_t);
|
||||||
|
+$GPERF_TEST]
|
||||||
|
+)],
|
||||||
|
+[GPERF_LEN_TYPE=size_t],
|
||||||
|
+[AC_COMPILE_IFELSE(
|
||||||
|
+[AC_LANG_PROGRAM([
|
||||||
|
+#include <string.h>
|
||||||
|
+const char * in_word_set(const char *, unsigned);
|
||||||
|
+$GPERF_TEST]
|
||||||
|
+)],
|
||||||
|
+[GPERF_LEN_TYPE=unsigned],
|
||||||
|
+[AC_MSG_ERROR([** unable to determine gperf len type])]
|
||||||
|
+)]
|
||||||
|
+)
|
||||||
|
+AC_DEFINE_UNQUOTED([GPERF_LEN_TYPE], [$GPERF_LEN_TYPE], [gperf len type])
|
||||||
|
|
||||||
|
m4_ifdef([GOBJECT_INTROSPECTION_CHECK], [
|
||||||
|
GOBJECT_INTROSPECTION_CHECK([1.34.0])
|
||||||
|
diff --git a/src/libpriv/rpmostree-scripts.h b/src/libpriv/rpmostree-scripts.h
|
||||||
|
index c981131..87d64d2 100644
|
||||||
|
--- a/src/libpriv/rpmostree-scripts.h
|
||||||
|
+++ b/src/libpriv/rpmostree-scripts.h
|
||||||
|
@@ -43,7 +43,7 @@ struct RpmOstreePackageScriptHandler {
|
||||||
|
RpmOstreeScriptAction action;
|
||||||
|
};
|
||||||
|
|
||||||
|
-const struct RpmOstreePackageScriptHandler* rpmostree_script_gperf_lookup(const char *key, unsigned length);
|
||||||
|
+const struct RpmOstreePackageScriptHandler* rpmostree_script_gperf_lookup(const char *key, GPERF_LEN_TYPE length);
|
||||||
|
|
||||||
|
gboolean rpmostree_script_ignore_hash_from_strv (const char *const *strv,
|
||||||
|
GHashTable **out_hash,
|
||||||
|
--
|
||||||
|
2.9.3
|
||||||
|
|
@ -1,7 +1,7 @@
|
|||||||
Summary: Client side upgrade program and server side compose tool
|
Summary: Client side upgrade program and server side compose tool
|
||||||
Name: rpm-ostree
|
Name: rpm-ostree
|
||||||
Version: 2017.2
|
Version: 2017.2
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
#VCS: https://github.com/cgwalters/rpm-ostree
|
#VCS: https://github.com/cgwalters/rpm-ostree
|
||||||
# This tarball is generated via "make -f Makefile.dist-packaging dist-snapshot"
|
# This tarball is generated via "make -f Makefile.dist-packaging dist-snapshot"
|
||||||
Source0: rpm-ostree-%{version}.tar.xz
|
Source0: rpm-ostree-%{version}.tar.xz
|
||||||
@ -28,6 +28,8 @@ BuildRequires: libattr-devel
|
|||||||
# We currently interact directly with librepo
|
# We currently interact directly with librepo
|
||||||
BuildRequires: pkgconfig(librepo)
|
BuildRequires: pkgconfig(librepo)
|
||||||
|
|
||||||
|
Patch0: 0001-build-Deal-with-gperf-3.1-changing-to-size_t.patch
|
||||||
|
|
||||||
# libhif bundling
|
# libhif bundling
|
||||||
# We're using RPATH to pick up our bundled version
|
# We're using RPATH to pick up our bundled version
|
||||||
%global __requires_exclude ^libhif[.]so[.].*$
|
%global __requires_exclude ^libhif[.]so[.].*$
|
||||||
@ -122,6 +124,10 @@ python autofiles.py > files.devel \
|
|||||||
%files devel -f files.devel
|
%files devel -f files.devel
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Sat Feb 18 2017 Colin Walters <walters@verbum.org> - 2017.2-3
|
||||||
|
- Add patch for gperf 3.1 compatibility
|
||||||
|
Resolves: #1424268
|
||||||
|
|
||||||
* Wed Feb 15 2017 Colin Walters <walters@verbum.org> - 2017.2-2
|
* Wed Feb 15 2017 Colin Walters <walters@verbum.org> - 2017.2-2
|
||||||
- New upstream version
|
- New upstream version
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user