git master snapshot for RHBZ#1565647
This commit is contained in:
parent
1196f1c2b3
commit
32bd097220
1
.gitignore
vendored
1
.gitignore
vendored
@ -61,3 +61,4 @@
|
||||
/rpm-ostree-2018.4.tar.xz
|
||||
/rpm-ostree-2018.5.tar.xz
|
||||
/rpm-ostree-2018.6.tar.xz
|
||||
/rpm-ostree-2018.6.42.gda27b94b.tar.xz
|
||||
|
@ -1,61 +0,0 @@
|
||||
From 696cad7df63dad0ba89a9f2fdfdd05cdf02c0ada Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Mon, 16 Jul 2018 15:05:37 -0400
|
||||
Subject: [PATCH] build-sys: Use python3 for libdnf by default if available
|
||||
|
||||
Probably at some point libdnf will drop py2 support, but the
|
||||
main reason I'm doing this is avoids a python2 dependency
|
||||
for rpm-ostree for distributions that don't want that.
|
||||
---
|
||||
configure.ac | 22 ++++++++++++++++++++++
|
||||
1 file changed, 22 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 66c4a933..043115a6 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -113,6 +113,23 @@ AS_IF([pkg-config --atleast-version=4.13.0.1 rpm], [
|
||||
|
||||
AC_PATH_PROG([XSLTPROC], [xsltproc])
|
||||
|
||||
+dnl This was painful to figure out; it's sad that Automake's
|
||||
+dnl python support doesn't do a better job of optionally supporting
|
||||
+dnl both 2 and 3. Anyways the logic here is: Honor $PYTHON if set
|
||||
+dnl uncondionally, otherwise try python3 if it appears to be available
|
||||
+dnl first, then fall back to 2.
|
||||
+dnl Recommendation is explicit PYTHON=python3 ./configure ...
|
||||
+AS_IF([test -z "$PYTHON"], [
|
||||
+ AS_IF([test -x /usr/bin/python3], [
|
||||
+ AM_PATH_PYTHON([3.6])
|
||||
+ ], [
|
||||
+ AM_PATH_PYTHON([2.7])
|
||||
+ ])
|
||||
+])
|
||||
+dnl http://maemo.org/maemo_training_material/maemo4.x/html/maemo_Application_Development_Chinook/Chapter_05_GNU_Autotools.html
|
||||
+dnl incorrectly says the quoted ']' is @>:@ (...crying...)
|
||||
+pyver=$($PYTHON -c "import sys; sys.stdout.write(sys.version @<:@ :3 @:>@ )")
|
||||
+
|
||||
GLIB_TESTS
|
||||
LIBGLNX_CONFIGURE
|
||||
|
||||
@@ -226,6 +243,10 @@ else
|
||||
export cmake_args
|
||||
fi
|
||||
|
||||
+case $pyver in
|
||||
+ 3.*) cmake_args="${cmake_args} -DPYTHON_DESIRED:str=3";;
|
||||
+esac
|
||||
+
|
||||
dnl I picked /usr/libexec/rpm-ostree just because we need an
|
||||
dnl arbitrary path - we don't actually install there.
|
||||
(set -euo pipefail; mkdir -p libdnf-build && cd libdnf-build &&
|
||||
@@ -257,5 +278,6 @@ echo "
|
||||
introspection: $found_introspection
|
||||
bubblewrap: $with_bubblewrap
|
||||
gtk-doc: $enable_gtk_doc
|
||||
+ python: $PYTHON $pyver
|
||||
rust: $enable_rust
|
||||
"
|
||||
--
|
||||
2.17.1
|
||||
|
@ -1,54 +0,0 @@
|
||||
From 681b194c4bd5d1f677ad8e165d5f31b9d7cbfcd7 Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Mon, 23 Jul 2018 16:37:43 +0000
|
||||
Subject: [PATCH] core: Use new `rpmtsSetVfyLevel()` API for writing rpmdb
|
||||
|
||||
Newer librpm defaults to doing a full payload checksum, which we can't
|
||||
do at this point (writing the db) because we imported the RPMs into
|
||||
ostree commits, saving just the header in metadata - we don't have the
|
||||
exact original content to provide again.
|
||||
|
||||
Ref: https://bugzilla.redhat.com/show_bug.cgi?id=1607223
|
||||
---
|
||||
configure.ac | 4 ++++
|
||||
src/libpriv/rpmostree-core.c | 9 +++++++++
|
||||
2 files changed, 13 insertions(+)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 20a941b4..00b3e38c 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -110,6 +110,10 @@ AS_IF([pkg-config --atleast-version=4.13.0.1 rpm], [
|
||||
AC_DEFINE([BUILDOPT_HAVE_RPM_FILETRIGGERS], 1, [Set to 1 if we have file triggers])
|
||||
AC_DEFINE([BUILDOPT_HAVE_RPMFILES], 1, [Set to 1 if we have rpmfiles API])
|
||||
], [have_modern_rpm=false])
|
||||
+dnl See usage
|
||||
+AS_IF([pkg-config --atleast-version=4.14.2-rc1 rpm], [
|
||||
+ AC_DEFINE([BUILDOPT_HAVE_NEW_RPM_VERIFY], 1, [Set to 1 if we have rpmtsSetVfyLevel ])
|
||||
+])
|
||||
|
||||
AC_PATH_PROG([XSLTPROC], [xsltproc])
|
||||
|
||||
diff --git a/src/libpriv/rpmostree-core.c b/src/libpriv/rpmostree-core.c
|
||||
index 68ac8871..6271d370 100644
|
||||
--- a/src/libpriv/rpmostree-core.c
|
||||
+++ b/src/libpriv/rpmostree-core.c
|
||||
@@ -4010,6 +4010,15 @@ rpmostree_context_assemble (RpmOstreeContext *self,
|
||||
|
||||
g_auto(rpmts) rpmdb_ts = rpmtsCreate ();
|
||||
rpmtsSetVSFlags (rpmdb_ts, _RPMVSF_NOSIGNATURES | _RPMVSF_NODIGESTS);
|
||||
+ /* https://bugzilla.redhat.com/show_bug.cgi?id=1607223 i
|
||||
+ * Newer librpm defaults to doing a full payload checksum, which we can't
|
||||
+ * do at this point because we imported the RPMs into ostree commits, saving
|
||||
+ * just the header in metadata - we don't have the exact original content to
|
||||
+ * provide again.
|
||||
+ */
|
||||
+#ifdef BUILDOPT_HAVE_NEW_RPM_VERIFY
|
||||
+ rpmtsSetVfyLevel (rpmdb_ts, 0);
|
||||
+#endif
|
||||
rpmtsSetFlags (rpmdb_ts, RPMTRANS_FLAG_JUSTDB);
|
||||
|
||||
tdata.ctx = self;
|
||||
--
|
||||
2.17.1
|
||||
|
@ -1,29 +0,0 @@
|
||||
From 7be25521cf639acc77ad8f968eb6c918533e94ec Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Wed, 11 Jul 2018 14:56:32 -0400
|
||||
Subject: [PATCH] libglnx.m4: Include stdio.h for renameat2
|
||||
|
||||
glibc added it upstream:
|
||||
https://sourceware.org/git/?p=glibc.git;a=commit;h=d6da5cb6a8e0e8a9ce92b7d951a254cf325248d7
|
||||
|
||||
But we need the right header.
|
||||
Ref: https://github.com/flatpak/flatpak/issues/1890
|
||||
---
|
||||
libglnx.m4 | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/libglnx.m4 b/libglnx.m4
|
||||
index 34caf20..5922805 100644
|
||||
--- a/libglnx/libglnx.m4
|
||||
+++ b/libglnx/libglnx.m4
|
||||
@@ -7,6 +7,7 @@ AC_CHECK_DECLS([
|
||||
[], [], [[
|
||||
#include <sys/types.h>
|
||||
#include <unistd.h>
|
||||
+#include <stdio.h>
|
||||
#include <sys/mount.h>
|
||||
#include <fcntl.h>
|
||||
#include <sched.h>
|
||||
--
|
||||
2.17.1
|
||||
|
@ -8,15 +8,12 @@
|
||||
|
||||
Summary: Hybrid image/package system
|
||||
Name: rpm-ostree
|
||||
Version: 2018.6
|
||||
Release: 4%{?dist}
|
||||
Version: 2018.6.42.gda27b94b
|
||||
Release: 1%{?dist}
|
||||
#VCS: https://github.com/cgwalters/rpm-ostree
|
||||
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
|
||||
# in the upstream git. If rust is enabled, it contains vendored sources.
|
||||
Source0: rpm-ostree-%{version}.tar.xz
|
||||
Patch1: 0001-build-sys-Use-python3-for-libdnf-by-default-if-avail.patch
|
||||
Patch2: 0001-core-Use-new-rpmtsSetVfyLevel-API-for-writing-rpmdb.patch
|
||||
Patch3: 0001-libglnx.m4-Include-stdio.h-for-renameat2.patch
|
||||
License: LGPLv2+
|
||||
URL: https://github.com/projectatomic/rpm-ostree
|
||||
|
||||
@ -181,6 +178,9 @@ $PYTHON autofiles.py > files.devel \
|
||||
%files devel -f files.devel
|
||||
|
||||
%changelog
|
||||
* Wed Aug 01 2018 Jonathan Lebon <jonathan@jlebon.com> - 2018.6.42.gda27b94b-1
|
||||
- git master snapshot for https://bugzilla.redhat.com/show_bug.cgi?id=1565647
|
||||
|
||||
* Mon Jul 30 2018 Colin Walters <walters@verbum.org> - 2018.6-4
|
||||
- Backport patch for https://bugzilla.redhat.com/show_bug.cgi?id=1607223
|
||||
from https://github.com/projectatomic/rpm-ostree/pull/1469
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (rpm-ostree-2018.6.tar.xz) = bb553229ab5e15e51ce877f230f5c11143d0b88d76e70d2060293e42f7d8d9c631afe92894b68c6b3bea4113af3bea6176d69b5e684b632af5bbebe0a3360e1d
|
||||
SHA512 (rpm-ostree-2018.6.42.gda27b94b.tar.xz) = d4a2c390a95483bb55542018689464c8d1a92d979b29eb3ed2abf8d7ed3159cb279822bfed7383d8f75292015584b1ee60a375a7e6357b8daac6476fd4d390c1
|
||||
|
Loading…
Reference in New Issue
Block a user