import rpm-ostree-2020.7-1.el8
This commit is contained in:
parent
e37517763f
commit
1ed2b5013b
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
SOURCES/rpm-ostree-2020.2.tar.xz
|
||||
SOURCES/rpm-ostree-2020.7.tar.xz
|
||||
|
@ -1 +1 @@
|
||||
c78822f97ac201db308cd39c8fc7d65b296e570c SOURCES/rpm-ostree-2020.2.tar.xz
|
||||
d17719c3f3574bc49348124d5636035a55c8ccdc SOURCES/rpm-ostree-2020.7.tar.xz
|
||||
|
@ -1,41 +0,0 @@
|
||||
From 0bfd20c900e75d8c4a42d80d7e2c3405141dd90b Mon Sep 17 00:00:00 2001
|
||||
From: Colin Walters <walters@verbum.org>
|
||||
Date: Thu, 14 May 2020 00:38:48 +0000
|
||||
Subject: [PATCH] build-sys: Disable zchunk for libdnf if we don't have it
|
||||
|
||||
Going to update rpm-ostree for RHEL 8.3, we did a huge bump
|
||||
in libdnf which now defaults to enabling zchunk in its build
|
||||
system. We added the infrastructure before to detect things,
|
||||
so propagate that to libdnf.
|
||||
---
|
||||
configure.ac | 6 +++++-
|
||||
1 file changed, 5 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 684f202b..57d9ae24 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -131,8 +131,9 @@ AS_IF([pkg-config --atleast-version=4.14.2 rpm], [], [AC_MSG_ERROR([librpm 4.14.
|
||||
|
||||
dnl We don't *actually* use this ourself, but librepo does, and libdnf gets confused
|
||||
dnl if librepo doesn't support it.
|
||||
+have_zchunk=no
|
||||
AS_IF([pkg-config --exists zck],
|
||||
- [AC_DEFINE([HAVE_ZCHUNK], 1, [Define if we have zchunk])])
|
||||
+ [have_zchunk=yes; AC_DEFINE([HAVE_ZCHUNK], 1, [Define if we have zchunk])])
|
||||
|
||||
AC_PATH_PROG([XSLTPROC], [xsltproc])
|
||||
|
||||
@@ -259,6 +260,9 @@ cmake_args=-DCMAKE_BUILD_TYPE=RelWithDebugInfo
|
||||
if test ${debug_release} = debug; then
|
||||
cmake_args="-DCMAKE_BUILD_TYPE=Debug"
|
||||
fi
|
||||
+if test x${have_zchunk} = xno; then
|
||||
+ cmake_args="${cmake_args} -DWITH_ZCHUNK:BOOL=0"
|
||||
+fi
|
||||
export cmake_args
|
||||
|
||||
dnl I picked /usr/libexec/rpm-ostree just because we need an
|
||||
--
|
||||
2.18.4
|
||||
|
@ -3,8 +3,8 @@
|
||||
|
||||
Summary: Hybrid image/package system
|
||||
Name: rpm-ostree
|
||||
Version: 2020.2
|
||||
Release: 2%{?dist}
|
||||
Version: 2020.7
|
||||
Release: 1%{?dist}
|
||||
#VCS: https://github.com/cgwalters/rpm-ostree
|
||||
# This tarball is generated via "cd packaging && make -f Makefile.dist-packaging dist-snapshot"
|
||||
# in the upstream git. If rust is enabled, it contains vendored sources.
|
||||
@ -19,8 +19,6 @@ URL: https://github.com/projectatomic/rpm-ostree
|
||||
|
||||
ExclusiveArch: %{rust_arches}
|
||||
|
||||
Patch0: 0001-build-sys-Disable-zchunk-for-libdnf-if-we-don-t-have.patch
|
||||
|
||||
%if 0%{?fedora}
|
||||
BuildRequires: cargo
|
||||
BuildRequires: rust
|
||||
@ -74,15 +72,16 @@ BuildRequires: gcc-c++
|
||||
|
||||
# more libdnf build deps (see libdnf's spec for versions)
|
||||
%global swig_version 3.0.12
|
||||
%global libmodulemd_version 2.5.0
|
||||
BuildRequires: swig >= %{swig_version}
|
||||
BuildRequires: pkgconfig(modulemd-2.0)
|
||||
BuildRequires: pkgconfig(modulemd-2.0) >= %{libmodulemd_version}
|
||||
BuildRequires: pkgconfig(json-c)
|
||||
BuildRequires: pkgconfig(cppunit)
|
||||
BuildRequires: pkgconfig(sqlite3)
|
||||
BuildRequires: pkgconfig(smartcols)
|
||||
BuildRequires: gpgme-devel
|
||||
|
||||
Requires: libmodulemd1%{?_isa}
|
||||
Requires: libmodulemd%{?_isa} >= %{libmodulemd_version}
|
||||
|
||||
# For now...see https://github.com/projectatomic/rpm-ostree/pull/637
|
||||
# and https://github.com/fedora-infra/fedmsg-atomic-composer/pull/17
|
||||
@ -185,6 +184,15 @@ $PYTHON autofiles.py > files.devel \
|
||||
%files devel -f files.devel
|
||||
|
||||
%changelog
|
||||
* Thu Nov 5 22:45:00 UTC 2020 Colin Walters <walters@verbum.org> - 2020.7-2
|
||||
- Update to 2020.7
|
||||
Resolves: #1894061
|
||||
|
||||
* Wed Jul 29 2020 Jonathan Lebon <jonathan@jlebon.com> - 2020.4-1
|
||||
- New upstream version
|
||||
https://github.com/coreos/rpm-ostree/releases/tag/v2020.4
|
||||
Resolves: #1861786
|
||||
|
||||
* Fri May 15 2020 Colin Walters <walters@verbum.org> - 2020.2-2
|
||||
- https://github.com/coreos/rpm-ostree/releases/tag/v2020.2
|
||||
Resolves: #1827712
|
||||
|
Loading…
Reference in New Issue
Block a user