import rpcsvc-proto-1.3.1-4.el8

This commit is contained in:
CentOS Sources 2019-05-07 08:57:07 -04:00 committed by Andrew Lukoshko
commit 53828ea816
4 changed files with 112 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/rpcsvc-proto-1.3.1.tar.gz

1
.rpcsvc-proto.metadata Normal file
View File

@ -0,0 +1 @@
089db6c72f2471071527a79355a75e9a092b761f SOURCES/rpcsvc-proto-1.3.1.tar.gz

View File

@ -0,0 +1,20 @@
Index: rpcsvc-proto-1.3.1/rpcgen/rpc_main.c
===================================================================
--- rpcsvc-proto-1.3.1.orig/rpcgen/rpc_main.c
+++ rpcsvc-proto-1.3.1/rpcgen/rpc_main.c
@@ -1346,15 +1346,6 @@ parseargs (int argc, const char *argv[],
cmd->Scflag = flag['C'];
cmd->makefileflag = flag['M'];
-#ifndef _RPC_THREAD_SAFE_
- if (mtflag || newstyle)
- {
- /* glibc doesn't support these flags. */
- f_print (stderr,
- _("This implementation doesn't support newstyle or MT-safe code!\n"));
- return (0);
- }
-#endif
if (tirpcflag)
{
pmflag = inetdflag ? 0 : 1; /* pmflag or inetdflag is always TRUE */

90
SPECS/rpcsvc-proto.spec Normal file
View File

@ -0,0 +1,90 @@
#
# spec file for package rpcsvc-proto
#
# Copyright (c) 2017 SUSE LINUX GmbH, Nuernberg, Germany.
#
# All modifications and additions to the file contributed by third parties
# remain the property of their copyright owners, unless otherwise agreed
# upon. The license for this file, and modifications and additions to the
# file, is the same license as for the pristine package itself (unless the
# license for the pristine package is not an Open Source License, in which
# case the license is the MIT License). An "Open Source License" is a
# license that conforms to the Open Source Definition (Version 1.9)
# published by the Open Source Initiative.
# Please submit bugfixes or comments via http://bugs.opensuse.org/
#
Name: rpcsvc-proto
Version: 1.3.1
Release: 4%{?dist}
Summary: RPC protocol definitions
License: BSD and LGPLv2+
Url: https://github.com/thkukuk/rpcsvc-proto
Source0: https://github.com/thkukuk/rpcsvc-proto/archive/v%{version}/%{name}-%{version}.tar.gz
# Enable MT code as libtirpc supports it.
Patch0: rpcsvc-proto-1.3.1-enable_MT_code.patch
Conflicts: glibc-headers < 2.26.9000-36
Conflicts: glibc-common < 2.26.9000-36
BuildRequires: automake, autoconf
%description
The rpcsvc-proto package includes several rpcsvc header files
and RPC protocol definitions from SunRPC sources (as shipped with
glibc).
%package devel
Summary: RPC protocol definitions
%description devel
The rpcsvc-proto package includes several rpcsvc header files
and RPC protocol definitions from SunRPC sources (as shipped with
glibc).
%package -n rpcgen
Summary: RPC protocol compiler
Provides: rpcgen
%description -n rpcgen
rpcgen is a tool that generates C code to implement an RPC protocol.
The input to rpcgen is a language similar to C known as RPC Language
(Remote Procedure Call Language).
%prep
%autosetup -p 1
%build
./autogen.sh
%configure
%make_build
%install
%make_install
# rquota.x and rquota.h are provided by quota
rm -f $RPM_BUILD_ROOT%{_prefix}/include/rpcsvc/rquota.[hx]
%files devel
%license COPYING
%{_includedir}/rpcsvc/
%files -n rpcgen
%{_bindir}/rpcgen
%{_mandir}/man1/rpcgen.1*
%changelog
* Tue Mar 27 2018 Björn Esser <besser82@fedoraproject.org> - 1.3.1-4
- Enable MT code as libtirpc supports it
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 1.3.1-3
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
* Tue Jan 23 2018 Steve Dickson <steved@redhat.com> 1.3.1-2
- Remove rquota.[hx] headers which are provided by quota (bz 1537133)
* Wed Jan 17 2018 Steve Dickson <steved@redhat.com> 1.3.1-1
- Initial commit (bz 1532364)