55 lines
1.6 KiB
Diff
55 lines
1.6 KiB
Diff
diff -up ./Makefile.am.orig ./Makefile.am
|
|
--- ./Makefile.am 2021-07-03 22:22:27.000000000 +0200
|
|
+++ ./Makefile.am 2021-08-06 12:18:48.498612099 +0200
|
|
@@ -1,7 +1,7 @@
|
|
##
|
|
## Toplevel Makefile.am for rng-tools
|
|
##
|
|
-SUBDIRS = contrib tests
|
|
+SUBDIRS = contrib tests jitterentropy-library
|
|
|
|
sbin_PROGRAMS = rngd
|
|
bin_PROGRAMS = rngtest
|
|
@@ -14,7 +14,7 @@ rngd_SOURCES = rngd.h rngd.c rngd_entsou
|
|
if NISTBEACON
|
|
rngd_SOURCES += rngd_nistbeacon.c
|
|
endif
|
|
-
|
|
+
|
|
if RDRAND
|
|
rngd_SOURCES += rngd_rdrand.c rdrand_asm.S
|
|
endif
|
|
@@ -27,29 +27,16 @@ if RNDR
|
|
rngd_SOURCES += rngd_rndr.c
|
|
endif
|
|
|
|
-if JITTER
|
|
rngd_SOURCES += rngd_jitter.c
|
|
-endif
|
|
-
|
|
-if RTLSDR
|
|
-rngd_SOURCES += rngd_rtlsdr.c
|
|
-endif
|
|
|
|
-rngd_LDADD = librngd.a $(LIBS) $(librtlsdr_LIBS) ${libp11_LIBS} ${libcrypto_LIBS} ${jansson_LIBS} ${libcurl_LIBS} ${libxml2_LIBS} ${openssl_LIBS} $(PTHREAD_LIBS)
|
|
+rngd_LDADD = librngd.a $(LIBS) jitterentropy-library/libjitterentropy.a ${libcrypto_LIBS} ${jansson_LIBS} ${libcurl_LIBS} ${libxml2_LIBS} ${openssl_LIBS} $(PTHREAD_LIBS)
|
|
|
|
-if PKCS11
|
|
-rngd_SOURCES += rngd_pkcs11.c
|
|
-pkcs11_ENGINE = -DDEFAULT_PKCS11_ENGINE=\"$(PKCS11_ENGINE)\"
|
|
-endif
|
|
-
|
|
-rngd_CFLAGS = ${pkcs11_CFLAGS} $(librtlsdr_CFLAGS) ${pkcs11_ENGINE} ${libp11_CFLAGS} ${libcrypto_CFLAGS} ${libxml2_CFLAGS} ${openssl_CFLAGS} $(PTHREAD_CFLAGS)
|
|
-rngd_LDFLAGS = $(PTHREAD_CFLAGS)
|
|
+rngd_CFLAGS = ${libcrypto_CFLAGS} ${libxml2_CFLAGS} ${openssl_CFLAGS} $(PTHREAD_CFLAGS) -DHAVE_JITTER -I./jitterentropy-library/
|
|
+rngd_LDFLAGS = $(PTHREAD_CFLAGS)
|
|
|
|
rngtest_SOURCES = exits.h stats.h stats.c rngtest.c
|
|
rngtest_LDADD = librngd.a
|
|
|
|
librngd_a_SOURCES = fips.h fips.c
|
|
|
|
-
|
|
EXTRA_DIST = autogen.sh
|
|
-
|