import rng-tools-6.15-3.el8
This commit is contained in:
parent
4cd71ca72a
commit
4825b1c499
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/jitterentropy-library-3.4.0.tar.gz
|
||||
SOURCES/jitterentropy-library-3.4.1.tar.gz
|
||||
SOURCES/rng-tools-6.15.tar.gz
|
||||
|
@ -1,2 +1,2 @@
|
||||
9b6ad5d20372878cc317a424135c575921d7aa61 SOURCES/jitterentropy-library-3.4.0.tar.gz
|
||||
79de2f603a8d5266691edd5b53efc1a7b6a02cd3 SOURCES/rng-tools-6.15.tar.gz
|
||||
2e3475074ae0c75fc417da553eb70ec160334b18 SOURCES/jitterentropy-library-3.4.1.tar.gz
|
||||
f8720f7aaef3f5ca0d63cf7b88d0de802a358ae0 SOURCES/rng-tools-6.15.tar.gz
|
||||
|
@ -1,8 +1,7 @@
|
||||
diff -up jitterentropy-library/Makefile jitterentropy-library/Makefile
|
||||
--- jitterentropy-library/Makefile 2021-07-13 17:23:42.954652287 +0200
|
||||
+++ jitterentropy-library/Makefile 2021-07-13 17:27:27.958549833 +0200
|
||||
@@ -3,11 +3,11 @@
|
||||
CC ?= gcc
|
||||
@@ -4,7 +4,7 @@ CC ?= gcc
|
||||
#Hardening
|
||||
ENABLE_STACK_PROTECTOR ?= 1
|
||||
CFLAGS ?= -fwrapv --param ssp-buffer-size=4 -fvisibility=hidden -fPIE -Wcast-align -Wmissing-field-initializers -Wshadow -Wswitch-enum
|
||||
@ -11,9 +10,6 @@ diff -up jitterentropy-library/Makefile jitterentropy-library/Makefile
|
||||
LDFLAGS +=-Wl,-z,relro,-z,now -lpthread
|
||||
|
||||
# Enable internal timer support
|
||||
CFLAGS += -DJENT_CONF_ENABLE_INTERNAL_TIMER
|
||||
|
||||
GCCVERSIONFORMAT := $(shell echo `$(CC) -dumpversion | sed 's/\./\n/g' | wc -l`)
|
||||
@@ -28,7 +28,7 @@ LIBDIR := lib
|
||||
INCDIR := include
|
||||
SRCDIR := src
|
||||
|
@ -10,7 +10,7 @@ diff -up Makefile.am Makefile.am
|
||||
|
||||
sbin_PROGRAMS = rngd
|
||||
bin_PROGRAMS = rngtest
|
||||
@@ -27,40 +27,27 @@ if RNDR
|
||||
@@ -23,44 +23,31 @@ if RNDR
|
||||
rngd_SOURCES += rngd_rndr.c
|
||||
endif
|
||||
|
||||
@ -22,6 +22,10 @@ diff -up Makefile.am Makefile.am
|
||||
-rngd_SOURCES += rngd_rtlsdr.c
|
||||
-endif
|
||||
|
||||
if QRYPT
|
||||
rngd_SOURCES += rngd_qrypt.c
|
||||
endif
|
||||
|
||||
-rngd_LDADD = librngd.a $(LIBS) $(librtlsdr_LIBS) ${libp11_LIBS} ${libcrypto_LIBS} ${jansson_LIBS} ${libcurl_LIBS} ${libxml2_LIBS} ${openssl_LIBS} ${libcap_LIBS} $(PTHREAD_LIBS)
|
||||
+rngd_LDADD = librngd.a $(LIBS) jitterentropy-library/libjitterentropy.a ${libcrypto_LIBS} ${jansson_LIBS} ${libcurl_LIBS} ${libxml2_LIBS} ${openssl_LIBS} ${libcap_LIBS} $(PTHREAD_LIBS)
|
||||
|
||||
|
@ -1,14 +0,0 @@
|
||||
--- configure.ac 2022-03-24 13:14:11.000000000 +0100
|
||||
+++ configure.ac.new 2022-03-24 15:58:56.187367770 +0100
|
||||
@@ -95,7 +95,10 @@ AS_IF(
|
||||
[AM_CONDITIONAL([JITTER], [true])
|
||||
AC_DEFINE([HAVE_JITTER],1,[Enable JITTER])
|
||||
AC_CHECK_LIB(jitterentropy, jent_notime_settick,
|
||||
- [AC_DEFINE([HAVE_JITTER_NOTIME],1,[Enable JITTER_NOTIME])],
|
||||
+ [
|
||||
+ AC_DEFINE([HAVE_JITTER_NOTIME],1,[Enable JITTER_NOTIME])
|
||||
+ AC_DEFINE([JENT_CONF_ENABLE_INTERNAL_TIMER],1,[Enable JENT_CONF_ENABLE_INTERNAL_TIMER])
|
||||
+ ],
|
||||
[],-lpthread)],
|
||||
AC_MSG_NOTICE([No Jitterentropy library found]),-lpthread)
|
||||
], [AC_MSG_NOTICE([Disabling JITTER entropy source])]
|
@ -1,6 +1,7 @@
|
||||
[Unit]
|
||||
Description=Hardware RNG Entropy Gatherer Daemon
|
||||
ConditionVirtualization=!container
|
||||
ConditionKernelCommandLine=!fips=1
|
||||
|
||||
# The "-f" option is required for the systemd service rngd to work with Type=simple
|
||||
[Service]
|
||||
|
@ -1,3 +1,3 @@
|
||||
# Optional arguments passed to rngd. See rngd(8) and
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1252175#c21
|
||||
RNGD_ARGS="--fill-watermark=0 -x pkcs11 -x nist -D daemon:daemon"
|
||||
RNGD_ARGS="--fill-watermark=0 -x pkcs11 -x nist -x qrypt -D daemon:daemon"
|
||||
|
@ -3,19 +3,19 @@
|
||||
Summary: Random number generator related utilities
|
||||
Name: rng-tools
|
||||
Version: 6.15
|
||||
Release: 1%{?dist}
|
||||
Release: 3%{?dist}
|
||||
Group: System Environment/Base
|
||||
License: GPLv2+
|
||||
URL: https://github.com/nhorman/rng-tools
|
||||
Source0: %{url}/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
Source1: rngd.service
|
||||
Source2: rngd.sysconfig
|
||||
Source3: jitterentropy-library-3.4.0.tar.gz
|
||||
Source3: jitterentropy-library-3.4.1.tar.gz
|
||||
|
||||
BuildRequires: gcc make binutils
|
||||
BuildRequires: gettext
|
||||
BuildRequires: systemd systemd-rpm-macros
|
||||
BuildRequires: autoconf automake
|
||||
BuildRequires: autoconf >= 2.57, automake >= 1.7
|
||||
BuildRequires: libgcrypt-devel libcurl-devel
|
||||
BuildRequires: libxml2-devel openssl-devel
|
||||
BuildRequires: jansson-devel
|
||||
@ -24,14 +24,16 @@ BuildRequires: libcap-devel
|
||||
Requires(post): systemd
|
||||
Requires(preun): systemd
|
||||
Requires(postun): systemd
|
||||
Requires: selinux-policy >= 3.14.3-98
|
||||
|
||||
# This ensures that the selinux-policy package and all its dependencies
|
||||
# are not pulled into containers and other systems that do not use SELinux.
|
||||
Requires: (selinux-policy >= 3.14.3-98 if selinux-policy)
|
||||
|
||||
Patch0: 1-je-rh-makefile.patch
|
||||
Patch1: 2-je-remove-install.patch
|
||||
Patch2: 3-rt-use-jitter-static.patch
|
||||
Patch3: 4-rt-revert-build-randstat.patch
|
||||
Patch4: 5-rt-comment-out-have-aesni.patch
|
||||
Patch5: 6-rt-fix-jent-define.patch
|
||||
Patch3: 4-rt-comment-out-have-aesni.patch
|
||||
Patch4: 5-rt-revert-build-randstat.patch
|
||||
|
||||
%description
|
||||
This is a random number generator daemon and its tools. It monitors
|
||||
@ -41,7 +43,7 @@ TPM, jitter) and supplies entropy from them to a kernel entropy pool.
|
||||
%prep
|
||||
%setup -q
|
||||
tar xf %{SOURCE3}
|
||||
mv jitterentropy-library-3.4.0 jitterentropy-library
|
||||
mv jitterentropy-library-3.4.1 jitterentropy-library
|
||||
%autopatch -p0
|
||||
|
||||
%build
|
||||
@ -71,7 +73,7 @@ install -D %{SOURCE2} -m0644 %{buildroot}%{_sysconfdir}/sysconfig/rngd
|
||||
%files
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
%license COPYING
|
||||
%doc AUTHORS README
|
||||
%doc AUTHORS README.md
|
||||
%{_bindir}/rngtest
|
||||
%{_sbindir}/rngd
|
||||
%{_mandir}/man1/rngtest.1.*
|
||||
@ -80,6 +82,19 @@ install -D %{SOURCE2} -m0644 %{buildroot}%{_sysconfdir}/sysconfig/rngd
|
||||
%config(noreplace) %attr(0644,root,root) %{_sysconfdir}/sysconfig/rngd
|
||||
|
||||
%changelog
|
||||
* Tue Dec 27 2022 Vladis Dronov <vdronov@redhat.com> - 6.15-3
|
||||
- Update rng-tools to v6.15 @ cb8cc624 (bz 2141379)
|
||||
- Update jitterentropy library to v3.4.1 @ 7bf9f85d
|
||||
- Fix a stack corruption on s390x
|
||||
- Fix a number of issues found by covscan code scanner
|
||||
- Add a jitter init timeout for tests
|
||||
- Add a start condition for the FIPS mode (bz 2154804)
|
||||
|
||||
* Tue Oct 04 2022 Vladis Dronov <vdronov@redhat.com> - 6.15-2
|
||||
- Update rng-tools to v6.15 @ 6dcc9ec2 (bz 2124602)
|
||||
- Update jitterentropy library to v3.4.1 @ 4544e113
|
||||
- Do not require selinux-policy if it is not present
|
||||
|
||||
* Sat Apr 16 2022 Vladis Dronov <vdronov@redhat.com> - 6.15-1
|
||||
- Update rng-tools to v6.15 @ 172bf0e3 (bz 2075974)
|
||||
- Update jitterentropy library to v3.4.0 @ 887c9871
|
||||
|
Loading…
Reference in New Issue
Block a user