import rhn-client-tools-2.10.10-1.0.8.el9
This commit is contained in:
commit
6ad25a45d5
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/rhn-client-tools-2.10.10.tar.gz
|
1
.rhn-client-tools.metadata
Normal file
1
.rhn-client-tools.metadata
Normal file
@ -0,0 +1 @@
|
||||
1a962a171cef70960ed8c00bb436f2bd72ba6b3e SOURCES/rhn-client-tools-2.10.10.tar.gz
|
21
SOURCES/1001-fix-base64-encoding-Bug34372838.patch
Normal file
21
SOURCES/1001-fix-base64-encoding-Bug34372838.patch
Normal file
@ -0,0 +1,21 @@
|
||||
Fix OL9 osad start failure due to base64.encodestring() removal in Python 3.9
|
||||
|
||||
Orabug: 34372838
|
||||
|
||||
Signed-off-by: Laurence Rochfort <laurence.rochfort@oracle.com>
|
||||
Reviewed-by: Darren Kenny <darren.kenny@oracle.com>
|
||||
---
|
||||
diff -ruN rhn-client-tools-2.10.10.orig/src/bin/rhn_check.py rhn-client-tools-2.10.10/src/bin/rhn_check.py
|
||||
--- rhn-client-tools-2.10.10.orig/src/bin/rhn_check.py 2022-07-20 08:00:18.941150794 +0000
|
||||
+++ rhn-client-tools-2.10.10/src/bin/rhn_check.py 2022-07-20 08:19:54.181497449 +0000
|
||||
@@ -289,8 +289,8 @@
|
||||
data['return_code'] = 255
|
||||
data['process_start'] = '1970-01-01 00:00:00' # dummy values as we have no idea of start
|
||||
data['process_end'] = '1970-01-01 00:00:00' # and especially about the end
|
||||
- with open(action_lock) as f:
|
||||
- data['output'] = base64.encodestring(f.read())
|
||||
+ with open(action_lock, 'rb') as f:
|
||||
+ data['output'] = base64.encodebytes(f.read())
|
||||
log.log_debug("Sending back response", (255, "Previous run of action didn't completed sucessfully, aborting.", data))
|
||||
ret = self.submit_response(action['id'], 255, "Previous run of action didn't completed sucessfully, aborting.", data)
|
||||
os.remove(action_lock)
|
@ -0,0 +1,19 @@
|
||||
This is to fix OL9 systems to register with ULN. The platform dist no longer available
|
||||
in OL9 and dist not used in up2dateErrors.py file. The fix is to remove unused dist from
|
||||
up2dateErrors.py file.
|
||||
|
||||
Orabug: 33858443
|
||||
Signed-off-by: PSM Swamiji <psm.swamiji@oracle.com>
|
||||
Signed-off-by: Darren Archibald <darren.archibald@oracle.com>
|
||||
---
|
||||
diff -ruN rhn-client-tools-2.10.10/src/up2date_client/up2dateErrors.py.orig rhn-client-tools-2.10.10/src/up2date_client/up2dateErrors.py
|
||||
--- rhn-client-tools-2.10.10/src/up2date_client/up2dateErrors.py.orig 2022-02-22 09:28:17.442866600 +0530
|
||||
+++ rhn-client-tools-2.10.10/src/up2date_client/up2dateErrors.py 2022-02-22 10:32:09.148452800 +0530
|
||||
@@ -27,7 +27,6 @@
|
||||
t.ugettext = t.gettext
|
||||
_ = t.ugettext
|
||||
import OpenSSL
|
||||
-from platform import dist
|
||||
from rhn.i18n import ustr
|
||||
from up2date_client import config
|
||||
from up2date_client import up2dateLog
|
1577
SPECS/rhn-client-tools.spec
Normal file
1577
SPECS/rhn-client-tools.spec
Normal file
File diff suppressed because it is too large
Load Diff
Loading…
Reference in New Issue
Block a user