import rhn-client-tools-2.8.16-13.module+el8.1.0+3455+3ddf2832

This commit is contained in:
CentOS Sources 2020-12-16 12:53:48 +00:00 committed by Andrew Lukoshko
commit 6283507928
15 changed files with 13546 additions and 0 deletions

1
.gitignore vendored Normal file
View File

@ -0,0 +1 @@
SOURCES/rhn-client-tools-2.8.16.tar.gz

View File

@ -0,0 +1 @@
00925d8eeab654d05263068a9b4004e04cc4612b SOURCES/rhn-client-tools-2.8.16.tar.gz

View File

@ -0,0 +1,23 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 4b46b95..5babf90 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -9,7 +9,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 1%{?dist}
+Release: 2%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -647,6 +647,9 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Mon Feb 19 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-2
+- rebuild for rhel8
+
* Fri Feb 09 2018 Michael Mraka <michael.mraka@redhat.com> 2.8.16-1
- remove install/clean section initial cleanup
- removed Group from specfile

View File

@ -0,0 +1,51 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index a14055c..1d9e477 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -15,7 +15,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 10%{?dist}
+Release: 11%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -689,6 +689,9 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Tue Nov 06 2018 Michael Mraka <michael.mraka@redhat.com> 2.8.16-11
+- Resolves: #1646929 - convert values from bytes to string in py3
+
* Fri Nov 02 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-10
- Resolves: #1626421 - python3 is expecting str, not bytes
(tkasparek@redhat.com)
diff --git a/src/up2date_client/up2dateUtils.py b/src/up2date_client/up2dateUtils.py
index b7d4496..93aea40 100644
--- a/src/up2date_client/up2dateUtils.py
+++ b/src/up2date_client/up2dateUtils.py
@@ -38,8 +38,9 @@ else:
SYSRELVER = 'system-release(releasever)'
version = sstr(h['version'])
release = sstr(h['release'])
- if SYSRELVER in h['providename']:
- provides = dict(zip(h['providename'], h['provideversion']))
+ if SYSRELVER in (sstr(provide) for provide in h['providename']):
+ provides = dict((sstr(n), sstr(v))
+ for n,v in zip(h['providename'], h['provideversion']))
release = '%s-%s' % (version, release)
version = provides[SYSRELVER]
osVersionRelease = (sstr(h['name']), version, release)
@@ -49,8 +50,9 @@ else:
SYSRELVER = 'system-release(releasever)'
version = sstr(h['version'])
release = sstr(h['release'])
- if SYSRELVER in h['providename']:
- provides = dict(zip(h['providename'], h['provideversion']))
+ if SYSRELVER in (sstr(provide) for provide in h['providename']):
+ provides = dict((sstr(n), sstr(v))
+ for n,v in zip(h['providename'], h['provideversion']))
release = '%s-%s' % (version, release)
version = provides[SYSRELVER]
osVersionRelease = (sstr(h['name']), version, release)

View File

@ -0,0 +1,36 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 1d9e477..9dafedf 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -15,7 +15,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 11%{?dist}
+Release: 12%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -689,6 +689,9 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Mon Feb 04 2019 Michael Mraka <michael.mraka@redhat.com> 2.8.16-12
+- Resolves: #1666099 - python3 is picky about bytes and string
+
* Tue Nov 06 2018 Michael Mraka <michael.mraka@redhat.com> 2.8.16-11
- Resolves: #1646929 - convert values from bytes to string in py3
diff --git a/src/up2date_client/config.py b/src/up2date_client/config.py
index 077312f..79d70be 100644
--- a/src/up2date_client/config.py
+++ b/src/up2date_client/config.py
@@ -122,7 +122,7 @@ class ConfigFile:
# possibly split value into a list
values = value.split(";")
if key in ['proxyUser', 'proxyPassword']:
- value = str(value.encode(locale.getpreferredencoding()))
+ value = sstr(value.encode(locale.getpreferredencoding()))
elif len(values) == 1:
try:
value = int(value)

File diff suppressed because it is too large Load Diff

View File

@ -0,0 +1,65 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 5babf90..9c40d15 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -1,4 +1,4 @@
-%if 0%{?fedora} || 0%{?suse_version} > 1320
+%if 0%{?fedora} || 0%{?suse_version} > 1320 || 0%{?rhel} >= 8
%global build_py3 1
%global default_py3 1
%endif
@@ -9,7 +9,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 2%{?dist}
+Release: 3%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -26,7 +26,7 @@ Requires: %{pythonX}-%{name} = %{version}-%{release}
%if 0%{?suse_version}
Requires: zypper
%else
-%if 0%{?fedora}
+%if 0%{?fedora} || 0%{?rhel} >= 8
Requires: dnf
%else
Requires: yum
@@ -48,10 +48,15 @@ BuildRequires: desktop-file-utils
BuildRequires: fedora-logos
BuildRequires: dnf
%endif
+
%if 0%{?rhel}
BuildRequires: redhat-logos
+%if 0%{?rhel} >= 8
+BuildRequires: dnf
+%else
BuildRequires: yum
%endif
+%endif
%description
Red Hat Satellite Client Tools provides programs and libraries to allow your
@@ -147,7 +152,7 @@ Requires: %{pythonX}-rhn-check = %{version}-%{release}
%if 0%{?suse_version}
Requires: zypp-plugin-spacewalk
%else
-%if 0%{?fedora}
+%if 0%{?fedora} || 0%{?rhel} >= 8
Requires: dnf-plugin-spacewalk >= 2.4.0
%else
Requires: yum-rhn-plugin >= 1.6.4-1
@@ -647,6 +652,11 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Tue Feb 20 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-3
+- don't require yum on rhel8 (tkasparek@redhat.com)
+- require dnf-plugin-spacewalk on rhel8 (tkasparek@redhat.com)
+- rhel8 utilizes python3 (tkasparek@redhat.com)
+
* Mon Feb 19 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-2
- rebuild for rhel8

View File

@ -0,0 +1,205 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 9c40d15..7a7a051 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -3,13 +3,17 @@
%global default_py3 1
%endif
+%if ( 0%{?fedora} && 0%{?fedora} < 28 ) || ( 0%{?rhel} && 0%{?rhel} < 8 )
+%global build_py2 1
+%endif
+
%define pythonX %{?default_py3: python3}%{!?default_py3: python2}
%{!?python2_sitelib: %global python2_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 3%{?dist}
+Release: 4%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -62,6 +66,7 @@ BuildRequires: yum
Red Hat Satellite Client Tools provides programs and libraries to allow your
system to receive software updates from Red Hat Satellite or Spacewalk.
+%if 0%{?build_py2}
%package -n python2-%{name}
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
%{?python_provide:%python_provide python2-%{name}}
@@ -112,6 +117,7 @@ Requires: rhnlib >= 2.5.78
%description -n python2-%{name}
Python 2 specific files of %{name}.
+%endif
%if 0%{?build_py3}
%package -n python3-%{name}
@@ -163,6 +169,7 @@ Requires: yum-rhn-plugin >= 1.6.4-1
rhn-check polls a Red Hat Satellite or Spacewalk server to find and execute
scheduled actions.
+%if 0%{?build_py2}
%package -n python2-rhn-check
Summary: Check for RHN actions
%{?python_provide:%python_provide python2-rhn-check}
@@ -170,6 +177,7 @@ Requires: rhn-check = %{version}-%{release}
%description -n python2-rhn-check
Python 2 specific files for rhn-check.
+%endif
%if 0%{?build_py3}
%package -n python3-rhn-check
@@ -195,6 +203,7 @@ Requires: rhnsd
rhn-setup contains programs and utilities to configure a system to use
Red Hat Satellite or Spacewalk, and to register a system with a Red Hat Satellite or Spacewalk server.
+%if 0%{?build_py2}
%package -n python2-rhn-setup
Summary: Configure and register an RHN/Spacewalk client
%{?python_provide:%python_provide python2-rhn-setup}
@@ -208,6 +217,7 @@ Requires: newt-python
%description -n python2-rhn-setup
Python 2 specific files for rhn-setup.
+%endif
%if 0%{?build_py3}
%package -n python3-rhn-setup
@@ -233,6 +243,7 @@ Requires: pam >= 0.72
rhn-setup-gnome contains a GTK+ graphical interface for configuring and
registering a system with a Red Hat Satellite or Spacewalk server.
+%if 0%{?build_py2}
%package -n python2-rhn-setup-gnome
Summary: Configure and register an RHN/Spacewalk client
%{?python_provide:%python_provide python2-rhn-setup-gnome}
@@ -249,6 +260,7 @@ Requires: liberation-sans-fonts
%description -n python2-rhn-setup-gnome
Python 2 specific files for rhn-setup-gnome.
+%endif
%if 0%{?build_py3}
%package -n python3-rhn-setup-gnome
@@ -278,9 +290,11 @@ Python 3 specific files for rhn-setup-gnome.
make -f Makefile.rhn-client-tools
%install
+%if 0%{?build_py2}
make -f Makefile.rhn-client-tools install VERSION=%{version}-%{release} \
PYTHONPATH=%{python_sitelib} PYTHONVERSION=%{python_version} \
PREFIX=$RPM_BUILD_ROOT MANPATH=%{_mandir}
+%endif
%if 0%{?build_py3}
sed -i 's|#!/usr/bin/python|#!/usr/bin/python3|' src/actions/*.py src/bin/*.py test/*.py
make -f Makefile.rhn-client-tools
@@ -310,22 +324,28 @@ mkdir -p $RPM_BUILD_ROOT/%{_presetdir}
install 50-spacewalk-client.preset $RPM_BUILD_ROOT/%{_presetdir}
%endif
+%if 0%{?build_py2}
%if 0%{?fedora} || 0%{?rhel} > 5 || 0%{?suse_version} >= 1140
rm $RPM_BUILD_ROOT%{python_sitelib}/up2date_client/hardware_hal.*
%else
rm $RPM_BUILD_ROOT%{python_sitelib}/up2date_client/hardware_gudev.*
rm $RPM_BUILD_ROOT%{python_sitelib}/up2date_client/hardware_udev.*
%endif
+%endif
%if 0%{?rhel} == 5
+%if 0%{?build_py2}
rm -rf $RPM_BUILD_ROOT%{python_sitelib}/up2date_client/firstboot
+%endif
rm -f $RPM_BUILD_ROOT%{_datadir}/firstboot/modules/rhn_register.*
%endif
%if 0%{?rhel} == 6
rm -rf $RPM_BUILD_ROOT%{_datadir}/firstboot/modules/rhn_*_*.*
%endif
%if ! 0%{?rhel} || 0%{?rhel} > 6
+%if 0%{?build_py2}
rm -rf $RPM_BUILD_ROOT%{python_sitelib}/up2date_client/firstboot
+%endif
rm -rf $RPM_BUILD_ROOT%{_datadir}/firstboot/
%endif
%if 0%{?build_py3}
@@ -415,6 +435,7 @@ make -f Makefile.rhn-client-tools test
%{_presetdir}/50-spacewalk-client.preset
%endif
+%if 0%{?build_py2}
%files -n python2-%{name}
%{_sbindir}/rhn-profile-sync-%{python_version}
%dir %{python_sitelib}/up2date_client/
@@ -439,6 +460,7 @@ make -f Makefile.rhn-client-tools test
%{python_sitelib}/up2date_client/capabilities.*
%{python_sitelib}/up2date_client/rhncli.*
%{python_sitelib}/up2date_client/pkgplatform.*
+%endif
%if 0%{?build_py3}
%files -n python3-%{name}
@@ -493,6 +515,7 @@ make -f Makefile.rhn-client-tools test
%{_mandir}/man8/rhn_check.8*
%{_sbindir}/rhn_check
+%if 0%{?build_py2}
%files -n python2-rhn-check
%{_sbindir}/rhn_check-%{python_version}
%dir %{python_sitelib}/rhn
@@ -505,6 +528,7 @@ make -f Makefile.rhn-client-tools test
%{python_sitelib}/rhn/actions/reboot.*
%{python_sitelib}/rhn/actions/rhnsd.*
%{python_sitelib}/rhn/actions/up2date_config.*
+%endif
%if 0%{?build_py3}
%files -n python3-rhn-check
@@ -553,6 +577,7 @@ make -f Makefile.rhn-client-tools test
%dir %{_datadir}/setuptool/setuptool.d
%endif
+%if 0%{?build_py2}
%files -n python2-rhn-setup
%{_sbindir}/rhn_register-%{python_version}
%{_sbindir}/rhnreg_ks-%{python_version}
@@ -561,6 +586,7 @@ make -f Makefile.rhn-client-tools test
%{python2_sitelib}/up2date_client/pmPlugin.*
%{python2_sitelib}/up2date_client/tui.*
%{python2_sitelib}/up2date_client/rhnreg_constants.*
+%endif
%if 0%{?build_py3}
%files -n python3-rhn-setup
@@ -607,6 +633,7 @@ make -f Makefile.rhn-client-tools test
%dir %{_datadir}/rhn/up2date_client
%endif
+%if 0%{?build_py2}
%files -n python2-rhn-setup-gnome
%{python_sitelib}/up2date_client/messageWindow.*
%{python_sitelib}/up2date_client/rhnregGui.*
@@ -636,6 +663,7 @@ make -f Makefile.rhn-client-tools test
%{python_sitelib}/up2date_client/firstboot/rhn_finish_gui.*
%endif
%endif
+%endif
%if 0%{?build_py3}
%files -n python3-rhn-setup-gnome
@@ -652,6 +680,12 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Tue Mar 20 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-4
+- don't try to delete python2 files when there are none (tkasparek@redhat.com)
+- don't build python2 when building python3 only (tkasparek@redhat.com)
+- don't build python2 subpackages on systems with default python2
+ (tkasparek@redhat.com)
+
* Tue Feb 20 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-3
- don't require yum on rhel8 (tkasparek@redhat.com)
- require dnf-plugin-spacewalk on rhel8 (tkasparek@redhat.com)

View File

@ -0,0 +1,33 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 7a7a051..73ad32d 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -13,7 +13,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 4%{?dist}
+Release: 5%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -23,7 +23,7 @@ BuildRequires: update-desktop-files
%endif
Requires: rpm >= 4.2.3-24_nonptl
-Requires: gnupg
+Requires: /usr/bin/gpg
Requires: coreutils
Requires: %{pythonX}-%{name} = %{version}-%{release}
@@ -680,6 +680,10 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Mon Apr 16 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-5
+- Resolves: #1566025 - require latest provider of /usr/bin/gpg
+ (tkasparek@redhat.com)
+
* Tue Mar 20 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-4
- don't try to delete python2 files when there are none (tkasparek@redhat.com)
- don't build python2 when building python3 only (tkasparek@redhat.com)

View File

@ -0,0 +1,32 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 73ad32d..6284bdf 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -13,7 +13,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 5%{?dist}
+Release: 6%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -290,6 +290,7 @@ Python 3 specific files for rhn-setup-gnome.
make -f Makefile.rhn-client-tools
%install
+export RHEL_ALLOW_PYTHON2_FOR_BUILD=1
%if 0%{?build_py2}
make -f Makefile.rhn-client-tools install VERSION=%{version}-%{release} \
PYTHONPATH=%{python_sitelib} PYTHONVERSION=%{python_version} \
@@ -680,6 +681,10 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Tue Jul 24 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-6
+- set RHEL_ALLOW_PYTHON2_FOR_BUILD=1 to enable using gtk-builder-convert during
+ build (tkasparek@redhat.com)
+
* Mon Apr 16 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-5
- Resolves: #1566025 - require latest provider of /usr/bin/gpg
(tkasparek@redhat.com)

View File

@ -0,0 +1,23 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 6284bdf..ebfe178 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -13,7 +13,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 6%{?dist}
+Release: 7%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -681,6 +681,9 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Tue Jul 24 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-7
+- bump package version
+
* Tue Jul 24 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-6
- set RHEL_ALLOW_PYTHON2_FOR_BUILD=1 to enable using gtk-builder-convert during
build (tkasparek@redhat.com)

View File

@ -0,0 +1,97 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index ebfe178..37010d8 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -13,11 +13,13 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 7%{?dist}
+Release: 8%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
-BuildArch: noarch
+#BuildArch: noarch
+# see BZ 1617942 for more info as Requires are written into RPM headers
+# there's no way how to do this dynamicaly based on arch, so splitting arches is the only option
%if 0%{?suse_version}
BuildRequires: update-desktop-files
%endif
@@ -72,7 +74,9 @@ Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
%{?python_provide:%python_provide python2-%{name}}
Requires: %{name} = %{version}-%{release}
Requires: rpm-python
+%if %{_arch} == x86_64
Requires: python-dmidecode
+%endif
Requires: python-ethtool >= 0.4
Requires: rhnlib >= 2.5.78
BuildRequires: python-devel
@@ -135,7 +139,9 @@ Requires: newt-python3
Requires: python3-gobject-base
%endif
Requires: python3-rpm
+%if %{_arch} == x86_64
Requires: python3-dmidecode
+%endif
Requires: python3-netifaces
Requires: python3-hwdata
Requires: python3-rhnlib >= 2.5.78
@@ -681,6 +687,13 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Thu Sep 27 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-8
+- Related: #1622145 - don't run dmi_warnings() if there's no dmidecode
+ (tkasparek@redhat.com)
+- Related: #1622145 - split into arch package (tkasparek@redhat.com)
+- Resolves: #1622145 - drop dmidecode dependency on non x86_64 arches
+ (tkasparek@redhat.com)
+
* Tue Jul 24 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-7
- bump package version
diff --git a/src/up2date_client/hardware.py b/src/up2date_client/hardware.py
index 0cb9f76..c63df42 100644
--- a/src/up2date_client/hardware.py
+++ b/src/up2date_client/hardware.py
@@ -46,6 +46,12 @@ try:
except ImportError:
netifaces_present = False
+try:
+ import dmidecode
+ dmidecode_present = True
+except ImportError:
+ dmidecode_present = False
+
import gettext
t = gettext.translation('rhn-client-tools', fallback=True)
# Python 3 translations don't have a ugettext method
@@ -54,7 +60,6 @@ if not hasattr(t, 'ugettext'):
_ = t.ugettext
import dbus
-import dmidecode
from up2date_client import up2dateLog
try:
@@ -83,7 +88,7 @@ except ImportError:
# this does not change, we can cache it
_dmi_data = None
-_dmi_not_available = 0
+_dmi_not_available = 0 if dmidecode_present else 1
def dmi_warnings():
if not hasattr(dmidecode, 'get_warnings'):
@@ -91,7 +96,7 @@ def dmi_warnings():
return dmidecode.get_warnings()
-dmi_warn = dmi_warnings()
+dmi_warn = None if _dmi_not_available else dmi_warnings()
if dmi_warn:
dmidecode.clear_warnings()
log = up2dateLog.initLog()

View File

@ -0,0 +1,28 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 37010d8..4ddbaad 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -10,10 +10,12 @@
%define pythonX %{?default_py3: python3}%{!?default_py3: python2}
%{!?python2_sitelib: %global python2_sitelib %(python -c "from distutils.sysconfig import get_python_lib; print get_python_lib()")}
+%global debug_package %{nil}
+
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 8%{?dist}
+Release: 9%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -687,6 +689,9 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Thu Sep 27 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-9
+- Resolves: #1622145 - disable debug* packages (tkasparek@redhat.com)
+
* Thu Sep 27 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-8
- Related: #1622145 - don't run dmi_warnings() if there's no dmidecode
(tkasparek@redhat.com)

View File

@ -0,0 +1,37 @@
diff --git a/rhn-client-tools.spec b/rhn-client-tools.spec
index 4ddbaad..a14055c 100644
--- a/rhn-client-tools.spec
+++ b/rhn-client-tools.spec
@@ -15,7 +15,7 @@
Summary: Support programs and libraries for Red Hat Satellite or Spacewalk
Name: rhn-client-tools
Version: 2.8.16
-Release: 9%{?dist}
+Release: 10%{?dist}
License: GPLv2
Source0: https://github.com/spacewalkproject/spacewalk/archive/%{name}-%{version}.tar.gz
URL: https://github.com/spacewalkproject/spacewalk
@@ -689,6 +689,10 @@ make -f Makefile.rhn-client-tools test
%endif
%changelog
+* Fri Nov 02 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-10
+- Resolves: #1626421 - python3 is expecting str, not bytes
+ (tkasparek@redhat.com)
+
* Thu Sep 27 2018 Tomas Kasparek <tkasparek@redhat.com> 2.8.16-9
- Resolves: #1622145 - disable debug* packages (tkasparek@redhat.com)
diff --git a/src/up2date_client/config.py b/src/up2date_client/config.py
index 242f92e..077312f 100644
--- a/src/up2date_client/config.py
+++ b/src/up2date_client/config.py
@@ -312,7 +312,7 @@ def getProxySetting():
if proxyHost[:7] == "http://":
proxyHost = proxyHost[7:]
parts = proxyHost.split(':')
- parts[0] = idn_ascii_to_puny(parts[0])
+ parts[0] = str(idn_ascii_to_puny(parts[0]))
proxy = ':'.join(parts)
return proxy

1150
SPECS/rhn-client-tools.spec Normal file

File diff suppressed because it is too large Load Diff