Sync with Fedora; network fact gathering

network - role should support running tests with ANSIBLE_GATHERING=explicit
Resolves:rhbz#2100559

Synchronize automation-related changes from Fedora spec file
Resolves:rhbz#2149678
This commit is contained in:
Rich Megginson 2023-01-16 15:48:54 -07:00
parent 33ef5a3554
commit ea1134c9da
9 changed files with 119 additions and 376 deletions

25
.gitignore vendored
View File

@ -389,3 +389,28 @@
/storage-1.9.4.tar.gz
/ha_cluster-1.8.5.tar.gz
/community-general-6.2.0.tar.gz
/ad_integration-1.0.1.tar.gz
/ansible-posix-1.5.1.tar.gz
/ansible-sshd-v0.18.1.tar.gz
/auto-maintenance-d6a8e0167e9ed8d089093b7ead1e298241b534e1.tar.gz
/certificate-1.1.8.tar.gz
/cockpit-1.4.3.tar.gz
/crypto_policies-1.2.7.tar.gz
/firewall-1.4.2.tar.gz
/kdump-1.2.6.tar.gz
/kernel_settings-1.1.11.tar.gz
/logging-1.11.5.tar.gz
/metrics-1.8.1.tar.gz
/nbde_client-1.2.9.tar.gz
/nbde_server-1.3.1.tar.gz
/podman-1.1.1.tar.gz
/postfix-1.3.2.tar.gz
/storage-1.9.5.tar.gz
/timesync-1.7.2.tar.gz
/tlog-1.2.11.tar.gz
/vpn-1.5.3.tar.gz
/postfix-1.3.3.tar.gz
/selinux-1.5.1.tar.gz
/network-1.11.1.tar.gz
/ssh-1.1.12.tar.gz
/nbde_server-1.3.2.tar.gz

View File

@ -1,79 +0,0 @@
From 1bda31d2d07ed9042b09b0596904dd4f317d8f48 Mon Sep 17 00:00:00 2001
From: Jakub Jelen <jjelen@redhat.com>
Date: Mon, 26 Sep 2022 20:20:47 +0200
Subject: [PATCH] Add final version of the option RequiredRSASize (#53)
* Update source template to match generated template
* Add final name of the RequiredRSASize parameter
keeping the old version for backward compatibility.
Upstream commit:
https://github.com/openssh/openssh-portable/commit/54b333d1
---
.dev-tools/10_top.j2 | 4 ++--
.dev-tools/options_body | 1 +
templates/ssh_config.j2 | 3 +++
3 files changed, 6 insertions(+), 2 deletions(-)
diff --git a/.dev-tools/10_top.j2 b/.dev-tools/10_top.j2
index 99704bd..8411de8 100644
--- a/.dev-tools/10_top.j2
+++ b/.dev-tools/10_top.j2
@@ -7,10 +7,10 @@
{% elif value is sameas false %}
{{ key }} no
{% elif value is string or value is number %}
-{{ key }} {{ value }}
+{{ key }} {{ value | string }}
{% else %}
{% for i in value %}
-{{ key }} {{ i }}
+{{ key }} {{ i | string }}
{% endfor %}
{% endif %}
{% endif %}
diff --git a/.dev-tools/options_body b/.dev-tools/options_body
index 176879d..8cc382f 100644
--- a/.dev-tools/options_body
+++ b/.dev-tools/options_body
@@ -84,6 +84,7 @@ RekeyLimit
RemoteCommand
RemoteForward
RequestTTY
+RequiredRSASize
RevokedHostKeys
RhostsRSAAuthentication
RSAAuthentication
diff --git a/templates/ssh_config.j2 b/templates/ssh_config.j2
index fab57de..7f277c7 100644
--- a/templates/ssh_config.j2
+++ b/templates/ssh_config.j2
@@ -119,6 +119,7 @@ Match {{ match["Condition"] }}
{{ render_option("RemoteCommand",match["RemoteCommand"],true) -}}
{{ render_option("RemoteForward",match["RemoteForward"],true) -}}
{{ render_option("RequestTTY",match["RequestTTY"],true) -}}
+{{ render_option("RequiredRSASize",match["RequiredRSASize"],true) -}}
{{ render_option("RevokedHostKeys",match["RevokedHostKeys"],true) -}}
{{ render_option("RhostsRSAAuthentication",match["RhostsRSAAuthentication"],true) -}}
{{ render_option("RSAAuthentication",match["RSAAuthentication"],true) -}}
@@ -240,6 +241,7 @@ Host {{ host["Condition"] }}
{{ render_option("RemoteCommand",host["RemoteCommand"],true) -}}
{{ render_option("RemoteForward",host["RemoteForward"],true) -}}
{{ render_option("RequestTTY",host["RequestTTY"],true) -}}
+{{ render_option("RequiredRSASize",host["RequiredRSASize"],true) -}}
{{ render_option("RevokedHostKeys",host["RevokedHostKeys"],true) -}}
{{ render_option("RhostsRSAAuthentication",host["RhostsRSAAuthentication"],true) -}}
{{ render_option("RSAAuthentication",host["RSAAuthentication"],true) -}}
@@ -354,6 +356,7 @@ Host {{ host["Condition"] }}
{{ body_option("RemoteCommand",ssh_RemoteCommand) -}}
{{ body_option("RemoteForward",ssh_RemoteForward) -}}
{{ body_option("RequestTTY",ssh_RequestTTY) -}}
+{{ body_option("RequiredRSASize",ssh_RequiredRSASize) -}}
{{ body_option("RevokedHostKeys",ssh_RevokedHostKeys) -}}
{{ body_option("RhostsRSAAuthentication",ssh_RhostsRSAAuthentication) -}}
{{ body_option("RSAAuthentication",ssh_RSAAuthentication) -}}
--
2.37.3

View File

@ -1,83 +0,0 @@
From 1408f489240dca04f086e4b32b253313eea28ea8 Mon Sep 17 00:00:00 2001
From: Jakub Jelen <jjelen@redhat.com>
Date: Mon, 26 Sep 2022 15:26:12 +0200
Subject: [PATCH] Add final version of RequiredRSASize
Keep the old version for backward compatibility
Upstream commit:
https://github.com/openssh/openssh-portable/commit/1875042c
---
meta/options_body | 1 +
meta/options_match | 1 +
templates/sshd_config.j2 | 2 ++
templates/sshd_config_snippet.j2 | 2 ++
4 files changed, 6 insertions(+)
diff --git a/meta/options_body b/meta/options_body
index 8681269..23a00f4 100644
--- a/meta/options_body
+++ b/meta/options_body
@@ -89,6 +89,7 @@ PubkeyAuthentication
RSAAuthentication
RSAMinSize
RekeyLimit
+RequiredRSASize
RevokedKeys
RDomain
RhostsRSAAuthentication
diff --git a/meta/options_match b/meta/options_match
index 6ef9214..5ec1413 100644
--- a/meta/options_match
+++ b/meta/options_match
@@ -47,6 +47,7 @@ PubkeyAuthentication
RDomain
RekeyLimit
RevokedKeys
+RequiredRSASize
RhostsRSAAuthentication
RSAAuthentication
RSAMinSize
diff --git a/templates/sshd_config.j2 b/templates/sshd_config.j2
index 2899f0a..a3b2465 100644
--- a/templates/sshd_config.j2
+++ b/templates/sshd_config.j2
@@ -89,6 +89,7 @@ Match {{ match["Condition"] }}
{{ render_option("RDomain",match["RDomain"],true) -}}
{{ render_option("RekeyLimit",match["RekeyLimit"],true) -}}
{{ render_option("RevokedKeys",match["RevokedKeys"],true) -}}
+{{ render_option("RequiredRSASize",match["RequiredRSASize"],true) -}}
{{ render_option("RhostsRSAAuthentication",match["RhostsRSAAuthentication"],true) -}}
{{ render_option("RSAAuthentication",match["RSAAuthentication"],true) -}}
{{ render_option("RSAMinSize",match["RSAMinSize"],true) -}}
@@ -203,6 +204,7 @@ Match {{ match["Condition"] }}
{{ body_option("RSAAuthentication",sshd_RSAAuthentication) -}}
{{ body_option("RSAMinSize",sshd_RSAMinSize) -}}
{{ body_option("RekeyLimit",sshd_RekeyLimit) -}}
+{{ body_option("RequiredRSASize",sshd_RequiredRSASize) -}}
{{ body_option("RevokedKeys",sshd_RevokedKeys) -}}
{{ body_option("RDomain",sshd_RDomain) -}}
{{ body_option("RhostsRSAAuthentication",sshd_RhostsRSAAuthentication) -}}
diff --git a/templates/sshd_config_snippet.j2 b/templates/sshd_config_snippet.j2
index 0ece8ed..a12cb3b 100644
--- a/templates/sshd_config_snippet.j2
+++ b/templates/sshd_config_snippet.j2
@@ -88,6 +88,7 @@ Match {{ match["Condition"] }}
{{ render_option("RDomain",match["RDomain"],true) -}}
{{ render_option("RekeyLimit",match["RekeyLimit"],true) -}}
{{ render_option("RevokedKeys",match["RevokedKeys"],true) -}}
+{{ render_option("RequiredRSASize",match["RequiredRSASize"],true) -}}
{{ render_option("RhostsRSAAuthentication",match["RhostsRSAAuthentication"],true) -}}
{{ render_option("RSAAuthentication",match["RSAAuthentication"],true) -}}
{{ render_option("RSAMinSize",match["RSAMinSize"],true) -}}
@@ -202,6 +203,7 @@ Match {{ match["Condition"] }}
{{ body_option("RSAAuthentication",sshd_RSAAuthentication) -}}
{{ body_option("RSAMinSize",sshd_RSAMinSize) -}}
{{ body_option("RekeyLimit",sshd_RekeyLimit) -}}
+{{ body_option("RequiredRSASize",sshd_RequiredRSASize) -}}
{{ body_option("RevokedKeys",sshd_RevokedKeys) -}}
{{ body_option("RDomain",sshd_RDomain) -}}
{{ body_option("RhostsRSAAuthentication",sshd_RhostsRSAAuthentication) -}}
--
2.37.3

View File

@ -1,6 +1,17 @@
Changelog
=========
[1.21.0-0.15] - 2023-01-20
----------------------------
### New Features
- none
### Bug Fixes
- none
[1.21.0-0.14] - 2023-01-13
----------------------------

10
extrasources.inc Normal file
View File

@ -0,0 +1,10 @@
Source801: https://galaxy.ansible.com/download/ansible-posix-1.5.1.tar.gz
Source901: https://galaxy.ansible.com/download/community-general-6.2.0.tar.gz
Source902: https://galaxy.ansible.com/download/containers-podman-1.10.1.tar.gz
Provides: bundled(ansible-collection(ansible.posix)) = 1.5.1
Provides: bundled(ansible-collection(community.general)) = 6.2.0
Provides: bundled(ansible-collection(containers.podman)) = 1.10.1
Source996: CHANGELOG.rst
Source998: collection_readme.sh

View File

@ -30,7 +30,7 @@ Name: linux-system-roles
Url: https://github.com/linux-system-roles
Summary: Set of interfaces for unified system management
Version: 1.21.0
Release: 0.14%{?dist}
Release: 0.15%{?dist}
License: GPLv3+ and MIT and BSD and Python
%global _pkglicensedir %{_licensedir}/%{name}
@ -107,96 +107,81 @@ Requires: (ansible-core >= 2.11.0 or ansible >= 2.9.0)
%%global rolestodir %%{?rolestodir} %%{roletodir%{1}}
}
#%%defcommit 1 14314822b529520ac12964e0d2938c4bb18ab895
%global mainid d6a8e0167e9ed8d089093b7ead1e298241b534e1
Source: %{url}/auto-maintenance/archive/%{mainid}/auto-maintenance-%{mainid}.tar.gz
# BEGIN AUTOGENERATED SOURCES
%global rolename1 postfix
%deftag 1 1.3.1
%deftag 1 1.3.3
#%%defcommit 2 9fe6eb36772e83b53dcfb8ceb73608fd4f72eeda
%global rolename2 selinux
%deftag 2 1.5.0
%deftag 2 1.5.1
#%%defcommit 3 cbe4bf262bffae3bf53e531662237741954c4182
%global rolename3 timesync
%deftag 3 1.7.1
%deftag 3 1.7.2
#%%defcommit 4 02fc72b482e165472624b2f68eecd2ddce1d93b1
%global rolename4 kdump
%deftag 4 1.2.5
%deftag 4 1.2.6
#%%defcommit 5 a74092634adfe45f76cf761138abab1811692b4b
%global rolename5 network
%deftag 5 1.11.0
%deftag 5 1.11.1
#%%defcommit 6 d7c5eac5d289f141e55ae330d4584eb26fabde39
%global rolename6 storage
%deftag 6 1.9.4
%deftag 6 1.9.5
#%%defcommit 7 d57caa8ca506d8cbc7ca0f96f7cb62b7e965f163
%global rolename7 metrics
%deftag 7 1.8.0
%deftag 7 1.8.1
#%%defcommit 8 2b9e53233ee3a68bdb532e62f289733e436a6106
%global rolename8 tlog
%deftag 8 1.2.10
%deftag 8 1.2.11
#%%defcommit 9 9373303b98e09ef38df7afc8d06e5e55812096c7
%global rolename9 kernel_settings
%deftag 9 1.1.10
%deftag 9 1.1.11
#%%defcommit 10 8330de7e6f0606b1c79999ec4c5f319c6bc80640
%global rolename10 logging
%deftag 10 1.11.4
%deftag 10 1.11.5
#%%defcommit 11 c57d0b1f3384c525738fa26ba4bdca485e162567
%global rolename11 nbde_server
%deftag 11 1.3.0
%deftag 11 1.3.2
#%%defcommit 12 bef2fad5e365712d1f40e53662490ba2550a253f
%global rolename12 nbde_client
%deftag 12 1.2.8
#%%defcommit 13 310fc53db04e8d3134524afb7a89b0477a2ffb83
%global rolename13 certificate
%deftag 13 1.1.6
%deftag 13 1.1.8
#%%defcommit 14 b2a9857ac661fa32e66666e444b73bfdb34cdf95
%global rolename14 crypto_policies
%deftag 14 1.2.6
%deftag 14 1.2.7
%global forgeorg15 https://github.com/willshersystems
%global repo15 ansible-sshd
%global rolename15 sshd
#%%defcommit 15 9766d9097a87a130d4c8abde2247aaad5c925ecf
%deftag 15 v0.18.0
%deftag 15 v0.18.1
#%%defcommit 16 59b9fd7b25607d8bd33bdb082748955f2652846a
%global rolename16 ssh
%deftag 16 1.1.11
%deftag 16 1.1.12
#%%defcommit 17 f901239cb91878719c9e7461760ef8d4789d626d
%global rolename17 ha_cluster
%deftag 17 1.8.5
#%%defcommit 18 d21c896c0d5de83ec3a92d6adf8d14f0324803ca
%global rolename18 vpn
%deftag 18 1.5.2
%deftag 18 1.5.3
%global rolename19 firewall
%deftag 19 1.4.1
%deftag 19 1.4.2
#%%defcommit 20 7e30ef9672ffd1d1daa9c8a6939ca63b3b503b5a
%global rolename20 cockpit
%deftag 20 1.4.2
%deftag 20 1.4.3
%global rolename21 podman
%deftag 21 1.1.0
%deftag 21 1.1.1
#%%defcommit 22 8e536917c4202f847ec8bf53c759b78304019a2f
%global rolename22 ad_integration
%deftag 22 1.0.0
%deftag 22 1.0.1
#%%global rolename23 rhc
#%%deftag 23 1.0.0
%global mainid e3ac549bee05349d7ae033971448f861415ad608
Source: %{url}/auto-maintenance/archive/%{mainid}/auto-maintenance-%{mainid}.tar.gz
Source1: %{archiveurl1}
Source2: %{archiveurl2}
Source3: %{archiveurl3}
@ -219,30 +204,15 @@ Source19: %{archiveurl19}
Source20: %{archiveurl20}
Source21: %{archiveurl21}
Source22: %{archiveurl22}
#Source23: %{archiveurl23}
# END AUTOGENERATED SOURCES
# Not conditionalizing sources per FPC:
# https://docs.fedoraproject.org/en-US/packaging-guidelines/SourceURL/#_do_not_conditionalize_sources
# Collections to vendor on RHEL only, Fedora has these available from RPMs
Source801: https://galaxy.ansible.com/download/ansible-posix-1.4.0.tar.gz
Source901: https://galaxy.ansible.com/download/community-general-6.2.0.tar.gz
Source902: https://galaxy.ansible.com/download/containers-podman-1.10.1.tar.gz
%if 0%{?rhel}
Provides: bundled(ansible-collection(ansible.posix)) = 1.4.0
Provides: bundled(ansible-collection(community.general)) = 6.2.0
Provides: bundled(ansible-collection(containers.podman)) = 1.10.1
%endif
# Includes with definitions/tags that differ between RHEL and Fedora
Source1001: extrasources.inc
%include %{SOURCE1001}
# RHEL only, changelog is auto generated on Fedora
Source995: CHANGELOG.md
Source996: CHANGELOG.rst
# Fedora only, script to convert spec %%changelog into collection CHANGELOG.md
Source997: spec-to-changelog-md.sh
# RHEL only, script to convert the collection README from Galaxy to Automation Hub
Source998: collection_readme.sh
Patch51: network-disable-bondtests.diff
BuildArch: noarch
@ -300,7 +270,9 @@ for i,v in ipairs(roles) do
end
%prep
# BEGIN AUTOGENERATED SETUP
%setup -q -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a12 -a13 -a14 -a15 -a16 -a17 -a18 -a19 -a20 -a21 -a22 -n %{getarchivedir 0}
# END AUTOGENERATED SETUP
%if 0%{?rhel}
# Untar vendored collection tarballs to corresponding directories
@ -332,16 +304,14 @@ for rolename in %{rolenames}; do
mv "$dir_from_archive" ${rolename}
done
%if 0%{?rhel}
cd %{rolename2}/tests
# this test causes avcs we want to ignore
sed -r -i -e '/hosts: all/a\
tags:\
- tests::avc' tests_selinux_disabled.yml
cd ../..
cd %{rolename5}
%patch51 -p1
cd ..
%endif
cd %{rolename15}
find -P tests examples -name \*.yml | while read file; do
@ -552,15 +522,17 @@ for role in %{rolenames}; do
.collections/ansible_collections/%{collection_namespace}/%{collection_name}/roles/$role/README.md
done
%if 0%{?rhel}
# Remove test only collection dependencies
# NOTE: These should not be in meta/collection-requirements.yml, they should be
# in tests/collection-requirements.yml, but they can't be moved yet
sed -i -e '/community[.]mysql:/d' -e '/community[.]postgresql:/d' \
.collections/ansible_collections/%{collection_namespace}/%{collection_name}/galaxy.yml
cp %{SOURCE995} \
.collections/ansible_collections/%{collection_namespace}/%{collection_name}/docs/CHANGELOG.md
%if 0%{?rhel}
cp %{SOURCE996} \
.collections/ansible_collections/%{collection_namespace}/%{collection_name}/CHANGELOG.rst
%else
# Build the collection CHANGELOG.md
%{SOURCE997} %{_specdir}/%{name}.spec \
.collections/ansible_collections/%{collection_namespace}/%{collection_name}/docs/CHANGELOG.md
%endif
# Build the collection
@ -770,6 +742,12 @@ find %{buildroot}%{ansible_roles_dir} -mindepth 1 -maxdepth 1 | \
%endif
%changelog
* Fri Jan 20 2023 Rich Megginson <rmeggins@redhat.com> - 1.21.0-0.15
- Resolves:rhbz#2149678 : Synchronize automation-related changes from Fedora spec file
- Resolves:rhbz#2100559 : network - role should support running tests with ANSIBLE_GATHERING=explicit
- Fix ansible-test issues in several roles
- Fix nbde_server tang test failure
* Fri Jan 13 2023 Rich Megginson <rmeggins@redhat.com> - 1.21.0-0.14
- Resolves:rhbz#2140804 : ha_cluster - Allow quorum device configuration
- Resolves:rhbz#2153030 : ha_cluster - Allow enabled SBD on disabled cluster

View File

@ -1,65 +0,0 @@
From d6c8319f52f3859b28044841063adf0013df878b Mon Sep 17 00:00:00 2001
From: Rich Megginson <rmeggins@redhat.com>
Date: Thu, 25 Mar 2021 13:57:45 -0600
Subject: [PATCH 3/4] Patch53: network-disable-bondtests.diff
---
tests/playbooks/tests_bond.yml | 2 ++
tests/playbooks/tests_bond_deprecated.yml | 2 ++
tests/tests_bond_deprecated_initscripts.yml | 1 +
tests/tests_bond_initscripts.yml | 1 +
4 files changed, 6 insertions(+)
diff --git a/tests/playbooks/tests_bond.yml b/tests/playbooks/tests_bond.yml
index 1e45788..d3005a6 100644
--- a/tests/playbooks/tests_bond.yml
+++ b/tests/playbooks/tests_bond.yml
@@ -8,6 +8,8 @@
dhcp_interface1: test1
port2_profile: bond0.1
dhcp_interface2: test2
+ tags:
+ - "tests::expfail"
tasks:
- name: "INIT Prepare setup"
debug:
diff --git a/tests/playbooks/tests_bond_deprecated.yml b/tests/playbooks/tests_bond_deprecated.yml
index f37e19a..ae475c4 100644
--- a/tests/playbooks/tests_bond_deprecated.yml
+++ b/tests/playbooks/tests_bond_deprecated.yml
@@ -8,6 +8,8 @@
dhcp_interface1: test1
port2_profile: bond0.1
dhcp_interface2: test2
+ tags:
+ - "tests::expfail"
tasks:
- name: "INIT Prepare setup"
debug:
diff --git a/tests/tests_bond_deprecated_initscripts.yml b/tests/tests_bond_deprecated_initscripts.yml
index 383b488..cdf3de0 100644
--- a/tests/tests_bond_deprecated_initscripts.yml
+++ b/tests/tests_bond_deprecated_initscripts.yml
@@ -10,6 +10,7 @@
network_provider: initscripts
tags:
- always
+ - "tests::expfail"
- import_playbook: playbooks/tests_bond_deprecated.yml
when: (ansible_distribution in ['CentOS','RedHat'] and
diff --git a/tests/tests_bond_initscripts.yml b/tests/tests_bond_initscripts.yml
index 8fa74c5..6a231c4 100644
--- a/tests/tests_bond_initscripts.yml
+++ b/tests/tests_bond_initscripts.yml
@@ -10,6 +10,7 @@
network_provider: initscripts
tags:
- always
+ - "tests::expfail"
- import_playbook: playbooks/tests_bond.yml
when: (ansible_distribution in ['CentOS','RedHat'] and
--
2.30.2

View File

@ -1,54 +0,0 @@
From 4b1a8a87e7d297fd6669d653af7308dd9c1a513a Mon Sep 17 00:00:00 2001
From: Rich Megginson <rmeggins@redhat.com>
Date: Thu, 6 May 2021 13:52:38 -0600
Subject: [PATCH] tag 802-1x test as expfail; make sure bridge test cleans up
properly
The 802-1x test will fail on platforms where `hostapd` is not available,
so tag that test to make it skippable.
The initscripts bridge test does not clean up properly, leaving the
device around which causes the nm test to fail. Explicitly remove
the device for cleanup.
---
tests/playbooks/tests_802_1x.yml | 2 ++
tests/playbooks/tests_bridge.yml | 10 ++++++++++
2 files changed, 12 insertions(+)
diff --git a/tests/playbooks/tests_802_1x.yml b/tests/playbooks/tests_802_1x.yml
index 9cce1ae..4ceebb1 100644
--- a/tests/playbooks/tests_802_1x.yml
+++ b/tests/playbooks/tests_802_1x.yml
@@ -3,6 +3,8 @@
- hosts: all
vars:
interface: 802-1x-test
+ tags:
+ - tests::expfail
tasks:
- name: "INIT: 802.1x tests"
debug:
diff --git a/tests/playbooks/tests_bridge.yml b/tests/playbooks/tests_bridge.yml
index d79d6ad..14b1225 100644
--- a/tests/playbooks/tests_bridge.yml
+++ b/tests/playbooks/tests_bridge.yml
@@ -49,6 +49,16 @@
profile: "{{ interface }}"
task: tasks/assert_profile_absent.yml
+- name: Remove test bridge
+ hosts: all
+ tags:
+ - tests::cleanup
+ tasks:
+ - name: Remove the test interface
+ command: ip link delete {{ interface | quote }}
+ ignore_errors: yes
+ changed_when: false
+
# FIXME: Devices might still be left when profile is absent
# - import_playbook: run_tasks.yml
# vars:
--
2.30.2

44
sources
View File

@ -1,26 +1,26 @@
SHA512 (ad_integration-1.0.0.tar.gz) = f8b063945da7034c2697dc398a5d4e40ccf13bb483281daa1b58de57188ed2bf0de6693c1dac00b3da118a785360fd6ffb35eb5a5bf6e7b326741e4d0dd03598
SHA512 (ansible-posix-1.4.0.tar.gz) = 669261538e2b0e4598f148abb63138b18e92599a56cd48d523a259ac5253a9fc9abb7eb6bf5a792bfcdedcaeaa240acde916b19045317b3e7e8561e1190b6a2e
SHA512 (ansible-sshd-v0.18.0.tar.gz) = 5df134ebcdc4fa61026e55862c9df8d84c0415870b63e9e7dbe00b3302ff7fff85e6a4e1fc48c5bf1bad90e60beb893684f2f6794cf312508034b44d283bb3d0
SHA512 (auto-maintenance-e3ac549bee05349d7ae033971448f861415ad608.tar.gz) = 540f86046dfba3fa58942f9f544d01963c501da69c245757e5161ef78533bee10b0ccfd69781254918b042cfa4eac83cbe527c7d8b8dd45a076f80eac8fbfccf
SHA512 (certificate-1.1.6.tar.gz) = c37b00b1a0c3f6c01447ced8c66bc37b97f08d6994020ae855781535858fc1765d5bb44279e285787d71f5b804a3cb1d5e90eb037c780ce0741e2e8d29008793
SHA512 (cockpit-1.4.2.tar.gz) = 5fb9852b2e866f2096f9c8aa92c96097dda5caef6a068f73b1b34224a9faf67691e90a731d5befed0eb3bc31fad19362f6ffe7a22f68b84d3e9326af44041128
SHA512 (ad_integration-1.0.1.tar.gz) = 3d184408e40a6de62af10920f83765e1413a64202745fc8f2a199cb4d80beb706cd40fd674d5871f99c48cdc7622ddc14ec6e288235307fd40945336b3b6b0a8
SHA512 (ansible-posix-1.5.1.tar.gz) = ca2cadb27c230bd2f921797fb61bbb97c578ddd5d782f04cbd232bba84d091102fee872e69ebcfa5fb5c90b0db4fd90c2f97268e43621b233aa5309e5a0f8802
SHA512 (ansible-sshd-v0.18.1.tar.gz) = e537160b69a1fe096b59a683acf7c5b1cd25b43d8666124da63b78a1664513d1bd3623cf94f2521347ca0a77448622cc329d215af4d2d67ccbe830cfee12befc
SHA512 (auto-maintenance-d6a8e0167e9ed8d089093b7ead1e298241b534e1.tar.gz) = a138b1e1192db8a913c5747b3c92455f41ab75e2c19351e58d69c698681d663c2b192b374934f3acb21a648162188e540fa3751f48b4c3aa0cc6378e745f47c6
SHA512 (certificate-1.1.8.tar.gz) = 82140cd5a8c850156616791b9656c64be49cdb3ddd465e6e7a2d1250144af4e5f6610d466d87abc5c216b9f41c7b4d6296884416d858698d7c5d58e231d53bb3
SHA512 (cockpit-1.4.3.tar.gz) = 9bc613ea4b1dc25831df3b1503ed6697d1b9fc6a61183cd4feb8a5c29568e1b60534d6b088d6a24f6ea773d44502b10090a92a4c344bf3c4150680095f5a5209
SHA512 (community-general-6.2.0.tar.gz) = 537e9b4cf76925baaf19558655597d2f8f40b28a813fd4e1bf0cf09c6741545bdd4a5a36ff0e2757eb5065d4876ba3d4373f2362c99e29e641f1c61265695bcb
SHA512 (containers-podman-1.10.1.tar.gz) = 6b489058ae2c38124d0466bd7dccc28b4f36d00c37520399c7d36e1dddb6bc63358f74cccd511067c355364f83e95f3e5256ffb2f9b3dc9d925df0ff74fde77c
SHA512 (crypto_policies-1.2.6.tar.gz) = bf16a89dca4475b658b8bc8a1d84b2b900b23a5c5440180aa29d56d67e8bdc4f3f7bc0f1acc316e7f1aa3662b0a685532bc179b6aee6e92f5b64d553a942318b
SHA512 (firewall-1.4.1.tar.gz) = f23ec34d3ec5f82e3e612c58d4527aafded0e3188e55caf22508251d60c87142859f6bf0327e601bbdeb92e7cc022b29aba70766191c9bc9effd4cea05fdd6ee
SHA512 (crypto_policies-1.2.7.tar.gz) = 3c47e46f49bfe6116b834cfc32f5242fe866074d8cbbc530ad1391980c8dea8dc418bc9372565cbdd46becbab97de7ed69b4ea425750add0925e279e80954b45
SHA512 (firewall-1.4.2.tar.gz) = 88ecce48eb84044c980e2320ea8e06053464e9385ee51b2c4022cdac9a48b18c3ba58b108ae7267decc27d6c991a0ec83f1b2aa0f6b719d93c18b9870663d6a7
SHA512 (ha_cluster-1.8.5.tar.gz) = 8b4f5be0dfc22a973ead9952cf231509111b1e90f5d77347cabae05e60c19c948c698d74118130ffb41d05bd0f6855321cad7195609d4096771369475e43319c
SHA512 (kdump-1.2.5.tar.gz) = 3f8df4917f8cc2421c8e351f36332e38a18677ce3db135fc5ea2e78809194ebc793324e5091726d09e70a7e02a81fa6bc4456062878da903efbcbcebba97f707
SHA512 (kernel_settings-1.1.10.tar.gz) = e3a2d4298bbe160b106f5b90b2ee065404ca0e437f6928f6fe82aa92b9a9140bda73d16a72f6eab3d5e472fb7f7c0c066918e4dc75b53673a9e7f45b570c33a1
SHA512 (logging-1.11.4.tar.gz) = abc60cef4b5adb81c87e21b51352447758e1cf6f72f49fd14b79135c01a865697c28fd8ee13d1a0d1ae837913af86f6a5cd61ccef845434e09e5995db305c344
SHA512 (metrics-1.8.0.tar.gz) = 6191f845e0c9919c44ae5a0271f74dcd78d693311a80aec95f8452b9f7f91ea4b8eaab65d2afce370029160bf9ed70095b202dfb63503f015567db39527631e0
SHA512 (kdump-1.2.6.tar.gz) = 2e0b8ef49970a43d1c64d55a688925e48733f29e8ee862b0c1f5b01572d6e330ca1de01f65412ea492598d2fb43bc4f9d860f29b45a56051b3a4599001b3536f
SHA512 (kernel_settings-1.1.11.tar.gz) = 70b6f851ab12af1bf6b7c95159a42c709c6d8a9d5673672cf2b77310cdea8288fe05d769c424681288bd711ca3f4f519f87caa726c7f0eb6543b7a0ee272a883
SHA512 (logging-1.11.5.tar.gz) = 8594d4fec3cc6d1fec9feb5a6a2929992f1774dd0c586ab45bcac9f41dc8e9f3d969e417ed855892c281d7c7b5fe29f3da9f5316660c6d268298621fa4ec937f
SHA512 (metrics-1.8.1.tar.gz) = c4373bc925b5b89f47d4abe23e576dba8c8043682e7cd0e564c87474c14e80e347f4fe3ce78ae15bd5eca525c1ab7b9079908651bcf52590fa789fe362453b28
SHA512 (nbde_client-1.2.8.tar.gz) = 7bbb342533f559f021f8df91a8e267daaa5b14c7afe24a9aec71add48111f0fb2a47bf81a2c0bea2c75b928d8c73582f4433dbf51b08a81fd271d7e913062974
SHA512 (nbde_server-1.3.0.tar.gz) = 7a5811389e132ab3c9c5b172a764882110a2c7e72d89ff36168d301a27ecbbe78f18a6fd47c7909ea4b32547f32cc5cb0a26083c8c127e8a5ae3c710fc2c3da1
SHA512 (network-1.11.0.tar.gz) = 021e69c4564ddbbe0b6d4e5cd7c981dc3bb251be8f367291d7014dfc8b9dc07d6635a0f54fbdee663194b976fdf95f19d4e64b24f7a7b37c721d08a6cbc79dc4
SHA512 (podman-1.1.0.tar.gz) = 62b4043c554045e8cebc2f85965d4a636e66a008d2f98c197540cf21382164a39b63ad3566085ee2897175155e10b6677834c225134565a9b8935d61162ed3ef
SHA512 (postfix-1.3.1.tar.gz) = 95e83bfe1f6e162086c72104fb8731072341750ad0316b5ebfd48d623cb1df6558ae46681b55b372c793ccd344aad959cc6d4192cd1bb648899f842dd397a757
SHA512 (selinux-1.5.0.tar.gz) = 8779441ef87acc901724f2e402e9a36556a43f227e7aa23bf01e16aa774ffd2681bb7fa35672098d7256c98beaeda1ed022a84e750584a1af04c21552dfe4af0
SHA512 (ssh-1.1.11.tar.gz) = 42f67d11f903bfc645db734aaf8663eb0580bada658b0cb00a36dec926bb26b28991fc8ef71575da33e57ac57cac46fea92df06d7195d3a64f7628ea39c0a4ae
SHA512 (storage-1.9.4.tar.gz) = 6b35092138f4a5f04709ab2b727150f1ba72d7339e82774cfc5c699a55b9346a4d36460e07c5d3202aedc7824ac49567754f969c27df337f793bb7d293221db5
SHA512 (timesync-1.7.1.tar.gz) = bf3e1e94092a14e144e10c798a2ad495ff261c79e915f9470389cdebe176ba74a40c4b48533517b96540581d37a1cb6e6d472a5ba1422ac345e665d9eaec3826
SHA512 (tlog-1.2.10.tar.gz) = 525c1c21384624fe69bc0ce748e9398145168a06cdaa2773dd415d4379f77f326832c07fe32e11a7756d50ec0ec0cbe5854fe6ad83c7e1e3659dc8a80a2bdeaa
SHA512 (vpn-1.5.2.tar.gz) = 68f78aa4ac5c9c32deb58f3f6c58fc4810659fa9f1093ecade5e12c2955827f4c014a8afc529292022e177de6e073866d8d1402173ffb9f5251181aad70691b0
SHA512 (nbde_server-1.3.2.tar.gz) = fbf2ca2e171b3774358fbb5427d3bf7c531c928afcc30d2146d5f2c442bc758dc6f2be12c0e2e7a942ce562a782e3a644e38e1090958f9ade012715f2396bbea
SHA512 (network-1.11.1.tar.gz) = b7de11b69b33521dd9edbac718276c757c6bbbd6e83b1cdddf5b925d21f7d6c7bbfe2df4097c50d174d86adfb05f65831bfac7f7c2dcb158094361e3e7e6ad22
SHA512 (podman-1.1.1.tar.gz) = e702f536bba4e0f159a246ffb0b9e19b865a1c5dd9c1c95801460740c6185398e859299e7c3e0563ff7471b7f9d28853d54dc7f4271eec1eea416a36dcf1df3d
SHA512 (postfix-1.3.3.tar.gz) = 93cb2ec4764d5ea7922298194e5ed8613bac50a6646e4410bb608c8590e5f4a1b7aa3a6251bc9551ab3ba2033394a2700542f6377d9bf08676c8ee2b963710de
SHA512 (selinux-1.5.1.tar.gz) = ab12ced2eb1445739e3e49c7b9f3579192cc7c14b759e203bdabac0bad214403d1a0882e4a9d05b2047aa65b852df1576a6062f7ff89c461687560b6ed258055
SHA512 (ssh-1.1.12.tar.gz) = b3041110726467bb9711babc2dd327622cacb31e3ba19f5f0036b538575ebe71b55521eb7f7e7cb6e5fc22ee230f2909c3eb2308ac163144c72422211f979d6d
SHA512 (storage-1.9.5.tar.gz) = 641cacf3afc0e85c181a8f6128c007f5903cf33aba46c22562b951e63021b8d2a265db3bd449f8a961bf9377a54e25e8a2565fe425e703842bc49d199af96282
SHA512 (timesync-1.7.2.tar.gz) = 0410ef3934ca080f968253a6f5b655e5d7467808af0320f1eb3237eb758415010f8bfe74447ea949fe9d30af63f7b145c455c5485c12227768b8567bb89b024b
SHA512 (tlog-1.2.11.tar.gz) = 98240b3042ff3640a7eccedc4f8b2a99749b2507d7ff7588fa8a2f8cc1004433389b11f654ee5887039e427858eeb891bfd434131daa2bf62b4cd4678c0fe62b
SHA512 (vpn-1.5.3.tar.gz) = fcd0f3c5beaf96f9e07d968562753d2742b9ef32f95c42f1f1093f9de60e0c44772df35964ccc5db8ee0d720ed93f081a96c8e6fd2877b15c8cc1c7cfc451016