import rhel-system-roles-1.6.6-1.el8

This commit is contained in:
CentOS Sources 2021-08-10 04:25:24 +00:00 committed by Andrew Lukoshko
commit 9a4fcc552c
6 changed files with 1322 additions and 0 deletions

19
.gitignore vendored Normal file
View File

@ -0,0 +1,19 @@
SOURCES/ansible-sshd-v0.13.1.tar.gz
SOURCES/auto-maintenance-ec364d2e0bd422b69f34871a1188114f368097a0.tar.gz
SOURCES/certificate-1.0.5.tar.gz
SOURCES/crypto_policies-1.1.0.tar.gz
SOURCES/ha_cluster-1.2.0.tar.gz
SOURCES/kdump-1.0.5.tar.gz
SOURCES/kernel_settings-1.0.4.tar.gz
SOURCES/logging-1.4.1.tar.gz
SOURCES/metrics-1.2.4.tar.gz
SOURCES/nbde_client-1.0.4.tar.gz
SOURCES/nbde_server-1.0.3.tar.gz
SOURCES/network-b08a0b3748ee87aa3bdbcf1f0b7e41ef4971bbee.tar.gz
SOURCES/postfix-1.0.0.tar.gz
SOURCES/selinux-1.2.3.tar.gz
SOURCES/ssh-1.0.2.tar.gz
SOURCES/storage-1.5.2.tar.gz
SOURCES/timesync-1.5.0.tar.gz
SOURCES/tlog-1.1.1.tar.gz
SOURCES/vpn-1.1.0.tar.gz

View File

@ -0,0 +1,19 @@
668bfd090b01b48ef3959bf499599a23ef795f76 SOURCES/ansible-sshd-v0.13.1.tar.gz
bfd618e94056a68c75de22dfcde7b29445850176 SOURCES/auto-maintenance-ec364d2e0bd422b69f34871a1188114f368097a0.tar.gz
3408d5c37df62b4e9e7a4499ec9015627ea9e890 SOURCES/certificate-1.0.5.tar.gz
92387eef86823e8078bc883d53b717e58269ea32 SOURCES/crypto_policies-1.1.0.tar.gz
f78287302516f645edd8ee469dd785d1bfab3684 SOURCES/ha_cluster-1.2.0.tar.gz
ccf003fe359ed688cd38d909405a0cb814dafee1 SOURCES/kdump-1.0.5.tar.gz
98688933568950c4e90c40d9d1ab8cd1a0ef7083 SOURCES/kernel_settings-1.0.4.tar.gz
4ce4d5a1178727a0d0706ea58934374ce4666727 SOURCES/logging-1.4.1.tar.gz
be9780403c5113d2a86c8f94d6b428a21f365b37 SOURCES/metrics-1.2.4.tar.gz
996c1d4f2763d8ae7fe2973d48429b6fcb88d387 SOURCES/nbde_client-1.0.4.tar.gz
717e2cd6ba686ffa7abdf885e04e185d09b03d88 SOURCES/nbde_server-1.0.3.tar.gz
487459f2ff5856bdf7f0f7686cdfb63d5e2a5007 SOURCES/network-b08a0b3748ee87aa3bdbcf1f0b7e41ef4971bbee.tar.gz
609a44ce29de5786eaab9b8b4f0c3b0f2586a525 SOURCES/postfix-1.0.0.tar.gz
9e060a747dda947cc87321bf472db9ecf37912a0 SOURCES/selinux-1.2.3.tar.gz
3fa7da323b39ad6555d5232aa5fb4b7dd173c01c SOURCES/ssh-1.0.2.tar.gz
4184728dff887a9e6c9badc41b19ca063dfafa90 SOURCES/storage-1.5.2.tar.gz
ba01428f0812c5780d8c1c839d53f2b76ff4e9d6 SOURCES/timesync-1.5.0.tar.gz
67a587cad5bf1716931556844a592ea348a70e5c SOURCES/tlog-1.1.1.tar.gz
bc5dd7ab2f823c394a14c1074c709497c3d31a74 SOURCES/vpn-1.1.0.tar.gz

14
SOURCES/collection_readme.sh Executable file
View File

@ -0,0 +1,14 @@
#!/bin/bash
set -euxo pipefail
readme_md=${1:-"lsr_role2collection/collection_readme.md"}
sed -i -e '/## Currently supported distributions/{:1;/## Dependencies/!{N;b 1};s|.*|## Dependencies|}' \
-e 's/Linux/Red Hat Enterprise Linux/g' \
-e 's/Ansible Galaxy/Automation Hub/g' \
-e 's/fedora\(.\)linux_system_roles/redhat\1rhel_system_roles/g' \
-e 's/linux-system-roles/rhel-system-roles/g' \
-e '/## Documentation/{:a;/## Support/!{N;b a};s|.*|## Documentation\nThe official RHEL System Roles documentation can be found in the [Product Documentation section of the Red Hat Customer Portal](https://access.redhat.com/documentation/en-us/red_hat_enterprise_linux/8/html/administration_and_configuration_tasks_using_system_roles_in_rhel/index).\n\n## Support|}' \
-e 's/ $//' \
$readme_md

View File

@ -0,0 +1,65 @@
From d6c8319f52f3859b28044841063adf0013df878b Mon Sep 17 00:00:00 2001
From: Rich Megginson <rmeggins@redhat.com>
Date: Thu, 25 Mar 2021 13:57:45 -0600
Subject: [PATCH 3/4] Patch53: network-disable-bondtests.diff
---
tests/playbooks/tests_bond.yml | 2 ++
tests/playbooks/tests_bond_deprecated.yml | 2 ++
tests/tests_bond_deprecated_initscripts.yml | 1 +
tests/tests_bond_initscripts.yml | 1 +
4 files changed, 6 insertions(+)
diff --git a/tests/playbooks/tests_bond.yml b/tests/playbooks/tests_bond.yml
index 1e45788..d3005a6 100644
--- a/tests/playbooks/tests_bond.yml
+++ b/tests/playbooks/tests_bond.yml
@@ -8,6 +8,8 @@
dhcp_interface1: test1
port2_profile: bond0.1
dhcp_interface2: test2
+ tags:
+ - "tests::expfail"
tasks:
- name: "INIT Prepare setup"
debug:
diff --git a/tests/playbooks/tests_bond_deprecated.yml b/tests/playbooks/tests_bond_deprecated.yml
index f37e19a..ae475c4 100644
--- a/tests/playbooks/tests_bond_deprecated.yml
+++ b/tests/playbooks/tests_bond_deprecated.yml
@@ -8,6 +8,8 @@
dhcp_interface1: test1
port2_profile: bond0.1
dhcp_interface2: test2
+ tags:
+ - "tests::expfail"
tasks:
- name: "INIT Prepare setup"
debug:
diff --git a/tests/tests_bond_deprecated_initscripts.yml b/tests/tests_bond_deprecated_initscripts.yml
index 383b488..cdf3de0 100644
--- a/tests/tests_bond_deprecated_initscripts.yml
+++ b/tests/tests_bond_deprecated_initscripts.yml
@@ -10,6 +10,7 @@
network_provider: initscripts
tags:
- always
+ - "tests::expfail"
- import_playbook: playbooks/tests_bond_deprecated.yml
when: (ansible_distribution in ['CentOS','RedHat'] and
diff --git a/tests/tests_bond_initscripts.yml b/tests/tests_bond_initscripts.yml
index 8fa74c5..6a231c4 100644
--- a/tests/tests_bond_initscripts.yml
+++ b/tests/tests_bond_initscripts.yml
@@ -10,6 +10,7 @@
network_provider: initscripts
tags:
- always
+ - "tests::expfail"
- import_playbook: playbooks/tests_bond.yml
when: (ansible_distribution in ['CentOS','RedHat'] and
--
2.30.2

View File

@ -0,0 +1,54 @@
From 4b1a8a87e7d297fd6669d653af7308dd9c1a513a Mon Sep 17 00:00:00 2001
From: Rich Megginson <rmeggins@redhat.com>
Date: Thu, 6 May 2021 13:52:38 -0600
Subject: [PATCH] tag 802-1x test as expfail; make sure bridge test cleans up
properly
The 802-1x test will fail on platforms where `hostapd` is not available,
so tag that test to make it skippable.
The initscripts bridge test does not clean up properly, leaving the
device around which causes the nm test to fail. Explicitly remove
the device for cleanup.
---
tests/playbooks/tests_802_1x.yml | 2 ++
tests/playbooks/tests_bridge.yml | 10 ++++++++++
2 files changed, 12 insertions(+)
diff --git a/tests/playbooks/tests_802_1x.yml b/tests/playbooks/tests_802_1x.yml
index 9cce1ae..4ceebb1 100644
--- a/tests/playbooks/tests_802_1x.yml
+++ b/tests/playbooks/tests_802_1x.yml
@@ -3,6 +3,8 @@
- hosts: all
vars:
interface: 802-1x-test
+ tags:
+ - tests::expfail
tasks:
- name: "INIT: 802.1x tests"
debug:
diff --git a/tests/playbooks/tests_bridge.yml b/tests/playbooks/tests_bridge.yml
index d79d6ad..14b1225 100644
--- a/tests/playbooks/tests_bridge.yml
+++ b/tests/playbooks/tests_bridge.yml
@@ -49,6 +49,16 @@
profile: "{{ interface }}"
task: tasks/assert_profile_absent.yml
+- name: Remove test bridge
+ hosts: all
+ tags:
+ - tests::cleanup
+ tasks:
+ - name: Remove the test interface
+ command: ip link delete {{ interface | quote }}
+ ignore_errors: yes
+ changed_when: false
+
# FIXME: Devices might still be left when profile is absent
# - import_playbook: run_tasks.yml
# vars:
--
2.30.2

1151
SPECS/rhel-system-roles.spec Normal file

File diff suppressed because it is too large Load Diff