resteasy/resteasy-2.3.2.Final-remove-dependenciesA.patch
2012-04-24 13:41:10 +02:00

306 lines
10 KiB
Diff

diff --git a/async-http-jbossweb/async-http-jbossweb-jar/pom.xml b/async-http-jbossweb/async-http-jbossweb-jar/pom.xml
index 4a31c8b..80b5a58 100644
--- a/async-http-jbossweb/async-http-jbossweb-jar/pom.xml
+++ b/async-http-jbossweb/async-http-jbossweb-jar/pom.xml
@@ -14,9 +14,8 @@
<dependencies>
<dependency>
- <groupId>jboss.web</groupId>
+ <groupId>org.jboss.web</groupId>
<artifactId>jbossweb</artifactId>
- <version>2.1.7.GA</version>
<scope>provided</scope>
</dependency>
<dependency>
@@ -46,4 +45,4 @@
</plugins>
</build>
-</project>
\ No newline at end of file
+</project>
diff --git a/async-http-tomcat/asynch-http-tomcat-jar/pom.xml b/async-http-tomcat/asynch-http-tomcat-jar/pom.xml
index deca25f..1c27e72 100644
--- a/async-http-tomcat/asynch-http-tomcat-jar/pom.xml
+++ b/async-http-tomcat/asynch-http-tomcat-jar/pom.xml
@@ -14,9 +14,8 @@
<dependencies>
<dependency>
- <groupId>jboss.web</groupId>
+ <groupId>org.jboss.web</groupId>
<artifactId>jbossweb</artifactId>
- <version>2.1.7.GA</version>
<scope>provided</scope>
</dependency>
<dependency>
@@ -51,4 +50,4 @@
</plugins>
</build>
-</project>
\ No newline at end of file
+</project>
diff --git a/pom.xml b/pom.xml
index 455d6ee..5250f81 100644
--- a/pom.xml
+++ b/pom.xml
@@ -255,8 +255,8 @@
</dependency>
<dependency>
<groupId>org.apache.james</groupId>
- <artifactId>apache-mime4j</artifactId>
- <version>0.6</version>
+ <artifactId>apache-mime4j-core</artifactId>
+ <version>0.7.2</version>
<exclusions>
<exclusion>
<artifactId>commons-logging</artifactId>
diff --git a/providers/fastinfoset/pom.xml b/providers/fastinfoset/pom.xml
index 7d4de0f..b6dbd53 100644
--- a/providers/fastinfoset/pom.xml
+++ b/providers/fastinfoset/pom.xml
@@ -14,11 +14,6 @@
<dependencies>
<dependency>
- <groupId>org.springframework</groupId>
- <artifactId>spring-webmvc</artifactId>
- <version>3.0.3.RELEASE</version>
- </dependency>
- <dependency>
<groupId>org.jboss.resteasy</groupId>
<artifactId>resteasy-jaxrs</artifactId>
<version>${project.version}</version>
diff --git a/providers/jackson/pom.xml b/providers/jackson/pom.xml
index 28d687b..19364b8 100644
--- a/providers/jackson/pom.xml
+++ b/providers/jackson/pom.xml
@@ -70,6 +70,11 @@
<artifactId>junit</artifactId>
<scope>test</scope>
</dependency>
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <scope>test</scope>
+ </dependency>
</dependencies>
<build>
<plugins>
diff --git a/providers/jaxb/pom.xml b/providers/jaxb/pom.xml
index 3b9e14a..d162d92 100644
--- a/providers/jaxb/pom.xml
+++ b/providers/jaxb/pom.xml
@@ -47,6 +47,13 @@
<artifactId>junit</artifactId>
<scope>test</scope>
</dependency>
+
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <scope>test</scope>
+ </dependency>
+
</dependencies>
diff --git a/providers/jettison/pom.xml b/providers/jettison/pom.xml
index dfce204..6269fb8 100644
--- a/providers/jettison/pom.xml
+++ b/providers/jettison/pom.xml
@@ -56,6 +56,11 @@
<artifactId>junit</artifactId>
<scope>test</scope>
</dependency>
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <scope>test</scope>
+ </dependency>
</dependencies>
diff --git a/providers/multipart/pom.xml b/providers/multipart/pom.xml
index 9acdfb4..c4cef26 100644
--- a/providers/multipart/pom.xml
+++ b/providers/multipart/pom.xml
@@ -34,7 +34,11 @@
</dependency>
<dependency>
<groupId>org.apache.james</groupId>
- <artifactId>apache-mime4j</artifactId>
+ <artifactId>apache-mime4j-core</artifactId>
+ </dependency>
+ <dependency>
+ <groupId>org.apache.james</groupId>
+ <artifactId>apache-mime4j-dom</artifactId>
</dependency>
<dependency>
<groupId>javax.servlet</groupId>
@@ -70,4 +74,4 @@
</plugins>
</build>
-</project>
\ No newline at end of file
+</project>
diff --git a/providers/resteasy-atom/pom.xml b/providers/resteasy-atom/pom.xml
index 732c0c4..54a230e 100644
--- a/providers/resteasy-atom/pom.xml
+++ b/providers/resteasy-atom/pom.xml
@@ -43,6 +43,11 @@
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>
</dependency>
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <scope>test</scope>
+ </dependency>
<!--
<dependency>
<groupId>tjws</groupId>
diff --git a/providers/test-all-jaxb/pom.xml b/providers/test-all-jaxb/pom.xml
index a4f72a1..2fec2f6 100644
--- a/providers/test-all-jaxb/pom.xml
+++ b/providers/test-all-jaxb/pom.xml
@@ -69,6 +69,11 @@
<scope>test</scope>
</dependency>
-->
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ </dependency>
+
</dependencies>
diff --git a/providers/test-jackson-jaxb-coexistence/pom.xml b/providers/test-jackson-jaxb-coexistence/pom.xml
index e80d285..ffebf88 100644
--- a/providers/test-jackson-jaxb-coexistence/pom.xml
+++ b/providers/test-jackson-jaxb-coexistence/pom.xml
@@ -47,6 +47,12 @@
<version>${project.version}</version>
<scope>test</scope>
</dependency>
+ <dependency>
+ <groupId>com.sun.istack</groupId>
+ <artifactId>istack-commons-runtime</artifactId>
+ <scope>test</scope>
+ </dependency>
+
<!--
<dependency>
<groupId>tjws</groupId>
diff --git a/resteasy-guice/pom.xml b/resteasy-guice/pom.xml
index 2990ce0..52892c4 100644
--- a/resteasy-guice/pom.xml
+++ b/resteasy-guice/pom.xml
@@ -14,9 +14,8 @@
<dependencies>
<dependency>
- <groupId>com.google.code.guice</groupId>
+ <groupId>com.google.inject</groupId>
<artifactId>guice</artifactId>
- <version>2.0</version>
</dependency>
<dependency>
<groupId>org.jboss.resteasy</groupId>
@@ -48,4 +47,4 @@
</dependency>
-->
</dependencies>
-</project>
\ No newline at end of file
+</project>
diff --git a/resteasy-jaxrs/pom.xml b/resteasy-jaxrs/pom.xml
index d599e79..36d5460 100644
--- a/resteasy-jaxrs/pom.xml
+++ b/resteasy-jaxrs/pom.xml
@@ -60,14 +60,8 @@
detected runtime?
-->
<dependency>
- <groupId>javax.annotation</groupId>
- <artifactId>jsr250-api</artifactId>
- </dependency>
-
- <!-- javax.activation.DataSource provider is required by spec -->
- <dependency>
- <groupId>javax.activation</groupId>
- <artifactId>activation</artifactId>
+ <groupId>org.jboss.spec.javax.annotation</groupId>
+ <artifactId>jboss-annotations-api_1.1_spec</artifactId>
</dependency>
<!-- Used for org.jboss.resteasy.plugins.client.httpclient.* -->
@@ -83,11 +77,6 @@
<artifactId>httpclient</artifactId>
</dependency>
- <dependency>
- <groupId>net.jcip</groupId>
- <artifactId>jcip-annotations</artifactId>
- </dependency>
-
<!-- Used by org.jboss.resteasy.plugins.server.tjws.* -->
<!--
<dependency>
diff --git a/resteasy-spring/pom.xml b/resteasy-spring/pom.xml
index aa7cdd2..ae4fe77 100644
--- a/resteasy-spring/pom.xml
+++ b/resteasy-spring/pom.xml
@@ -125,14 +125,8 @@
detected runtime?
-->
<dependency>
- <groupId>javax.annotation</groupId>
- <artifactId>jsr250-api</artifactId>
- </dependency>
-
- <!-- javax.activation.DataSource provider is required by spec -->
- <dependency>
- <groupId>javax.activation</groupId>
- <artifactId>activation</artifactId>
+ <groupId>org.jboss.spec.javax.annotation</groupId>
+ <artifactId>jboss-annotations-api_1.1_spec</artifactId>
</dependency>
<!-- Used for org.jboss.resteasy.plugins.client.httpclient.* -->
diff --git a/resteasy-test-data/pom.xml b/resteasy-test-data/pom.xml
index 6bde1de..ee2aeb5 100644
--- a/resteasy-test-data/pom.xml
+++ b/resteasy-test-data/pom.xml
@@ -20,25 +20,14 @@
<groupId>com.sun.xml.fastinfoset</groupId>
<artifactId>FastInfoset</artifactId>
</dependency>
- <!-- javax.activation.DataSource provider is required by spec -->
- <dependency>
- <groupId>javax.activation</groupId>
- <artifactId>activation</artifactId>
- </dependency>
</dependencies>
<build>
<plugins>
<plugin>
<groupId>org.jvnet.jaxb2.maven2</groupId>
- <artifactId>maven-jaxb2-plugin</artifactId>
+ <artifactId>maven-jaxb22-plugin</artifactId>
<version>0.7.3</version>
<dependencies>
- <!-- javax.activation.DataSource provider is required by spec -->
- <dependency>
- <groupId>javax.activation</groupId>
- <artifactId>activation</artifactId>
- <version>1.1</version>
- </dependency>
<dependency>
<groupId>com.sun.xml.bind</groupId>
<artifactId>jaxb-impl</artifactId>