Merges redhat provider into heartbeat provider for pacemaker support
Resolves: rhbz#917681 Resolves: rhbz#928890 Resolves: rhbz#952716 Resolves: rhbz#960555
This commit is contained in:
parent
9114766388
commit
ce546be6ad
1
.gitignore
vendored
1
.gitignore
vendored
@ -10,3 +10,4 @@ resource-agents-3.0.14.tar.bz2
|
|||||||
/resource-agents-3.9.1.tar.bz2
|
/resource-agents-3.9.1.tar.bz2
|
||||||
/resource-agents-3.9.2.tar.bz2
|
/resource-agents-3.9.2.tar.bz2
|
||||||
/resource-agents-3.9.5.tar.gz
|
/resource-agents-3.9.5.tar.gz
|
||||||
|
/ClusterLabs-resource-agents-5434e96.tar.gz
|
||||||
|
@ -1,13 +0,0 @@
|
|||||||
diff --git a/configure.ac b/configure.ac
|
|
||||||
index fa417ee..be888af 100644
|
|
||||||
--- a/configure.ac
|
|
||||||
+++ b/configure.ac
|
|
||||||
@@ -705,7 +705,7 @@ AM_CONDITIONAL(USE_LIBNET, test "x$libnet_version" != "xnone" )
|
|
||||||
dnl ************************************************************************
|
|
||||||
dnl * Check for netinet/icmp6.h to enable the IPv6addr resource agent
|
|
||||||
AC_CHECK_HEADERS(netinet/icmp6.h,[],[],[#include <sys/types.h>])
|
|
||||||
-AM_CONDITIONAL(USE_IPV6ADDR, test "$ac_cv_header_netinet_icmp6_h" = yes )
|
|
||||||
+AM_CONDITIONAL(USE_IPV6ADDR, test "$ac_cv_header_netinet_icmp6_h" = yes && test "$ac_cv_header_heartbeat_glue_config_h" = yes)
|
|
||||||
|
|
||||||
dnl ========================================================================
|
|
||||||
dnl Compiler flags
|
|
@ -19,6 +19,9 @@
|
|||||||
# use the correct group for each.
|
# use the correct group for each.
|
||||||
#
|
#
|
||||||
|
|
||||||
|
%global upstream_prefix ClusterLabs-resource-agents
|
||||||
|
%global upstream_version 5434e96
|
||||||
|
|
||||||
# SSLeay (required by ldirectord)
|
# SSLeay (required by ldirectord)
|
||||||
%if 0%{?suse_version}
|
%if 0%{?suse_version}
|
||||||
%global SSLeay perl-Net_SSLeay
|
%global SSLeay perl-Net_SSLeay
|
||||||
@ -33,17 +36,15 @@
|
|||||||
Name: resource-agents
|
Name: resource-agents
|
||||||
Summary: Open Source HA Reusable Cluster Resource Scripts
|
Summary: Open Source HA Reusable Cluster Resource Scripts
|
||||||
Version: 3.9.5
|
Version: 3.9.5
|
||||||
Release: 3%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
Release: 5
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: http://to.be.defined.com/
|
URL: https://github.com/ClusterLabs/resource-agents
|
||||||
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
%else
|
%else
|
||||||
Group: Productivity/Clustering/HA
|
Group: Productivity/Clustering/HA
|
||||||
%endif
|
%endif
|
||||||
Source0: %{name}-%{version}%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:-%{alphatag}}%{?dirty:-%{dirty}}.tar.gz
|
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
|
||||||
Patch0: no-cluster-glue.patch
|
|
||||||
Patch1: rhbz915959-apache-resource-pidfile-path.patch
|
|
||||||
Obsoletes: heartbeat-resources <= %{version}
|
Obsoletes: heartbeat-resources <= %{version}
|
||||||
Provides: heartbeat-resources = %{version}
|
Provides: heartbeat-resources = %{version}
|
||||||
|
|
||||||
@ -146,9 +147,7 @@ See 'ldirectord -h' and linux-ha/doc/ldirectord for more information.
|
|||||||
%{error:Unable to determine the distribution/version. This is generally caused by missing /etc/rpm/macros.dist. Please install the correct build packages or define the required macros manually.}
|
%{error:Unable to determine the distribution/version. This is generally caused by missing /etc/rpm/macros.dist. Please install the correct build packages or define the required macros manually.}
|
||||||
exit 1
|
exit 1
|
||||||
%endif
|
%endif
|
||||||
%setup -q -n %{name}-%{version}%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:-%{alphatag}}%{?dirty:-%{dirty}}
|
%setup -q -n %{upstream_prefix}-%{upstream_version}
|
||||||
%patch0 -p1
|
|
||||||
%patch1 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if [ ! -f configure ]; then
|
if [ ! -f configure ]; then
|
||||||
@ -157,6 +156,7 @@ fi
|
|||||||
|
|
||||||
%if 0%{?fedora} >= 11 || 0%{?centos_version} > 5 || 0%{?rhel} > 5
|
%if 0%{?fedora} >= 11 || 0%{?centos_version} > 5 || 0%{?rhel} > 5
|
||||||
CFLAGS="$(echo '%{optflags}')"
|
CFLAGS="$(echo '%{optflags}')"
|
||||||
|
# TODO make this rsctmp folder the same as upstream
|
||||||
%global conf_opt_rsctmpdir "--with-rsctmpdir=%{_var}/run/heartbeat/rsctmp"
|
%global conf_opt_rsctmpdir "--with-rsctmpdir=%{_var}/run/heartbeat/rsctmp"
|
||||||
%global conf_opt_fatal "--enable-fatal-warnings=no"
|
%global conf_opt_fatal "--enable-fatal-warnings=no"
|
||||||
%else
|
%else
|
||||||
@ -250,6 +250,7 @@ rm -rf %{buildroot}
|
|||||||
|
|
||||||
%{_includedir}/heartbeat
|
%{_includedir}/heartbeat
|
||||||
|
|
||||||
|
# TODO make this rsctmp folder the same as upstream
|
||||||
%if 0%{?fedora} >= 11 || 0%{?centos_version} > 5 || 0%{?rhel} > 5
|
%if 0%{?fedora} >= 11 || 0%{?centos_version} > 5 || 0%{?rhel} > 5
|
||||||
%dir %{_var}/run/heartbeat/rsctmp
|
%dir %{_var}/run/heartbeat/rsctmp
|
||||||
%else
|
%else
|
||||||
@ -307,6 +308,15 @@ ccs_update_schema > /dev/null 2>&1 ||:
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jun 18 2013 David Vossel <dvossel@redhat.com> - 3.9.5-5
|
||||||
|
- Merges redhat provider into heartbeat provider. Remove
|
||||||
|
rgmanager's redhat provider.
|
||||||
|
|
||||||
|
Resolves: rhbz#917681
|
||||||
|
Resolves: rhbz#928890
|
||||||
|
Resolves: rhbz#952716
|
||||||
|
Resolves: rhbz#960555
|
||||||
|
|
||||||
* Tue Mar 12 2013 David Vossel <dvossel@redhat.com> - 3.9.5-3
|
* Tue Mar 12 2013 David Vossel <dvossel@redhat.com> - 3.9.5-3
|
||||||
- Fixes build system error with conditional logic involving
|
- Fixes build system error with conditional logic involving
|
||||||
IPv6addr and updates spec file to build against rhel 7 as
|
IPv6addr and updates spec file to build against rhel 7 as
|
||||||
|
@ -1,39 +0,0 @@
|
|||||||
diff --git a/heartbeat/apache b/heartbeat/apache
|
|
||||||
index d702765..a313372 100755
|
|
||||||
--- a/heartbeat/apache
|
|
||||||
+++ b/heartbeat/apache
|
|
||||||
@@ -173,7 +173,12 @@ apache_start() {
|
|
||||||
validate_default_config || return $OCF_ERR_CONFIGURED
|
|
||||||
# https://bugs.launchpad.net/ubuntu/+source/apache2/+bug/603211
|
|
||||||
[ -d /var/run/apache2 ] || mkdir /var/run/apache2
|
|
||||||
- ocf_run $HTTPD $HTTPDOPTS $OPTIONS -f $CONFIGFILE
|
|
||||||
+ if [ -z $PIDFILE_DIRECTIVE ];
|
|
||||||
+ then
|
|
||||||
+ ocf_run $HTTPD $HTTPDOPTS $OPTIONS -f $CONFIGFILE
|
|
||||||
+ else
|
|
||||||
+ ocf_run $HTTPD $HTTPDOPTS $OPTIONS -f $CONFIGFILE -c "PidFile $PidFile"
|
|
||||||
+ fi
|
|
||||||
tries=0
|
|
||||||
while : # wait until the user set timeout
|
|
||||||
do
|
|
||||||
diff --git a/heartbeat/apache-conf.sh b/heartbeat/apache-conf.sh
|
|
||||||
index 12723cb..cf679cc 100644
|
|
||||||
--- a/heartbeat/apache-conf.sh
|
|
||||||
+++ b/heartbeat/apache-conf.sh
|
|
||||||
@@ -139,7 +139,15 @@ GetParams() {
|
|
||||||
case $PidFile in
|
|
||||||
/*) ;;
|
|
||||||
[[:alnum:]]*) PidFile=$ServerRoot/$PidFile;;
|
|
||||||
- *) PidFile=$HA_VARRUNDIR/${httpd_basename}.pid;;
|
|
||||||
+ *)
|
|
||||||
+ # If the PidFile is not set in the config, set
|
|
||||||
+ # a default location.
|
|
||||||
+ PidFile=$HA_VARRUNDIR/${httpd_basename}.pid
|
|
||||||
+ # Force the daemon to use this location by using
|
|
||||||
+ # the -c option, which adds the PidFile directive
|
|
||||||
+ # as if it was in the configuration file to begin with.
|
|
||||||
+ PIDFILE_DIRECTIVE="true"
|
|
||||||
+ ;;
|
|
||||||
esac
|
|
||||||
|
|
||||||
for p in "$PORT" "$Port" 80; do
|
|
Loading…
Reference in New Issue
Block a user