Fix buildsystem for rawhide

This commit is contained in:
David Vossel 2013-10-30 15:50:51 -05:00
parent b2e101d901
commit 8a4aae5d1a
2 changed files with 32 additions and 1 deletions

26
fix_build_system.patch Normal file
View File

@ -0,0 +1,26 @@
diff --git a/ldirectord/Makefile.am b/ldirectord/Makefile.am
index 38c11e2..71461f9 100644
--- a/ldirectord/Makefile.am
+++ b/ldirectord/Makefile.am
@@ -37,7 +37,7 @@ harddir = $(sysconfdir)/ha.d/resource.d
.PHONY: install-exec-hook
install-exec-hook:
- $(mkinstalldirs) $(DESTDIR)$(harddir)
+ $(INSTALL) -d $(DESTDIR)$(harddir)
cd $(DESTDIR)$(harddir) && ln -s -f $(sbindir)/ldirectord .
.PHONY: uninstall-hook
diff --git a/ldirectord/init.d/Makefile.am b/ldirectord/init.d/Makefile.am
index 4effe96..e23265c 100644
--- a/ldirectord/init.d/Makefile.am
+++ b/ldirectord/init.d/Makefile.am
@@ -25,7 +25,7 @@ initd_SCRIPTS = ldirectord
install-initdSCRIPTS: $(initd_SCRIPTS)
@$(NORMAL_INSTALL)
- $(mkinstalldirs) $(DESTDIR)$(initddir)
+ $(INSTALL) -d $(DESTDIR)$(initddir)
@list='$(initd_SCRIPTS)'; for p in $$list; do \
f="`echo $$p|sed '$(transform)'`"; \
if test -f $$p; then \

View File

@ -36,7 +36,7 @@
Name: resource-agents Name: resource-agents
Summary: Open Source HA Reusable Cluster Resource Scripts Summary: Open Source HA Reusable Cluster Resource Scripts
Version: 3.9.5 Version: 3.9.5
Release: 9%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist} Release: 10%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
License: GPLv2+ and LGPLv2+ License: GPLv2+ and LGPLv2+
URL: https://github.com/ClusterLabs/resource-agents URL: https://github.com/ClusterLabs/resource-agents
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel} %if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
@ -45,6 +45,7 @@ Group: System Environment/Base
Group: Productivity/Clustering/HA Group: Productivity/Clustering/HA
%endif %endif
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
Patch0: fix_build_system.patch
Obsoletes: heartbeat-resources <= %{version} Obsoletes: heartbeat-resources <= %{version}
Provides: heartbeat-resources = %{version} Provides: heartbeat-resources = %{version}
@ -148,6 +149,7 @@ See 'ldirectord -h' and linux-ha/doc/ldirectord for more information.
exit 1 exit 1
%endif %endif
%setup -q -n %{upstream_prefix}-%{upstream_version} %setup -q -n %{upstream_prefix}-%{upstream_version}
%patch0 -p1
%build %build
if [ ! -f configure ]; then if [ ! -f configure ]; then
@ -300,6 +302,9 @@ ccs_update_schema > /dev/null 2>&1 ||:
%endif %endif
%changelog %changelog
* Wed Oct 20 2013 David Vossel <dvossel@redhat.com> - 3.9.5-10
- Fix build system for rawhide.
* Wed Oct 16 2013 David Vossel <dvossel@redhat.com> - 3.9.5-9 * Wed Oct 16 2013 David Vossel <dvossel@redhat.com> - 3.9.5-9
- Remove rgmanager agents from build. - Remove rgmanager agents from build.