Sync with latest upstream release
This commit is contained in:
parent
8a4aae5d1a
commit
57aff16e56
1
.gitignore
vendored
1
.gitignore
vendored
@ -11,3 +11,4 @@ resource-agents-3.0.14.tar.bz2
|
|||||||
/resource-agents-3.9.2.tar.bz2
|
/resource-agents-3.9.2.tar.bz2
|
||||||
/resource-agents-3.9.5.tar.gz
|
/resource-agents-3.9.5.tar.gz
|
||||||
/ClusterLabs-resource-agents-5434e96.tar.gz
|
/ClusterLabs-resource-agents-5434e96.tar.gz
|
||||||
|
/ClusterLabs-resource-agents-614b55f.tar.gz
|
||||||
|
@ -1,26 +0,0 @@
|
|||||||
diff --git a/ldirectord/Makefile.am b/ldirectord/Makefile.am
|
|
||||||
index 38c11e2..71461f9 100644
|
|
||||||
--- a/ldirectord/Makefile.am
|
|
||||||
+++ b/ldirectord/Makefile.am
|
|
||||||
@@ -37,7 +37,7 @@ harddir = $(sysconfdir)/ha.d/resource.d
|
|
||||||
|
|
||||||
.PHONY: install-exec-hook
|
|
||||||
install-exec-hook:
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(harddir)
|
|
||||||
+ $(INSTALL) -d $(DESTDIR)$(harddir)
|
|
||||||
cd $(DESTDIR)$(harddir) && ln -s -f $(sbindir)/ldirectord .
|
|
||||||
|
|
||||||
.PHONY: uninstall-hook
|
|
||||||
diff --git a/ldirectord/init.d/Makefile.am b/ldirectord/init.d/Makefile.am
|
|
||||||
index 4effe96..e23265c 100644
|
|
||||||
--- a/ldirectord/init.d/Makefile.am
|
|
||||||
+++ b/ldirectord/init.d/Makefile.am
|
|
||||||
@@ -25,7 +25,7 @@ initd_SCRIPTS = ldirectord
|
|
||||||
|
|
||||||
install-initdSCRIPTS: $(initd_SCRIPTS)
|
|
||||||
@$(NORMAL_INSTALL)
|
|
||||||
- $(mkinstalldirs) $(DESTDIR)$(initddir)
|
|
||||||
+ $(INSTALL) -d $(DESTDIR)$(initddir)
|
|
||||||
@list='$(initd_SCRIPTS)'; for p in $$list; do \
|
|
||||||
f="`echo $$p|sed '$(transform)'`"; \
|
|
||||||
if test -f $$p; then \
|
|
@ -9,18 +9,18 @@
|
|||||||
# published by the Open Source Initiative.
|
# published by the Open Source Initiative.
|
||||||
#
|
#
|
||||||
|
|
||||||
|
# Below is the script used to generate a new source file
|
||||||
|
# from the resource-agent upstream git repo.
|
||||||
|
#
|
||||||
|
# TAG=$(git log --pretty="format:%h" -n 1)
|
||||||
|
# distdir="ClusterLabs-resource-agents-${TAG}"
|
||||||
#
|
# TARFILE="${distdir}.tar.gz"
|
||||||
# Since this spec file supports multiple distributions, ensure we
|
# rm -rf $TARFILE $distdir
|
||||||
# use the correct group for each.
|
# git archive --prefix=$distdir/ HEAD | gzip > $TARFILE
|
||||||
#
|
#
|
||||||
|
|
||||||
%global upstream_prefix ClusterLabs-resource-agents
|
%global upstream_prefix ClusterLabs-resource-agents
|
||||||
%global upstream_version 5434e96
|
%global upstream_version 614b55f
|
||||||
|
|
||||||
# SSLeay (required by ldirectord)
|
# SSLeay (required by ldirectord)
|
||||||
%if 0%{?suse_version}
|
%if 0%{?suse_version}
|
||||||
@ -36,7 +36,7 @@
|
|||||||
Name: resource-agents
|
Name: resource-agents
|
||||||
Summary: Open Source HA Reusable Cluster Resource Scripts
|
Summary: Open Source HA Reusable Cluster Resource Scripts
|
||||||
Version: 3.9.5
|
Version: 3.9.5
|
||||||
Release: 10%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
Release: 11%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
||||||
License: GPLv2+ and LGPLv2+
|
License: GPLv2+ and LGPLv2+
|
||||||
URL: https://github.com/ClusterLabs/resource-agents
|
URL: https://github.com/ClusterLabs/resource-agents
|
||||||
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
||||||
@ -45,7 +45,6 @@ Group: System Environment/Base
|
|||||||
Group: Productivity/Clustering/HA
|
Group: Productivity/Clustering/HA
|
||||||
%endif
|
%endif
|
||||||
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
|
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
|
||||||
Patch0: fix_build_system.patch
|
|
||||||
Obsoletes: heartbeat-resources <= %{version}
|
Obsoletes: heartbeat-resources <= %{version}
|
||||||
Provides: heartbeat-resources = %{version}
|
Provides: heartbeat-resources = %{version}
|
||||||
|
|
||||||
@ -149,7 +148,6 @@ See 'ldirectord -h' and linux-ha/doc/ldirectord for more information.
|
|||||||
exit 1
|
exit 1
|
||||||
%endif
|
%endif
|
||||||
%setup -q -n %{upstream_prefix}-%{upstream_version}
|
%setup -q -n %{upstream_prefix}-%{upstream_version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if [ ! -f configure ]; then
|
if [ ! -f configure ]; then
|
||||||
@ -259,7 +257,7 @@ rm -rf %{buildroot}
|
|||||||
%dir %{_sysconfdir}/ha.d
|
%dir %{_sysconfdir}/ha.d
|
||||||
%{_sysconfdir}/ha.d/shellfuncs
|
%{_sysconfdir}/ha.d/shellfuncs
|
||||||
|
|
||||||
%{_libdir}/heartbeat
|
%{_libexecdir}/heartbeat
|
||||||
|
|
||||||
%if %{with rgmanager}
|
%if %{with rgmanager}
|
||||||
%post -n resource-agents
|
%post -n resource-agents
|
||||||
@ -302,6 +300,9 @@ ccs_update_schema > /dev/null 2>&1 ||:
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Thu Jan 2 2014 David Vossel <dvossel@redhat.com> - 3.9.5-11
|
||||||
|
- Sync with latest upstream.
|
||||||
|
|
||||||
* Wed Oct 20 2013 David Vossel <dvossel@redhat.com> - 3.9.5-10
|
* Wed Oct 20 2013 David Vossel <dvossel@redhat.com> - 3.9.5-10
|
||||||
- Fix build system for rawhide.
|
- Fix build system for rawhide.
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user