- Rebase to resource-agents 4.15.0 upstream release.

- IPaddr2: change default for lvs_ipv6_addrlabel to true to avoid
  last added IP becoming src IP

  Resolves: RHEL-50378, RHEL-46557
This commit is contained in:
Oyvind Albrigtsen 2024-07-24 10:35:38 +02:00
parent 69a67cf354
commit 200f2b0ca1
4 changed files with 11 additions and 90 deletions

View File

@ -1,60 +0,0 @@
From 9dc93c146edc904151f7a67aa3e4136b5a5392b5 Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Tue, 18 Jun 2024 10:42:24 +0200
Subject: [PATCH 1/2] apache/http-mon.sh: dont use -L for wget2 as it's not
implemented yet
---
heartbeat/http-mon.sh | 4 +++-
1 file changed, 3 insertions(+), 1 deletion(-)
diff --git a/heartbeat/http-mon.sh b/heartbeat/http-mon.sh
index ce13ccd39a..ddd79c1f92 100644
--- a/heartbeat/http-mon.sh
+++ b/heartbeat/http-mon.sh
@@ -21,7 +21,7 @@ if ocf_is_true "$OCF_RESKEY_use_ipv6" || echo "$STATUSURL" | grep -qs "::"; then
bind_address="::1"
curl_ipv6_opts="-g"
fi
-WGETOPTS="-O- -q -L --no-proxy --bind-address=$bind_address"
+WGETOPTS="-O- -q --no-proxy --bind-address=$bind_address"
CURLOPTS="-o - -Ss -L --interface lo $curl_ipv6_opts"
request_url_header() {
@@ -58,6 +58,8 @@ curl_func() {
fi
}
wget_func() {
+ # -L not implemented in wget2
+ wget -V | grep -q "^GNU Wget2 " || WGETOPTS="$WGETOPTS -L"
auth=""
cl_opts="$WGETOPTS $test_httpclient_opts"
[ x != "x$test_user" ] &&
From b2ca07d84f023623eed6d81edb26eb3dd597e7e3 Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Wed, 26 Jun 2024 16:05:24 +0200
Subject: [PATCH 2/2] apache/http-mon.sh: prefer curl due to new wget2 issues,
including not being able to resolve hostnames from /etc/hosts
---
heartbeat/http-mon.sh | 4 ++--
1 file changed, 2 insertions(+), 2 deletions(-)
diff --git a/heartbeat/http-mon.sh b/heartbeat/http-mon.sh
index ddd79c1f92..44ca8968e1 100644
--- a/heartbeat/http-mon.sh
+++ b/heartbeat/http-mon.sh
@@ -79,10 +79,10 @@ findhttpclient() {
# prefer wget (for historical reasons)
if [ "x$CLIENT" != x ] && which "$CLIENT" >/dev/null 2>&1; then
echo "$CLIENT"
- elif which wget >/dev/null 2>&1; then
- echo "wget"
elif which curl >/dev/null 2>&1; then
echo "curl"
+ elif which wget >/dev/null 2>&1; then
+ echo "wget"
else
return 1
fi

View File

@ -1,22 +0,0 @@
From a97a00c37d8a15ee3a8d11ac00281626f55790b3 Mon Sep 17 00:00:00 2001
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
Date: Mon, 8 Jan 2024 15:07:19 +0100
Subject: [PATCH] configure: fix "C preprocessor "gcc -E" fails sanity check"
error caused by autoconf 2.72
---
configure.ac | 1 +
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
index 74766899b..67b9ddd35 100644
--- a/configure.ac
+++ b/configure.ac
@@ -81,6 +81,7 @@ fi
AC_PROG_CC dnl Can force other with environment variable "CC".
AM_PROG_CC_C_O
AC_PROG_CC_STDC
+AC_PROG_CPP
AC_PROG_AWK
AC_PROG_LN_S
AC_PROG_INSTALL

View File

@ -20,7 +20,7 @@
#
%global upstream_prefix ClusterLabs-resource-agents
%global upstream_version 204f1461
%global upstream_version 92a213d8
# Whether this platform defaults to using systemd as an init system
# (needs to be evaluated prior to BuildRequires being enumerated and
@ -44,14 +44,12 @@
Name: resource-agents
Summary: Open Source HA Reusable Cluster Resource Scripts
Version: 4.13.0
Release: 6%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
Version: 4.15.0
Release: 1%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
License: GPL-2.0-or-later AND LGPL-2.1-or-later
URL: https://github.com/ClusterLabs/resource-agents
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
Patch0: pgsqlms-ra.patch
Patch1: configure-fix-sanity-check-autoconf-2.72.patch
Patch2: RHEL-40720-prefer-curl-dont-use-L-for-wget2.patch
# bundled ha-cloud-support libs
Patch500: ha-cloud-support-aliyun.patch
@ -202,8 +200,6 @@ exit 1
%endif
%setup -q -n %{upstream_prefix}-%{upstream_version}
%patch -p1 -P 0
%patch -p1 -P 1
%patch -p1 -P 2
# bundled ha-cloud-support libs
%patch -p1 -P 500
@ -516,6 +512,13 @@ rm -rf %{buildroot}/usr/share/doc/resource-agents
%{_usr}/lib/ocf/lib/heartbeat/OCF_*.pm
%changelog
* Wed Jul 24 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.15.0-1
- Rebase to resource-agents 4.15.0 upstream release.
- IPaddr2: change default for lvs_ipv6_addrlabel to true to avoid
last added IP becoming src IP
Resolves: RHEL-50378, RHEL-46557
* Thu Jun 27 2024 Oyvind Albrigtsen <oalbrigt@redhat.com> - 4.13.0-6
- apache: prefer curl due to wget2 issues, and dont use -L for wget2

View File

@ -1 +1 @@
SHA512 (ClusterLabs-resource-agents-204f1461.tar.gz) = 69a82bd10b441c5dcff23ed2021659f8815bd0e62b1247a94eb01975db785d70ce9fc8a2c5c721f104f94937bc2ea8e8e6b6f3e5f526dc1cddcfc830c845721e
SHA512 (ClusterLabs-resource-agents-92a213d8.tar.gz) = 6d3fcc8118bf531bedb86e4099faacdcb6f229529f6a21c4e99d436a1c309cc3dfba5d91d7c8870db8dc639d415f763310318775f0b37351bc2862376cff9eb7