import resource-agents-sap-hana-0.154.0-2.el8
This commit is contained in:
parent
d21e60febb
commit
01bd391ad4
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
|||||||
SOURCES/ClusterLabs-resource-agents-e711383f.tar.gz
|
SOURCES/ClusterLabs-resource-agents-e711383f.tar.gz
|
||||||
SOURCES/SAPHanaSR-2067519.tar.gz
|
SOURCES/SAPHanaSR-d1dde99.tar.gz
|
||||||
|
@ -1,2 +1,2 @@
|
|||||||
0358e1cb7fe86b2105bd2646cbe86f3c0273844a SOURCES/ClusterLabs-resource-agents-e711383f.tar.gz
|
0358e1cb7fe86b2105bd2646cbe86f3c0273844a SOURCES/ClusterLabs-resource-agents-e711383f.tar.gz
|
||||||
92409ca65e8f4e63d5c308368861fa67ced470f1 SOURCES/SAPHanaSR-2067519.tar.gz
|
442679403d1287835841d70c5bef208a330c2c11 SOURCES/SAPHanaSR-d1dde99.tar.gz
|
||||||
|
@ -1,49 +0,0 @@
|
|||||||
From d43d8af650ee9ed175ebd4fdfc15ac2767734a8d Mon Sep 17 00:00:00 2001
|
|
||||||
From: Fabian Herschel <fabian.herschel@suse.com>
|
|
||||||
Date: Wed, 25 Jul 2018 12:30:32 +0200
|
|
||||||
Subject: [PATCH] ra/SAPHanaTopology: bsc#1016691 "SAPHanaSR: Status file of
|
|
||||||
SAPHanaTopology is not multi instance aware (MCOS)"
|
|
||||||
|
|
||||||
---
|
|
||||||
SAPHana/ra/SAPHanaTopology | 20 +++++++++++---------
|
|
||||||
1 file changed, 11 insertions(+), 9 deletions(-)
|
|
||||||
|
|
||||||
diff --git a/SAPHanaSR-2067519/SAPHana/ra/SAPHanaTopology b/SAPHanaSR-2067519/SAPHana/ra/SAPHanaTopology
|
|
||||||
index 1e2f301..20d2593 100755
|
|
||||||
--- a/SAPHanaSR-2067519/SAPHana/ra/SAPHanaTopology
|
|
||||||
+++ b/SAPHanaSR-2067519/SAPHana/ra/SAPHanaTopology
|
|
||||||
@@ -28,7 +28,7 @@
|
|
||||||
#######################################################################
|
|
||||||
#
|
|
||||||
# Initialization:
|
|
||||||
-SAPHanaVersion="0.152.21"
|
|
||||||
+SAPHanaVersion="0.152.22"
|
|
||||||
timeB=$(date '+%s')
|
|
||||||
|
|
||||||
: ${OCF_FUNCTIONS_DIR=${OCF_ROOT}/lib/heartbeat}
|
|
||||||
@@ -736,15 +736,17 @@ function sht_start() {
|
|
||||||
# sht_stop: Stop the SAP HANA Topology Resource
|
|
||||||
#
|
|
||||||
function sht_stop() {
|
|
||||||
- super_ocf_log info "FLOW $FUNCNAME ($*)"
|
|
||||||
- local output=""
|
|
||||||
- local rc=0
|
|
||||||
-
|
|
||||||
- rm $HA_RSCTMP/SAPHana/SAPTopologyON.${SID}
|
|
||||||
- rc=$OCF_SUCCESS
|
|
||||||
+ super_ocf_log info "FLOW $FUNCNAME ($*)"
|
|
||||||
+ local output=""
|
|
||||||
+ local rc=0
|
|
||||||
+ if [ -f $HA_RSCTMP/SAPHana/SAPTopologyON ]; then
|
|
||||||
+ rm $HA_RSCTMP/SAPHana/SAPTopologyON
|
|
||||||
+ fi
|
|
||||||
+ rm $HA_RSCTMP/SAPHana/SAPTopologyON.${SID}
|
|
||||||
+ rc=$OCF_SUCCESS
|
|
||||||
|
|
||||||
- super_ocf_log info "FLOW $FUNCNAME rc=$rc"
|
|
||||||
- return $rc
|
|
||||||
+ super_ocf_log info "FLOW $FUNCNAME rc=$rc"
|
|
||||||
+ return $rc
|
|
||||||
}
|
|
||||||
|
|
||||||
|
|
@ -23,23 +23,22 @@
|
|||||||
%global upstream_version e711383f
|
%global upstream_version e711383f
|
||||||
|
|
||||||
%global saphana_prefix SAPHanaSR
|
%global saphana_prefix SAPHanaSR
|
||||||
%global saphana_hash 2067519
|
%global saphana_version d1dde99
|
||||||
|
|
||||||
Name: resource-agents-sap-hana
|
Name: resource-agents-sap-hana
|
||||||
Summary: SAP HANA cluster resource agents
|
Summary: SAP HANA cluster resource agents
|
||||||
Epoch: 1
|
Epoch: 1
|
||||||
Version: 0.152.22
|
Version: 0.154.0
|
||||||
Release: 1%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
Release: 2%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
||||||
License: GPLv2+
|
License: GPLv2+
|
||||||
URL: https://github.com/fmherschel/SAPHanaSR
|
URL: https://github.com/SUSE/SAPHanaSR
|
||||||
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
||||||
Group: System Environment/Base
|
Group: System Environment/Base
|
||||||
%else
|
%else
|
||||||
Group: Productivity/Clustering/HA
|
Group: Productivity/Clustering/HA
|
||||||
%endif
|
%endif
|
||||||
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
|
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
|
||||||
Source1: %{saphana_prefix}-%{saphana_hash}.tar.gz
|
Source1: %{saphana_prefix}-%{saphana_version}.tar.gz
|
||||||
Patch0: bz1738205-SAPHanaTopology-make-multi-instance-aware.patch
|
|
||||||
|
|
||||||
BuildArch: noarch
|
BuildArch: noarch
|
||||||
|
|
||||||
@ -52,6 +51,7 @@ BuildRequires: docbook-style-xsl docbook-dtds
|
|||||||
%endif
|
%endif
|
||||||
|
|
||||||
Requires: resource-agents >= 4.1.1
|
Requires: resource-agents >= 4.1.1
|
||||||
|
Conflicts: %{name}-scaleout
|
||||||
|
|
||||||
Requires: /bin/bash /usr/bin/grep /bin/sed /bin/gawk
|
Requires: /bin/bash /usr/bin/grep /bin/sed /bin/gawk
|
||||||
Requires: perl
|
Requires: perl
|
||||||
@ -62,15 +62,16 @@ SAP instances to be managed in a cluster environment.
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n %{upstream_prefix}-%{upstream_version}
|
%setup -q -n %{upstream_prefix}-%{upstream_version}
|
||||||
%setup -T -D -a 1 -n %{upstream_prefix}-%{upstream_version}
|
%setup -q -T -D -a 1 -n %{upstream_prefix}-%{upstream_version}
|
||||||
|
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
# add SAPHana agents to Makefile.am
|
# add SAPHana agents to Makefile.am
|
||||||
mv %{saphana_prefix}-%{saphana_hash}/SAPHana/ra/SAPHana* heartbeat
|
mv %{saphana_prefix}-%{saphana_version}/ra/SAPHana* heartbeat
|
||||||
sed -i -e '/ SAPInstance \\/a\ SAPHana \\\n SAPHanaTopology \\' heartbeat/Makefile.am
|
sed -i -e '/ SAPInstance \\/a\ SAPHana \\\n SAPHanaTopology \\' heartbeat/Makefile.am
|
||||||
sed -i -e '/ ocf_heartbeat_SAPInstance.7 \\/a\ ocf_heartbeat_SAPHana.7 \\\n ocf_heartbeat_SAPHanaTopology.7 \\' doc/man/Makefile.am
|
sed -i -e '/ ocf_heartbeat_SAPInstance.7 \\/a\ ocf_heartbeat_SAPHana.7 \\\n ocf_heartbeat_SAPHanaTopology.7 \\' doc/man/Makefile.am
|
||||||
|
|
||||||
|
# change provider company
|
||||||
|
sed -i -e 's/\("provider_company": \)"SUSE"/\1"Red Hat"/g' %{saphana_prefix}-%{saphana_version}/srHook/SAPHanaSR.py
|
||||||
|
|
||||||
%build
|
%build
|
||||||
if [ ! -f configure ]; then
|
if [ ! -f configure ]; then
|
||||||
./autogen.sh
|
./autogen.sh
|
||||||
@ -99,6 +100,9 @@ make install DESTDIR=%{buildroot}
|
|||||||
find %{buildroot}/usr/lib/ocf ! -type d ! -iname "SAPHana*" -exec rm {} \;
|
find %{buildroot}/usr/lib/ocf ! -type d ! -iname "SAPHana*" -exec rm {} \;
|
||||||
find %{buildroot}/%{_mandir} -type f ! -iname "*SAPHana*" -exec rm {} \;
|
find %{buildroot}/%{_mandir} -type f ! -iname "*SAPHana*" -exec rm {} \;
|
||||||
|
|
||||||
|
mkdir %{buildroot}/%{_datadir}/SAPHanaSR
|
||||||
|
cp -r %{saphana_prefix}-%{saphana_version}/srHook %{buildroot}/%{_datadir}/SAPHanaSR
|
||||||
|
|
||||||
## tree fixup
|
## tree fixup
|
||||||
# remove docs (there is only one and they should come from doc sections in files)
|
# remove docs (there is only one and they should come from doc sections in files)
|
||||||
rm -rf %{buildroot}/usr/share/doc/resource-agents
|
rm -rf %{buildroot}/usr/share/doc/resource-agents
|
||||||
@ -110,6 +114,7 @@ rm -rf %{buildroot}
|
|||||||
%defattr(-,root,root)
|
%defattr(-,root,root)
|
||||||
%{_usr}/lib/ocf/resource.d/heartbeat/SAPHana*
|
%{_usr}/lib/ocf/resource.d/heartbeat/SAPHana*
|
||||||
%{_mandir}/man7/*SAP*
|
%{_mandir}/man7/*SAP*
|
||||||
|
%{_datadir}/SAPHanaSR
|
||||||
|
|
||||||
%exclude /etc
|
%exclude /etc
|
||||||
%exclude /usr/include
|
%exclude /usr/include
|
||||||
@ -122,6 +127,11 @@ rm -rf %{buildroot}
|
|||||||
%exclude /usr/src
|
%exclude /usr/src
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Feb 14 2020 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.154.0-2
|
||||||
|
- Rebase to SAPHanaSR 0.154.0 upstream release.
|
||||||
|
|
||||||
|
Resolves: rhbz#1802104
|
||||||
|
|
||||||
* Fri Sep 6 2019 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.152.22-1
|
* Fri Sep 6 2019 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.152.22-1
|
||||||
- SAPHanaTopology: make multi instance aware (MCOS)
|
- SAPHanaTopology: make multi instance aware (MCOS)
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user