import resource-agents-sap-hana-scaleout-0.180.0-0.el8_4.3
This commit is contained in:
parent
c62af46af7
commit
46027d79ed
2
.gitignore
vendored
2
.gitignore
vendored
@ -1,2 +1,2 @@
|
||||
SOURCES/ClusterLabs-resource-agents-e711383f.tar.gz
|
||||
SOURCES/SAPHanaSR-ScaleOut-a77e8c6.tar.gz
|
||||
SOURCES/SAPHanaSR-ScaleOut-c2af06c.tar.gz
|
||||
|
@ -1,2 +1,2 @@
|
||||
0358e1cb7fe86b2105bd2646cbe86f3c0273844a SOURCES/ClusterLabs-resource-agents-e711383f.tar.gz
|
||||
e5624e3028720d0d55ab3d598655a1938042e26c SOURCES/SAPHanaSR-ScaleOut-a77e8c6.tar.gz
|
||||
b41ef7b3fbee84079804580c0159967fe5ca03ca SOURCES/SAPHanaSR-ScaleOut-c2af06c.tar.gz
|
||||
|
@ -1,23 +0,0 @@
|
||||
From 9eafa6e3dd9735bdd1e4e447d9e8c3d4da1e9c30 Mon Sep 17 00:00:00 2001
|
||||
From: Oyvind Albrigtsen <oalbrigt@redhat.com>
|
||||
Date: Thu, 27 Jun 2019 10:38:46 +0200
|
||||
Subject: [PATCH] SAPHanaSR-monitor: fix tolower() issue, which seems to be an
|
||||
artifact from a2p (Awk to Perl)
|
||||
|
||||
---
|
||||
SAPHana/bin/SAPHanaSR-monitor | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/bin/SAPHanaSR-monitor b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/bin/SAPHanaSR-monitor
|
||||
index 737545c..da6bf08 100755
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/bin/SAPHanaSR-monitor
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/bin/SAPHanaSR-monitor
|
||||
@@ -219,7 +219,7 @@ sub processMonitor() {
|
||||
#
|
||||
$sid=$sids[0]; # currently ony one sid is supported
|
||||
( $sid, $ino ) = split(":", $sid);
|
||||
- $sid=tolower("$sid");
|
||||
+ $sid=lc("$sid");
|
||||
get_hana_attributes($sid, \%Host, \%HName, \%Global, \%GName, \%Site, \%SName);
|
||||
if ( keys(%Host) == 0 ) {
|
||||
printf "No attributes found for SID=%s\n", $sid;
|
@ -1,34 +0,0 @@
|
||||
From 5c868c9d17e1c07711ee5423ed26d8f0f6562692 Mon Sep 17 00:00:00 2001
|
||||
From: Frank Danapfel <frank.danapfel@redhat.com>
|
||||
Date: Wed, 25 Mar 2020 11:09:49 +0100
|
||||
Subject: [PATCH] SAPHanaController: update start/stop/promote/monitor action
|
||||
default timeouts to match official recommendations
|
||||
|
||||
---
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController | 12 ++++++------
|
||||
1 file changed, 6 insertions(+), 6 deletions(-)
|
||||
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
index 1781b99..08239ed 100755
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
@@ -269,13 +269,13 @@ The resource agent uses the following four interfaces provided by SAP:
|
||||
</parameters>
|
||||
|
||||
<actions>
|
||||
- <action name="start" timeout="180" />
|
||||
- <action name="stop" timeout="240" />
|
||||
+ <action name="start" timeout="3600" />
|
||||
+ <action name="stop" timeout="3600" />
|
||||
<action name="status" timeout="60" />
|
||||
- <action name="monitor" depth="0" timeout="60" interval="120" />
|
||||
- <action name="monitor" depth="0" timeout="60" interval="121" role="Slave" />
|
||||
- <action name="monitor" depth="0" timeout="60" interval="119" role="Master" />
|
||||
- <action name="promote" timeout="320" />
|
||||
+ <action name="monitor" depth="0" timeout="700" interval="60" />
|
||||
+ <action name="monitor" depth="0" timeout="700" interval="61" role="Slave" />
|
||||
+ <action name="monitor" depth="0" timeout="700" interval="60" role="Master" />
|
||||
+ <action name="promote" timeout="3600" />
|
||||
<action name="demote" timeout="320" />
|
||||
<action name="validate-all" timeout="5" />
|
||||
<action name="meta-data" timeout="5" />
|
@ -1,28 +0,0 @@
|
||||
From 2039335555b89262b325d1ceb03844cfabe35869 Mon Sep 17 00:00:00 2001
|
||||
From: Frank Danapfel <frank.danapfel@redhat.com>
|
||||
Date: Wed, 25 Mar 2020 11:04:46 +0100
|
||||
Subject: [PATCH] SAPHanaTopology: update start/stop/monitor action default
|
||||
timeouts to match official recommendations
|
||||
|
||||
---
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology
|
||||
index 1e9a5c6..c83901a 100755
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology
|
||||
@@ -189,10 +189,10 @@ SAPHanaTopology scans the output table of landscapeHostConfiguration.py to ident
|
||||
</parameter>
|
||||
</parameters>
|
||||
<actions>
|
||||
- <action name="start" timeout="180" />
|
||||
- <action name="stop" timeout="60" />
|
||||
+ <action name="start" timeout="600" />
|
||||
+ <action name="stop" timeout="300" />
|
||||
<action name="status" timeout="60" />
|
||||
- <action name="monitor" depth="0" timeout="60" interval="60" />
|
||||
+ <action name="monitor" depth="0" timeout="600" interval="10" />
|
||||
<action name="validate-all" timeout="5" />
|
||||
<action name="meta-data" timeout="5" />
|
||||
<action name="methods" timeout="5" />
|
@ -1,108 +0,0 @@
|
||||
From 600160015e965ea67f716e1a332fbd92b855807c Mon Sep 17 00:00:00 2001
|
||||
From: AngelaBriel <abriel@suse.com>
|
||||
Date: Tue, 12 Nov 2019 18:05:14 +0100
|
||||
Subject: [PATCH] Use a fall-back scoring for the master nameserver nodes, if
|
||||
the current roles of the node(s) got lost. (bsc#1156067) version bump to
|
||||
0.164.0 remove old version(11SP3 from Dez. 2014) of
|
||||
SAPHana/doc/SAPHanaSR-Setup-Guide.pdf. Add a Link to
|
||||
https://www.suse.com/products/sles-for-sap/resource-library/sap-best-practices.html
|
||||
instead.
|
||||
|
||||
---
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.changes | 11 +++++++++++
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.spec | 3 ++-
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController | 4 +++-
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology | 3 ++-
|
||||
4 files changed, 19 insertions(+), 3 deletions(-)
|
||||
create mode 100644 .gitignore
|
||||
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.changes b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.changes
|
||||
index fea4c46..9749d8b 100644
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.changes
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.changes
|
||||
@@ -1,3 +1,14 @@
|
||||
+-------------------------------------------------------------------
|
||||
+Mon Nov 11 10:44:44 UTC 2019 - abriel@suse.com
|
||||
+
|
||||
+- change version to 0.164.0
|
||||
+- restart sapstartsrv service on master nameserver node
|
||||
+ (bsc#1156150)
|
||||
+- Use a fall-back scoring for the master nameserver nodes, if the
|
||||
+ current roles of the node(s) got lost.
|
||||
+ (bsc#1156067)
|
||||
+- clean up package, add checks, correct typos
|
||||
+
|
||||
-------------------------------------------------------------------
|
||||
Wed Sep 12 12:19:06 UTC 2018 - clanig@suse.de
|
||||
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.spec b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.spec
|
||||
index 4dc7093..4790be6 100644
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.spec
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/SAPHanaSR-ScaleOut.spec
|
||||
@@ -2,6 +2,7 @@
|
||||
# spec file for package SAPHanaSR-ScaleOut
|
||||
#
|
||||
# Copyright (c) 2016 SUSE LINUX GmbH, Nuernberg, Germany.
|
||||
+# Copyright (c) 2017-2019 SUSE LLC
|
||||
#
|
||||
# All modifications and additions to the file contributed by third parties
|
||||
# remain the property of their copyright owners, unless otherwise agreed
|
||||
@@ -20,7 +21,7 @@ License: GPL-2.0
|
||||
Group: Productivity/Clustering/HA
|
||||
AutoReqProv: on
|
||||
Summary: Resource agents to control the HANA database in system replication setup
|
||||
-Version: 0.163.2
|
||||
+Version: 0.164.0
|
||||
Release: 0
|
||||
Url: http://scn.sap.com/community/hana-in-memory/blog/2014/04/04/fail-safe-operation-of-sap-hana-suse-extends-its-high-availability-solution
|
||||
Source0: SAPHanaSR-ScaleOut-%{version}.tar.bz2
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
index 5b24513..1781b99 100755
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
@@ -12,6 +12,7 @@
|
||||
# License: GNU General Public License (GPL)
|
||||
# Copyright: (c) 2013,2014 SUSE Linux Products GmbH
|
||||
# Copyright: (c) 2015-2016 SUSE Linux GmbH
|
||||
+# Copyright: (c) 2017-2019 SUSE LLC
|
||||
#
|
||||
# An example usage:
|
||||
# See usage() function below for more details...
|
||||
@@ -33,7 +34,7 @@
|
||||
# systemReplicationStatus.py (>= SPS090)
|
||||
#
|
||||
#######################################################################
|
||||
-SAPHanaControllerVersion="0.163.2"
|
||||
+SAPHanaControllerVersion="0.164.0"
|
||||
#
|
||||
# Initialization:
|
||||
timeB=$(date '+%s')
|
||||
@@ -702,6 +703,7 @@ function saphana_init() {
|
||||
#
|
||||
SCORING_TABLE_PREFERRED_SITE_TAKEOVER=(
|
||||
"[234]:P:master[123]:master .* 150"
|
||||
+ "[234]:P:master[123] .* 140"
|
||||
"[234]:P:master[123]:slave:.*:standby .* 115"
|
||||
"[234]:P:master[123]:slave .* 110"
|
||||
"[015]:P:master[123]: .* 70"
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology
|
||||
index 2e3b065..1e9a5c6 100755
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaTopology
|
||||
@@ -14,6 +14,7 @@
|
||||
# License: GNU General Public License (GPL)
|
||||
# Copyright: (c) 2014 SUSE Linux Products GmbH
|
||||
# (c) 2015-2016 SUSE Linux GmbH
|
||||
+# (c) 2017-2019 SUSE LLC
|
||||
#
|
||||
# An example usage:
|
||||
# See usage() function below for more details...
|
||||
@@ -25,7 +26,7 @@
|
||||
#
|
||||
#######################################################################
|
||||
# DONE PRIO 1: AFTER(!) SAP HANA SPS12 is available we could use hdbnsutil --sr_stateConfiguration
|
||||
-SAPHanaTopologyVersion="0.163.2"
|
||||
+SAPHanaTopologyVersion="0.164.0"
|
||||
#
|
||||
# Initialization:
|
||||
timeB=$(date '+%s')
|
@ -1,25 +0,0 @@
|
||||
From 60eb13d27b8be8f38ab037432de9a8a14181f207 Mon Sep 17 00:00:00 2001
|
||||
From: Fabian Herschel <fabian.herschel@suse.com>
|
||||
Date: Thu, 7 Nov 2019 15:52:42 +0100
|
||||
Subject: [PATCH] bsc#1156150: SAPHanaSR: sapstartsrv service on
|
||||
master_nameserver node not restarted when being forcefully killed
|
||||
|
||||
---
|
||||
SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController | 2 ++
|
||||
1 file changed, 2 insertions(+)
|
||||
|
||||
diff --git a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
index e139053..5b24513 100755
|
||||
--- a/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
+++ b/SAPHanaSR-ScaleOut-a77e8c6/SAPHana/ra/SAPHanaController
|
||||
@@ -2569,8 +2569,10 @@ function saphana_monitor_clone() {
|
||||
#
|
||||
check_for_primary; primary_status=$?
|
||||
if [ $primary_status -eq $HANA_STATE_PRIMARY ]; then
|
||||
+ saphana_check_local_instance
|
||||
saphana_monitor_primary; rc=$?
|
||||
elif [ $primary_status -eq $HANA_STATE_SECONDARY ]; then
|
||||
+ saphana_check_local_instance
|
||||
saphana_monitor_secondary; rc=$?
|
||||
else
|
||||
#
|
@ -23,13 +23,13 @@
|
||||
%global upstream_version e711383f
|
||||
|
||||
%global saphana_scaleout_prefix SAPHanaSR-ScaleOut
|
||||
%global saphana_scaleout_hash a77e8c6
|
||||
%global saphana_scaleout_hash c2af06c
|
||||
|
||||
Name: resource-agents-sap-hana-scaleout
|
||||
Summary: SAP HANA Scale-Out cluster resource agents
|
||||
Epoch: 1
|
||||
Version: 0.164.0
|
||||
Release: 1%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}
|
||||
Version: 0.180.0
|
||||
Release: 0%{?rcver:%{rcver}}%{?numcomm:.%{numcomm}}%{?alphatag:.%{alphatag}}%{?dirty:.%{dirty}}%{?dist}.3
|
||||
License: GPLv2+
|
||||
URL: https://github.com/SUSE/SAPHanaSR-ScaleOut
|
||||
%if 0%{?fedora} || 0%{?centos_version} || 0%{?rhel}
|
||||
@ -39,11 +39,6 @@ Group: Productivity/Clustering/HA
|
||||
%endif
|
||||
Source0: %{upstream_prefix}-%{upstream_version}.tar.gz
|
||||
Source1: %{saphana_scaleout_prefix}-%{saphana_scaleout_hash}.tar.gz
|
||||
Patch0: SAPHanaSR-monitor-fix-tolower-error.patch
|
||||
Patch1: bz1827107-sap-hana-scaleout-1-timeouts-recommendations.patch
|
||||
Patch2: bz1827107-sap-hana-scaleout-2-timeouts-recommendations.patch
|
||||
Patch3: bz1827107-sap-hana-scaleout-3-fixes.patch
|
||||
Patch4: bz1827107-sap-hana-scaleout-4-sapstartsrv-fix.patch
|
||||
|
||||
BuildArch: noarch
|
||||
|
||||
@ -70,12 +65,6 @@ environment.
|
||||
%setup -q -n %{upstream_prefix}-%{upstream_version}
|
||||
%setup -q -T -D -a 1 -n %{upstream_prefix}-%{upstream_version}
|
||||
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
%patch2 -p1
|
||||
%patch3 -p1
|
||||
%patch4 -p1
|
||||
|
||||
# add SAPHana agents to Makefile.am
|
||||
mv %{saphana_scaleout_prefix}-%{saphana_scaleout_hash}/SAPHana/ra/SAPHana* heartbeat
|
||||
sed -i -e '/ SAPInstance \\/a\ SAPHanaController \\\n SAPHanaTopology \\' heartbeat/Makefile.am
|
||||
@ -156,8 +145,14 @@ rm -rf %{buildroot}
|
||||
%exclude /usr/sbin/ocf*
|
||||
%exclude /usr/share/%{name}
|
||||
%exclude /usr/src
|
||||
%exclude %{_mandir}/man8/SAPHanaSR-manageAttr.8.gz
|
||||
|
||||
%changelog
|
||||
* Mon Aug 2 2021 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.180.0-0.3
|
||||
- Add HANA MTR multi-site cluster support
|
||||
|
||||
Resolves: rhbz#1987660
|
||||
|
||||
* Thu Apr 30 2020 Oyvind Albrigtsen <oalbrigt@redhat.com> - 0.164.0-1
|
||||
- Set default timeouts based on recommendations and a couple of bugfixes
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user