54 lines
1.6 KiB
Diff
54 lines
1.6 KiB
Diff
From efdb3b41171d335511af511b0a0cdf43cde2144a Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Ha=C3=AFkel=20Gu=C3=A9mar?= <hguemar@fedoraproject.org>
|
|
Date: Mon, 8 Dec 2014 10:02:54 +0100
|
|
Subject: [PATCH 2/7] redis 3.2.3: deps library fPIC performance tuning
|
|
|
|
---
|
|
deps/Makefile | 2 +-
|
|
deps/geohash-int/Makefile | 2 +-
|
|
deps/linenoise/Makefile | 2 +-
|
|
3 files changed, 3 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/deps/Makefile b/deps/Makefile
|
|
index 1c10bce..14839de 100644
|
|
--- a/deps/Makefile
|
|
+++ b/deps/Makefile
|
|
@@ -59,7 +59,7 @@ ifeq ($(uname_S),SunOS)
|
|
LUA_CFLAGS= -D__C99FEATURES__=1
|
|
endif
|
|
|
|
-LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS)
|
|
+LUA_CFLAGS+= -O2 -Wall -DLUA_ANSI -DENABLE_CJSON_GLOBAL -DREDIS_STATIC='' $(CFLAGS) -fPIC
|
|
LUA_LDFLAGS+= $(LDFLAGS)
|
|
# lua's Makefile defines AR="ar rcu", which is unusual, and makes it more
|
|
# challenging to cross-compile lua (and redis). These defines make it easier
|
|
diff --git a/deps/geohash-int/Makefile b/deps/geohash-int/Makefile
|
|
index b7c2595..d8b5b40 100644
|
|
--- a/deps/geohash-int/Makefile
|
|
+++ b/deps/geohash-int/Makefile
|
|
@@ -2,7 +2,7 @@ STD=
|
|
WARN= -Wall
|
|
OPT= -O2
|
|
|
|
-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
|
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
|
|
R_LDFLAGS= $(LDFLAGS)
|
|
DEBUG= -g
|
|
|
|
diff --git a/deps/linenoise/Makefile b/deps/linenoise/Makefile
|
|
index 1dd894b..712f2a6 100644
|
|
--- a/deps/linenoise/Makefile
|
|
+++ b/deps/linenoise/Makefile
|
|
@@ -2,7 +2,7 @@ STD=
|
|
WARN= -Wall
|
|
OPT= -Os
|
|
|
|
-R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS)
|
|
+R_CFLAGS= $(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) -fPIC
|
|
R_LDFLAGS= $(LDFLAGS)
|
|
DEBUG= -g
|
|
|
|
--
|
|
2.9.3
|
|
|