9f0877ed49
For cases where we have two ways of doing one thing (using a patch or sed-based modification of files), rework these such that we're only using one method. Allows several of the patches to be dropped. Described in https://github.com/antirez/redis/issues/1417 is a method for allowing integration/replication-psync to be reliably run - start using it, and drop the patch that was disabling that test. Other small side-effects of this commit: - the build warning about "jemalloc not found" is fixed; - CFLAGS additions are now consistently handled (for deps as well) - using the upstream-provided mechanism for compiler flag propogation.
26 lines
893 B
Diff
26 lines
893 B
Diff
From bcd509def0d4a75f56d9d6a53eea280127803eb4 Mon Sep 17 00:00:00 2001
|
|
From: Remi Collet <fedora@famillecollet.com>
|
|
Date: Fri, 9 Sep 2016 17:23:27 +0200
|
|
Subject: [PATCH 7/7] install redis-check-rdb as a symlink instead of
|
|
duplicating the binary
|
|
|
|
---
|
|
src/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/Makefile b/src/Makefile
|
|
index 6c27dd9..2de5e3f 100644
|
|
--- a/src/Makefile
|
|
+++ b/src/Makefile
|
|
@@ -267,6 +267,6 @@ install: all
|
|
$(REDIS_INSTALL) $(REDIS_SERVER_NAME) $(INSTALL_BIN)
|
|
$(REDIS_INSTALL) $(REDIS_BENCHMARK_NAME) $(INSTALL_BIN)
|
|
$(REDIS_INSTALL) $(REDIS_CLI_NAME) $(INSTALL_BIN)
|
|
- $(REDIS_INSTALL) $(REDIS_CHECK_RDB_NAME) $(INSTALL_BIN)
|
|
$(REDIS_INSTALL) $(REDIS_CHECK_AOF_NAME) $(INSTALL_BIN)
|
|
@ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_SENTINEL_NAME)
|
|
+ @ln -sf $(REDIS_SERVER_NAME) $(INSTALL_BIN)/$(REDIS_CHECK_RDB_NAME)
|
|
--
|
|
2.9.3
|
|
|